Spanning VLANs - Multiple Sites

Unanswered Question
May 3rd, 2007
User Badges:

We are opening a new office that is roughly 20km from another core site. We plan on provisioning 2 x DS3 between sites and likely have a requirement to support the same subnets (VLANs) at both locations. Let?s say we have our core site (SA1) and new site (SA2). Core infra will be at SA1 (WAN, Inet, Servers, etc).


SA1 has 2 x 6513?s running HSRP and VTP load balancing ? core of the LAN. Has anyone spanned VLAN?s across sites like this and know of any major concerns to watch out for in doing so? One concern is delays from L3 lookups to the remote MSFC?s ? MLS should help here for any cached routes/decisions.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bmahaffey-pelco Thu, 05/03/2007 - 17:41
User Badges:

We are currently doing what you are talking about for some developers that need to see certain Layer 2 data @ our company but from the west coast to the east coast of the US with latency of 76ms and higher without any complaints.

L2TPv3 works great for this setup. Just requires advanced ip 12.4.10 and higher on the routers.


I haven't seen any issues and the tunnels have been up for over 6-7 months.

virenderj Thu, 05/03/2007 - 23:39
User Badges:

thanks for the info, it helps, we are planning to span approx 40 vlans with 450 users at new site. Is your setup is similar to what I mentioned and if you can provide some more details around actual implementation it would be great.

bmahaffey-pelco Fri, 05/04/2007 - 09:53
User Badges:

6509

trunking to router


7204

trunking on gi0/0


L2TPv3 Configuration

!

pseudowire-class vlan-xconnect

encapsulation l2tpv3

ip local interface Loopback1

ip pmtu

ip tos reflect

!

interface Loopback1

description L2TPv3 Tunnel Source

ip address 10.5.240.1 255.255.255.255

!

interface FastEthernet0/1.95

description L2TPv3 Tunnel VLAN 95

encapsulation dot1Q 95

no cdp enable

xconnect 10.5.240.3 95 pw-class vlan-xconnect


!!!!!!!


3845

trunking on gi0/0


L2TPv3 Configuration

!

pseudowire-class vlan-xconnect

encapsulation l2tpv3

ip local interface Loopback1

ip pmtu

ip tos reflect

!

interface Loopback1

description L2TPv3 Tunnel Source

ip address 10.5.240.3 255.255.255.255

!

interface FastEthernet0/1.95

description L2TPv3 Tunnel VLAN 95

encapsulation dot1Q 95

no cdp enable

xconnect 10.5.240.1 95 pw-class vlan-xconnect


http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s23/l2tpv3.htm


You can either use GRE or L2TPv3, GRE seems a better fit for you than L2TPv3.


GRE is easier to configure also.

http://www.cisco.com/en/US/tech/tk827/tk369/tk287/tsd_technology_support_sub-protocol_home.html

j.schouwenburg Thu, 05/10/2007 - 12:01
User Badges:

Can you explain how to use gre for l2 trunking? I did not know this was possible other than using bridging.

jiangu Thu, 05/10/2007 - 22:10
User Badges:

Wouldn't simple BCP configuration achieve what you want to do?

Actions

This Discussion