Master/Slave Synch Problem

Unanswered Question
May 4th, 2007
User Badges:

Hi

After maintenance, i tried to reconnect master and slave together. For the first view, it looks quite good. Master has slave added and slave says certificate is ok and master reachable. Master can see about 1800 device in campus manager and also 1800 device in rme inventory. Slave can see also 1800 devices in campus manager but in rme there are only about 300 devices in inventory.

I tried a few things, like stop daemon and restart it again on both server. Even

reboot both server. Nothing helps.

Application is LMS 2.5.1 SP4 and solaris 9. Both serve have the same applications.


Any ideas?


Regards


Hans

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Fri, 05/04/2007 - 09:03
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Check the management setting on the slave under RME > Admin > Device Management > Device Management Settings, and make sure "Automatically Manage Devices from Credential Repository" is checked. If not, you will need to manually add devices from DCR into the slave's RME.

anywebsbb Fri, 05/04/2007 - 09:14
User Badges:

Hi Joe


It already is. I have debug files in the attachment. Maybe you can take a view on them.The debug files are from the dcr.log from the master and the slave.


Thanks


Regards


Hans



Attachment: 
Joe Clarke Fri, 05/04/2007 - 10:35
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The problem is not the master/slave sync since Campus on the slave is properly populated. The problem must be with RME on the slave. Perhaps it was not told of available devices to manage. Go to RME > Devices > Device Management > RME Devices, and see if you can add the missing devices from DCR.

anywebsbb Fri, 05/04/2007 - 10:56
User Badges:


Under RME>Devices>Device Management>RME Devices i can olny see this 300 devices. Even unter campus manager and common services.


Joe Clarke Fri, 05/04/2007 - 11:05
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Now I'm confused. You initially said that Campus Manager could see 1800 devices on the slave. Is this not the case? Is this slave server integrated with ACS?

anywebsbb Fri, 05/04/2007 - 11:18
User Badges:

Sorry for confusing you. When i move to campus manager>administration on the slave server. i can see 1800 under device discovery. But when i move on rme on the slave server under Device>Device Management>RME Devices i can select from serveral sources. e.g common services, campus manager master, campus manager slave, rmr master and rme slave. For adding the devices i choose for e.g. common services. The page get loaded and brings back how many decives

would be added. Then i can this 300 devices. Same for campus manager.

Joe Clarke Fri, 05/04/2007 - 11:28
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This is what I suspected. Your master (i.e. ilmsos01) DCR only has 268 devices. The rest of the 1800 you see under Device Discovery must be unreachable.

Joe Clarke Fri, 05/04/2007 - 11:25
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Okay, the 1800 under discovery may be misleading. Device Discovery will only send reachable devices into DCR. While the number will say 1800, when you click on it, you may only see 300 devices in the list of 1800 that are reachable. Only those would then be sent to DCR.


So for troubleshooting this problem, pick one device that shows up under Common Services > Device and Credentials > Device Management > [email protected] that does NOT show up in RME on the slave server.


Then go to RME > Devices > Device Management > RME Devices on the slave, and click the Add Devices button. In the resulting window, you should see ONLY [email protected]. Does the missing device show up there? If so, try adding it to the slave RME.

anywebsbb Fri, 05/04/2007 - 11:48
User Badges:

[email protected] is the nmae of the slave server.Under Campus Manager>Device Discovery on the slave i see about 1800 device that are reachable. See also attachment.



Joe Clarke Fri, 05/04/2007 - 11:58
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Okay, back to my question of ACS. Is this slave server integrated with ACS?


Also, what do you see when you click the Add Device button under RME Devices on the slave server? How many devices are in the CS group there?

anywebsbb Fri, 05/04/2007 - 12:05
User Badges:

Sorry. Slave is not integrated with ACS. In the CS group are 268 Devices.

Joe Clarke Fri, 05/04/2007 - 12:08
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Okay, try this, turn the DCR slave server back into a standalone server, then restart dmgtd. Then recreate the slave relationship. Keep DCR debugging enabled on the slave. Then, if things still don't look right, pick ONE device that is showing up on the master in DCR that is not in the slave's RME, and trace that device through the logs.

anywebsbb Fri, 05/04/2007 - 13:22
User Badges:

Okay. Slave has now 400 devices. What do you exactly mean with trace that device through the logs.


Joe Clarke Fri, 05/04/2007 - 14:11
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Pick one device that is missing from the slave RME server, but is in the master DCR, and find it in the DCR logs. Look to see if there are any errors pertaining to that device.

anywebsbb Tue, 05/15/2007 - 06:47
User Badges:

Hi Joe


Customer did a few days later an add device. At this moment there were more than 1800 devices.

So since then we can see on the master and slave

rme nearly the same count of devices.


Thanks for help.


Kind regards


Hans

Joe Clarke Tue, 05/15/2007 - 08:14
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

If I understand you, you're saying all is working on both the master and the slave now?

Actions

This Discussion