IOS in Read Only

Unanswered Question
May 4th, 2007

I am trying to restore the IOS on one of my 2501 routers right now, however I am having a problem with the flash not letting me write changes. I have switched the register over to 0x2142 and reloaded the router, however it will still not let me restore the IOS. I know I am missing something somewhere but I'm not sure where. Any help or tips would be great.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Bernd.Waterkamp Sat, 05/05/2007 - 03:40

> I have switched the register over to 0x2142 and reloaded the router, however it will still not let me restore the IOS.

Changing the Config-Register to 0x2142 on 2500 series tells the router to "ignore the start-up configuration". Because 2500 series run their IOS from flash, the flash is still protected - the IOS is running (and ignoring the startup-config). This config-register setting is used for password-recovery, not for IOS-Upgrades.

You need to change the config-register to 0x2101. Now the router will run a small boot-image from ROM, but not the IOS stored in the flash. Don't forget to change it back to 0x2102, after upgrading the IOS or the router will enter the helper-IOS every time!

cnliukang Sun, 05/20/2007 - 06:00

try 0x2141 (writable flash & ignore startup-config) or 0x2101(writable flash with startup-config)

phamquoccuong Wed, 05/23/2007 - 01:47


I think on 2501 you have to boot from rommon (mini IOS locate on flash)to upgrade another IOS after delete curent IOS to save place for one new. Try it! Good luck!

Cuong Pham.

opteronguy Thu, 05/24/2007 - 12:13

Arg! Ok so I have set the register to 2101 and to 2141 with no luck. I've noticed that the router is telling me "8192K bytes of processor board System Flash (Device not programmable)." Now correct me if I am wrong, but this doesn't look good. I upgraded the the flash from 4mb to 8mb and was looking to restore the IOS to it, however I'm getting hosed!

Also, thanks for the help so far!

opteronguy Sun, 05/27/2007 - 08:08

Thanks for the link. It looks like this is the problem, as my Bootrom version is 9.14. However I can't get an updated version from Cisco. Any ideas on what to do next?

steven.washington Fri, 06/08/2007 - 09:04

Your 1st message stated you were trying to restore the IOS, plus you upgraded the flash from 4MB to 8MB. Since you appear to have an issue with the boot ROM, I suggest you remove the new flash (revert back to original 4MB). Determine if the IOS you are trying to load meets space requirements for 4MB and if so, you can proceed.

opteronguy Sat, 06/09/2007 - 10:33

Yes I could do this without a problem. The IOS on the router with the new 8MB of ram was 9.14. I have three other routers running 12.x and the IOS is roughly 8MB in size. I was wanting to restore the 12.x to the last 2501 so that I didn't have a difference between routers while studying for my CCNA. However, if I can't update the bootrom then it looks like I am pretty much hosed into sticking with the 9.14 and digging up all the old commands for it.


This Discussion