DHCP Server not working on 1721?

Unanswered Question
May 4th, 2007

I've setup a 1721 on an adsl connection. Everything works ok except the local dhcp server. Its setup as per all the proper cisco documentation but for some reason it just will not serve addresses to client pc's.

Ive ran a dhcp debug and tried an ipconfig /renew from a client, but the router just sits there and see's no events.

ANyone got any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Amit Singh Fri, 05/04/2007 - 06:09

Did you enable " Service DHCP " in the global configuration mode. Please paste the router configuration.

-amit singh

jdinsdale Wed, 05/09/2007 - 05:01

hi Guys

Here is my config, passwords and WAN IP addresses have been removed to protect the innocent :D


version 12.3

service config

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption


hostname Router





no logging buffered

enable secret ********************


no aaa new-model


resource policy


mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef



no ip dhcp use vrf connected

ip dhcp excluded-address


ip dhcp pool HOME

import all



dns-server **************** ****************

lease infinite



no ip ips deny-action ips-interface

ip name-server

ip name-server


no ftp-server write-enable



interface ATM0

description ADSL line interface

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1



interface Ethernet0

no ip address



interface FastEthernet0

description LAN

ip address

ip access-group 101 in

ip nat inside

ip virtual-reassembly

speed auto

no cdp enable


interface Dialer1

description Connection to ADSL

ip address ***********

ip access-group 102 in

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer idle-timeout 0

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp chap hostname ****************

ppp chap password ****************

ppp pap sent-username **************** password ****************


ip classless

ip route Dialer1


ip http server

ip http authentication local

ip http secure-server

ip nat inside source list 101 interface Dialer1 overload

ip nat inside source static tcp 3389 3389 extendable

ip nat inside source static tcp 29310 29310 extendable

ip nat inside source static udp 29310 29310 extendable


access-list 100 deny ip any any

access-list 101 permit ip any




line con 0

exec-timeout 0 0

password ****************


line aux 0

line vty 0 4

privilege level 15

password ****************

login local

transport input telnet ssh



Richard Burts Wed, 05/09/2007 - 05:05


I believe that the problem is the access list which is applied inbound on the FastEthernet interface:

access-list 101 permit ip any

The problem is that the DHCP request from the client has source address of and this is not permitted by your access list. If you add a permit for host I think that you will see DHCP work.



royalblues Wed, 05/09/2007 - 05:48

Add either of the following to your access-list

as suggested by Rick

access-list 101 permit ip host host

A better option would be to use the below

access-list 101 permit udp any any eq 67

access-list 101 permit udp any any eq 68

Try this and let us know how it goes

HTH, rate if it does


jdinsdale Sat, 05/12/2007 - 09:14

Hi Guys

The first options works, thanks!

Ive not tried the second option, but will consider that if i fix the other issue ive been having...

Which is that the router seems to drop the adsl connection regylarly, almost hourly. Ive rebuild a new config using SDM and also upgraded to the latest IOS, but nothing seems to fix the issue.

I know my line is ok as my old cheapy router stays connected forever pretty much.

Is there a chance the WIC is faulty?


This Discussion