Weird Catalyst IP routing issue

Unanswered Question

We have a network comprised of a Cisco 3845 router, Catalyst 3750 and 2950 switches connected to a WAN (See attached PDF).


The issue we are experiencing (I wouldn't call it a problem) is the Catalyst 2950 seems to ignore the IP DEFAULT-GATEWAY statement completely (Yes, I know it's a layer 2 switch). I can ping the remote node from the 2950 with or without the default-gateway statement in the config. In fact I can ping the remote node with the default-gateway statement pointing at a completely invalid IP address. The correct default gateway should point at the Ethernet interface of the WAN router.


Is this normal behavior for these switches. Can someone explain why this works in this fashion.


An help would be appreciated.


...Mike...

[email protected]



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sundar.palaniappan Fri, 05/04/2007 - 13:16
User Badges:
  • Green, 3000 points or more

Mike,


It's a strange behavior but true. I found this out a few days ago when I responded to a post on Netpro stating that this couldn't be possible. However, when I tested the same in my lab yes, indeed the layer2 catalyst switch was getting to remote networks with no default gateway set.


I am guessing the behavior may have changed with the newer code. What probably has got to happen the switch would ARP for any remote network and the router, if there's one, on the segment would respond with proxy ARP to the switch and that's how things start flowing.


HTH


Sundar

glen.grant Fri, 05/04/2007 - 15:25
User Badges:
  • Purple, 4500 points or more

Are you pinging from the console port or from a pc attached to the switch ? If its a pc attached to the switch the default gateway statement on the switch has no bearing whatsoever on how a pc attached to it is routed , the pc nic has to have the correct default gateway to get off the subnet . If you are on the console of the switch and you say you can ping anywhere even though the statement is incorrect then you probably have proxy arp turned on on the layer 3 routing device for that subnet . This should not be turned on if it is not needed . Use the no ip proxy arp command to turn it off and I bet you cant ping anymore with the incorrect default gateway. Do a "show ip interface" command on the layer 3 interface to see if proxy arp is enabled.

Actions

This Discussion