No Native vlan mismatch in 2950

Unanswered Question
May 7th, 2007
User Badges:

Hi,


Can anyone provide any inputs regarding the below problem.


A 6509 with the CATos 8.2(1) is connected to 2950 with the IOS 12.1(22)EA4.


We are getting the below error in log in 6509

2007 Apr 26 02:42:52 GMT+8 +08:00 %CDP-4-NVLANMISMATCH:Native vlan mismatch detected on port 7/3


But not getting any native vlan mismatch in 2950. My question is why the log is not coming in 2950.


Note: both the switches are running the CDP v2. so there is no cdp version mismatch


The configurations are as follows.


6509

-------------


****************** show port ******************


* = Configured MAC Address


Port Name Status Vlan Duplex Speed Type

----- -------------------- ---------- ---------- ------ ----------- ------------

7/3 switch2 Fa0/9 connected 304 full 100 10/100BaseTX


****************** show vlan ******************


VLAN Name Status IfIndex Mod/Ports, Vlans

---- -------------------------------- --------- ------- ------------------------

304 Extension-VLAN active 382 7/3



****************** show cdp neighbors detail ******************


Port (Our Port): 7/3

Device-ID: switch2.<removed>

Device Addresses:

IP Address: <removed>

Holdtime: 128 sec

Capabilities: SWITCH IGMP

Version:

Cisco Internetwork Operating System Software

IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA4, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2005 by cisco Systems, Inc.

Compiled Wed 23-Mar-05 17:25 by yenanh

Platform: cisco WS-C2950-24

Port-ID (Port on Neighbors's Device): FastEthernet0/9

VTP Management Domain: unknown

Native VLAN: 1 (Mismatch)

Duplex: full

System Name: unknown

System Object ID: unknown

Management Addresses:

IP Address: <removed>

Physical Location: unknown



2950

------------------------------


------------------ show run --------------------


interface FastEthernet0/9

speed 100

duplex full

!


------------------ show vlan ------------------




VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4

Fa0/5, Fa0/6, Fa0/7, Fa0/8

Fa0/9, Fa0/10, Fa0/11, Fa0/12

Fa0/13, Fa0/14, Fa0/15, Fa0/16

Fa0/17, Fa0/18, Fa0/19, Fa0/20

Fa0/21, Fa0/22, Fa0/23, Fa0/24



------------------ show cdp neighbors ------------------



Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone


Device ID Local Intrfce Holdtme Capability Platform Port ID

switch1

Fas 0/9 133 T S I WS-C6509 7/3



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bjornarsb Mon, 05/07/2007 - 05:29
User Badges:
  • Bronze, 100 points or more

Hi,


Port fa0/9 on your 2950 is not in trunk mode. :)


HTH


Regards,

Bjornarsb

ankbhasi Mon, 05/07/2007 - 05:43
User Badges:
  • Cisco Employee,

Hi Friend,


Can you paste the port config information of 6509 switch? Only for the port which is connected o 2950 switch?


Also paste the output of "sh int fa0/9 switchport" from 2950 switch.


I believe 2950 interface is in dynamic desirable state which is trying to form a trunk which is not the case with 6509 switch port.


Regards,


Ankur

sudiptapaul Mon, 05/07/2007 - 16:27
User Badges:


----------Port config in 6509 -----------------


set vlan 304 7/3

set trunk 7/3 off negotiate 1-1005,1025-4094

set spantree bpdu-guard 7/3,7/7 disable

set span 7/3 5/31 both inpkts disable learning enable multicast enable create


---------2950-------------------------

pofsw1102>sh int fa0/9 switchport


Name: Fa0/9


Switchport: Enabled


Administrative Mode: dynamic desirable


Operational Mode: static access


Administrative Trunking Encapsulation: dot1q


Operational Trunking Encapsulation: native


Negotiation of Trunking: On


Access Mode VLAN: 1 (default)


Trunking Native Mode VLAN: 1 (default)


Voice VLAN: none


Administrative private-vlan host-association: none


Administrative private-vlan mapping: none


Administrative private-vlan trunk native VLAN: none


Administrative private-vlan trunk encapsulation: dot1q


Administrative private-vlan trunk normal VLANs: none


Administrative private-vlan trunk private VLANs: none


Operational private-vlan: none


Trunking VLANs Enabled: ALL


Pruning VLANs Enabled: 2-1001


Capture Mode Disabled


Capture VLANs Allowed: ALL


Protected: false


Appliance trust: none



sudiptapaul Mon, 05/07/2007 - 18:35
User Badges:

Yahh..you are correct but the CDP information message for native vlan mismatch should appear on both....right ? But its not appearing in 2950 at all...I am looking for the reason behind that.

ankbhasi Mon, 05/07/2007 - 22:23
User Badges:
  • Cisco Employee,

Hi Sudipta,


Thanks for posting the information which I requested. Now what you see is an expected behavior and the reason behind is NATIVE VLAN is a concept only on trunk ports. Your Cat6k port is a normal access port as you have configured "set trunk off" which means it is not working as an access port which results in no Native Vlan concept on this port.


2950 interface is having default mode configuration on its interface and is working in "dynamic desirable mode" which means it will try to form a trunk with default native vlan as 1 which will be carried in CDP packets and will report Native Vlan mismatch on Cat6k only because the access vlan information on cat6k does not match Native Vlan which is coming in CDP packets from 2950.


HTH


Ankur


*Pls rate all helpfull post

sudiptapaul Tue, 05/08/2007 - 09:29
User Badges:

Hi Ankur,


Thanks for ur response.


I have another similar question regarding this.


We have tested the similar scenario with other switches. Giving the details



--------------sw1(3550 48SMI Version 12.1(20)EA1a)------------------

interface FastEthernet0/4

switchport access vlan 3

switchport mode access

speed 100

duplex full

spanning-tree portfast

!


-------------- sh log -------------

*Mar 1 08:05:10.444 GMT+8: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/4 (3), with sw2 FastEthernet0/1 (1)


--------------sw2( 3548 XL Version 12.0(5)WC3b)------------------


interface FastEthernet0/1

spanning-tree portfast

!


-------------- sh log -------------


*Mar 1 08:12:23.358 PST: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/1 (1), with sw1 FastEthernet0/4 (3).


Here I am getting the message on both. Why ?


I dont have the output for sh int switchport command. Anyway in 3550 the port is in access mode. But not sure about the 3550XL. Can u pls. give any input regarding this ?

Amit Singh Tue, 05/08/2007 - 09:41
User Badges:
  • Cisco Employee,

Ports on 3548XL are static access not dynamic desirable bydefault. Ports on 3550 are dynamic desirable by default.You have set the switchport mode to static access on both the switches.


Do the following on 3550 switch:


config t

default interface fa 0/4


on 3548Xl, assign the port on a different vlan other than the default vlan. Observe the error and let us know your finding.


-amit singh

Actions

This Discussion