New VOIP system - VLAN Routing questions

Answered Question

Hello - I have a flat network (one subnet) that we are adding a VOIP system into. We are installing a 4510 Switch in the core and each of the 4 wiring closets will have one 3560-POE 48 port switch with fiber back to the core. I think I understand the use of a separate VLAN for the voice network but I'm having a hard time getting the setup of the separate subnet for the voice vlan and getting that subnet to talk to the other VLAN for configuration from the TFTP server (primary call manager). The 4510 has a primary and secondary supervisor engine. The Primary and secondary call managers are on the data subnet. Can someone point me in the right direction for getting the VLANs and Routing information correct? The ports on the switches will need to run multiple vlans since the computers on the network will hook into the new phones. The new IP phones are mostly 7941s with a few 7911s and 7970s.


Thanks

Correct Answer by jahilnt10 about 9 years 10 months ago

You have to have Gateway in your dhcp conf to get it worked.


DHCP Server: 10.0.0.176

Subnet IP Address: 10.0.23.0

Gateway (Option 3) 10.0.23.1

Primary Start IP Address: 10.0.23.10

Primary End IP Address: 10.0.23.15

Subnet Mask 255.255.255.0

Primary TFTP Server (Option 150) 10.0.0.176

Arp Timout 300

IP Addr Lease Time 36000

Renewal (T1) 36000

Rebinding (T2) 36000


cheers,

Masood Ahmad Shah

BLOG: http://www.weblogs.com.pk/jahil/


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.9 (7 ratings)
Loading.
Amit Singh Tue, 05/08/2007 - 07:08
User Badges:
  • Cisco Employee,

Chris,


I am listing the steps that you need to do :


1. Create two separate vlan on the core switch 4510 and on all the 3560's. You can do it manually or use VTP for propogating vlans from the core to access switches.


2. Create trunk between core and all the 3560 switches.


3. Once the trunking is done, configure the 3560 switch ports to use both the Data and Voice vlan. Do this:


conf t

interface gig 0/1

switchport mode access

switchport access vlan 1 <-- Data Vlan

switchport voice vlan 2 <-- Voice vlan


4. Once the port config is done, configure SVI's on coare 4510 for both voice and data vlan


conf t

int vlan 1

ip address a.a.a.1. b.b.b.0

no shut


int vlan 2

ip address x.x.x.1 y.y.y.0

no shut


You might have to use " ip-helper address " command under the SVI interface if your DHCP server for ip phones is on a diff subnet.


HTH,

-amit singh



ankbhasi Tue, 05/08/2007 - 07:11
User Badges:
  • Cisco Employee,

Hi Friend,


First you need to create 2 vlans in your database. One you alreday have and second you can create.


Once 2 vlans are created you can verify the same using "sh vlan". After that configure your interfaces on which you will connect you ip phone as


switchport mode access

switchport access vlan

switchport voice vlan


Once you are done with this on your sup engine configure inter vlan routing


ip routing


interface vlan

ip address x.x.x.x x.x.x.x


interface vlan

ip address x.x.x.x x.x.x.x


Make sure the ip addresses which you configure on your vlan interfaces should be assigned as the gateway to respective devices in their vlan. Also make sure you configure trunk links between your 3560 switches and 4510 switch allowing only these 2 vlans.


HTH


Ankur

Ok, I have the two vlans created on my core 4510 switch. For now I am just working with that switch and will worry about the trunks to the IDFs later (if that is ok?).

I have data vlan 10 and voice vlan 23. I have my data subnet, ie. 10.0.0.0/24 and a voice subnet ie 10.0.23.0/24. I have DHCP enabled on my Cisco Call manager (ip. 10.0.0.176) to supply IP addresses (in the subnet 10.0.23.0) to the phones. Computers get their IP address from a DHCP server on subnet 10.0.0.0. I'm confused in which IP addresses to put on the VLAN interfaces? Sorry but I've not had to deal with VLANs and switch routing before so I apologize if this is somewhat elementary.


Thanks for all your help.

ankbhasi Tue, 05/08/2007 - 09:03
User Badges:
  • Cisco Employee,

Hi Friend,


As you mentioned you want vlan 10 for data in subnet 10.0.0.x/24 and vlan 23 for voice in subnet 10.0.23.x/24 you have to create 2 layer 3 interfaces on your sup engine.


Something like this


interface vlan 10

ip address 10.0.0.x 255.255.255.0


interface vlan 23

ip address 10.0.23.x 255.255.255.0

ip helper-address 10.0.0.176


HTH


Ankur


*Pls rate all helpfull post

mohammedmahmoud Tue, 05/08/2007 - 09:04
User Badges:
  • Green, 3000 points or more

Hi,


Interface vlan 10

ip address 10.0.0.1 255.255.255.0

no shut


Interface vlan 23

ip address 10.0.23.1 255.255.255.0

ip helper-address 10.0.0.176

no shut


And make sure that these IPs are the gateway of you computers and IP Phones respectively.


HTH, please do rate all helpful replies,

Mohammed Mahmoud.

Thank you much - I am learning I think!


Another questions because I'm having difficulty getting the phone to register with the call manager using dhcp. The primary call manager is in the same subnet/vlan as our data network - how does the phone (which is in a different vlan/subnet) know to use the call manager (tftp server) as its dhcp server instead of the dhcp server that our network pcs use. Again, many thanks! I am learning.


ankbhasi Tue, 05/08/2007 - 11:00
User Badges:
  • Cisco Employee,

Hi Friend,


When your IP Phones send a DHCP request on vlan 23 it will be a broadcast and will hits vlan 23 layer 3 interface on your sup engine where it will be converted to the unicast ecause of ip helper command.


Now the unicast request will be sent by vlan 23 as a source ip address and will reach the DHCP server where DHCP server will inspect the source ip address from where the request had come and when it matches the DHCP pool subnet which you might have created for voice vlan it will return the ip address form voice vlan subnet.


HTH


Ankur


*Pls rate all helpfull post

mohammedmahmoud Tue, 05/08/2007 - 11:03
User Badges:
  • Green, 3000 points or more

Hi,


The inter-VLAN routing that you've configured (interface VLAN10 and Interfac VLAN 23 - and make sure that "ip routing" is configured on the switch) will do the reachability job between the 2 VLANs.


On the Interface VLAN 23, put the IP address of the DHCP server that you want the IP Phones to use using the "ip helper-address" command. Further you can configure the DHCP to give the IP phones the tftp server ip address.


Please don't hesitate for any further questions.


HTH, please do rate all helpful replies,

Mohammed Mahmoud.

The DHCP server (in this case the primary call manager) can reside in a different subnet and vlan, correct...hence the ip helper-address command?


Also, how do I know if IP Routing is enabled on the 4510 switch. I type in IP Routing from the config line and it accepts the command but I don't see anything when I do show run.

Amit Singh Tue, 05/08/2007 - 21:06
User Badges:
  • Cisco Employee,

Yes, you are right.


IP routing is enabled by default on Cat4500 Sup engines.It should list under the " show run ". Please paste the output.


To check if it really is working, Type " show ip route " and you should see all the SVI's that you have configured on the box.


-amit singh

ankbhasi Wed, 05/09/2007 - 05:56
User Badges:
  • Cisco Employee,

Hi Friend,


Yes IP routing is enabled on your switch and your config looks perfect. I believe your IP Phones should receive an ip address now from your DHCP server.


Can you confirm the same?


Regards,


Ankur

If I leave the 7911 phone set for DHCP Enabled it wants to pull an IP address from our 10.0.0.0 subnet. It does show as being in Voice Lan 23. If I disable DHCP on that phone and set the IP Address to 10.0.23.11 (an ip in our voice subnet) I get a message "router not in subnet".


I'm thinking it is in the gateway configuration... I have our CM1 set up with IP 10.0.0.176 and have DHCP server running on that with a DHCP pool in the 10.0.23.0 subnet. Is this ok? I want the phones to get an IP from the 10.0.23.0 subnet. Our 10.0.0.0 subnet gateway is 10.0.0.254.


On VLAN 23 I have the IP helper address set to our TFTP Server (which is our CM1, 10.0.0.176). Am I missing the boat on something here? Our 4510 switch IP address is 10.0.0.175.


ankbhasi Wed, 05/09/2007 - 08:09
User Badges:
  • Cisco Employee,

Hi Friend,


Your config is fine. I believe you ip phone is connected on gig 5/2 correct? Your CM1 which is working as your DHCP server has an ip address 10.0.0.176 correct?


Also I believe whe you have configured DHCP pool for your voice subnet you also have confgured gateway to be returned as DHCP option in your DHCP server. Also want to make sure you are returning 10.0.23.1 as the gateway addres for your ip phones?


Regards,


Ankur


*Pls rate all helpfull post

Yes - the ip phone is on gi5/2. CM1 is working as the DHCP server and has an ip address of 10.0.0.176.


Here is what I have configured under the DHCP Server setting in CM1...


Host Server... 10.0.0.176

Primary TFTP Server IP Address (Option 150) 10.0.0.176.

ARP Cache Timeout 300

IP Address Lease Time 36000

Renewal (T1)Time 36000

Rebinding (T2) Time 36000



Under DHCP Subnet I have the following..


DHCP Server: 10.0.0.176

Subnet IP Address: 10.0.23.0

Primary Start IP Address: 10.0.23.10

Primary End IP Address: 10.0.23.15

Subnet Mask 255.255.255.0

Primary TFTP Server (Option 150) 10.0.0.176

Arp Timout 300

IP Addr Lease Time 36000

Renewal (T1) 36000

Rebinding (T2) 36000






ankbhasi Wed, 05/09/2007 - 08:31
User Badges:
  • Cisco Employee,

Hi Friend,


In your DHCP server configuration I do not see its returning a gateway ip address for vlan 23 which is 10.0.23.1 , I believe its option number 3.


Also can you configure one another port on your switch for "switchport access vlan 23" and connect one computer to that interface and see if that computer gets an ip address from your voice vlan subnet.


Regards,


Ankur


*Pls rate all helpfull post

ankbhasi Wed, 05/09/2007 - 08:54
User Badges:
  • Cisco Employee,

Hi Friend,


In your DHCP server you have configred option 150 to return TFTP server ip address so in same way also configure option 3 to returen router address.


I believe your CM1 is a cisco call manager which uses windows as its OS correct? then under your DHCP pool you will get an option to configure OPTIONS to be returned in DHCP packets and the way you have configured option 150 same way confoigure option 3 to return router address which will be 10.0.23.1 which you have configured on your layer 3 interface on switch.


HTH


Ankur


*Pls rate all helpfull post

ankbhasi Wed, 05/09/2007 - 09:14
User Badges:
  • Cisco Employee,

Hi Friend,


Ok I am not sure about this DHCP server but it's a standard and all DHCP server should be capable of returning ROUTER ADDRESS.


What all option numbers you see under your DHCP pool.


Also did you tried configuring one spare interafce with access vlan 23 and connecting one computer to that interface to see what subent range ip address it gets?


Regards,


Ankur


*Pls rate all helpfull post

Amit Singh Wed, 05/09/2007 - 09:24
User Badges:
  • Cisco Employee,

Ankur,


Call Manager has a builtin in DHCP server for the IP phones. You dont have to configure the DHCP on windows server.You have to configure DHCP pool in the CM itself for the phones.


Chris: What happens when you set the static IP address on your IP phone and also the gateway set as the ip address of the Vlan 23 SVI of the 4510 switch.The error that you were getting earlier states that the gateway defined on the ip phone wasnot the same as the Ip address that phone obtained. Also set the TFTP server address under the phone settings as the CM address.


-amit singh

I set the static IP on the phone to 10.0.23.11...subnet to 255.255.255.0...tftp to 10.0.0.176.... it made me put a router ip in... I put in 10.0.23.1???? I have the phone into GI5/2 which has voice vlan 23 setup. IP Address of voice vlan 23 is 10.0.23.1 & subnet 255.255.255.0. IP-Helper address is 10.0.0.176.


CM (10.0.0.176) is setup for DHCP. Option 150 is the tftp server (same..10.0.0.176).

On the phone it just says registering and never changes.


Amit Singh Wed, 05/09/2007 - 10:29
User Badges:
  • Cisco Employee,

Your IP phones is hanging up on registering that means its trying to contact the CM/TFTP. How long have you waited to see that it is not working really. The IP phone usually takes sometime to get the load/config downloaded from the TFTP server.


Your ip routing table seems to be fine. Lets try few things here.


1. Try connecting IP phone to a port which is in Vlan 1 and see if gets an IP automatically and registers to CM.


2. Try setting an IP on the IP phone whic is in the range of VLAN1 to see if it registers to the CM.


Here we want to check if we can connect contact the CM or not.


I hope that you have already set up the IP phones MAC-address under the CM IP phones list. This has to be done as the first step.


Please see the link below for adding the IP phone to a call manager.


http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_administration_guide_chapter09186a00800c2fa3.html#66566


HTH, please rate if it does.


-amit singh

If I connect the phone to a port that is just in VLAN 1 and I set the phone up for DHCP it retrieves an ip address from my data subnet (10.0.0.0) and registers just fine with call manager and I'm able to make a call to another phone set up the same.


If I leave DHCP disabled, with the IP address from subnet 10.0.0.0 and put it back on a port with VLAN 23 it sticks at registering because the vlan id on the phone goes to 23.



In doing some troubleshooting I found that when I telnet into the switch I can ping devices on both subnets. I am able to ping the callmanager/tftp server (10.0.0.176) and I can also ping the voice vlan (10.0.23.1) and phone (10.0.23.11). However, from the callmanager I cannot ping to the 10.0.23.0 network (any devices?).

Does this help?


Correct Answer
jahilnt10 Wed, 05/09/2007 - 11:52
User Badges:

You have to have Gateway in your dhcp conf to get it worked.


DHCP Server: 10.0.0.176

Subnet IP Address: 10.0.23.0

Gateway (Option 3) 10.0.23.1

Primary Start IP Address: 10.0.23.10

Primary End IP Address: 10.0.23.15

Subnet Mask 255.255.255.0

Primary TFTP Server (Option 150) 10.0.0.176

Arp Timout 300

IP Addr Lease Time 36000

Renewal (T1) 36000

Rebinding (T2) 36000


cheers,

Masood Ahmad Shah

BLOG: http://www.weblogs.com.pk/jahil/


Actions

This Discussion