VLAN configuration

Answered Question
May 9th, 2007

Hi all,

I have 6 Catalyst 2950 switches that I am planning on configuring with 5 VLANS( VTP, Trunking, logical interfaces with separate subnets have been configured on the Router). The only clarification that I need is if I have to configure each VLAN with a separate subnet and if so where do I assign the ip subnet to the VLAN?

Thanks in advance.

I have this problem too.
0 votes
Correct Answer by Richard Burts about 9 years 8 months ago

Sadik

Yes you are correct that the encapsulation command on the logical inteface does specify the ID of the VLAN. This is how the assignment of subnet to VLAN takes place.

HTH

Rick

Correct Answer by bjornarsb about 9 years 8 months ago

Hi,

The configuration you want is called router on a stick. You configure trunk on the uplink port between your switch and your router.

Then you must have trunk encapsulation on your router and its on the router you assign subnets to your subinterfaces.

On the switch you configure the same vlan on the ports that belongs to the same subnet.

In short the vlan - subnet configuration is done at your router.

HTH

Do no hesitate to post a new question if you want config examples!

Regards,

Bjornarsb

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Richard Burts Wed, 05/09/2007 - 07:41

Sadik

Yes each VLAN should be configured with a separate subnet. The place to assign the ip subnet to the VLAN is in the logical interfaces on the router.

Each 2950 switch can have a single VLAN interface active and configured with an IP address. This is done to allow the switch to be managed remotely. Generally the switch addresses are in the same subnet and it is assigned to the management VLAN.

HTH

Rick

ankbhasi Wed, 05/09/2007 - 07:49

Hi Friend,

In addition to Rick's post 2950 is a layer 2 switch so you will not be able to create multiple logical interfaces on 2950 switch. Either you need layer 3 switch like 3550 and above or router where you can create sub interfaces for multiple vlan support.

It is always good to keep all your layer 2 switches like 2950 with same vlan interface/subnet for management purpose. As Rick updated you can only have one logical interface up and running on layer 2 switch which is 2950 in your case.

HTH

Ankur

Correct Answer
bjornarsb Wed, 05/09/2007 - 07:49

Hi,

The configuration you want is called router on a stick. You configure trunk on the uplink port between your switch and your router.

Then you must have trunk encapsulation on your router and its on the router you assign subnets to your subinterfaces.

On the switch you configure the same vlan on the ports that belongs to the same subnet.

In short the vlan - subnet configuration is done at your router.

HTH

Do no hesitate to post a new question if you want config examples!

Regards,

Bjornarsb

skhirbash Wed, 05/09/2007 - 08:18

Thanks to all for the prompt and concise clarification. I was confused on how the subnet on the router corresponds to the specific VLAN, but I now know that the logical interface is assigned the subnet ip and the 802.1q encapsulation is assigned the ID number of the VLAN. I hope I am correct!

Correct Answer
Richard Burts Wed, 05/09/2007 - 08:25

Sadik

Yes you are correct that the encapsulation command on the logical inteface does specify the ID of the VLAN. This is how the assignment of subnet to VLAN takes place.

HTH

Rick

bjornarsb Wed, 05/09/2007 - 08:27

Hi,

Yes like this:

interface fastethernet2/0.20

encapsulation isl 20

ip address 10.1.20.1 255.255.255.0

ip pim dense-mode

interface fastethernet2/0.30

encapsulation isl 30

ip address 10.1.30.1 255.255.255.0

ip pim dense-mode

HTH, please rate all helpfull posts.

BR,

Bjornarsb

Amit Singh Wed, 05/09/2007 - 09:31

In addition to Bjornarsb's post this what you need to do for 802.1q encapsulation

Router

interface FastEthernet0/0

no ip address

duplex auto

speed auto

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.10.10.15 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/0.16

encapsulation dot1Q 16

ip address 172.16.16.1 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/0.99

encapsulation dot1Q 99

ip address 192.168.180.50 255.255.255.0

no snmp trap link-status

Switch

interface FastEthernet0/23

switchport mode trunk

no ip address

interface Vlan1

ip address 10.10.10.12 255.255.255.0

no ip route-cache

-amit singh

Actions

This Discussion