Question Regarding switchport trunk

Answered Question
May 9th, 2007
User Badges:

All, recently I inherited the switches at our facility. Upon review of the configs, I found this config for a port that is connected to a ISCSI SAN:


switchport access vlan 100

switchport trunk pruning vlan 100

switchport mode access

flowcontrol receive desired

spanning-tree portfast


My question is: Is it incorrect to have "switchport trunk pruning vlan 100" on this interface?


Thanks

Correct Answer by jahilnt10 about 9 years 11 months ago

no never for access port...


You can remove all settings belongs to trunk port and add


switchport mode access

span..tree portfast


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Edison Ortiz Wed, 05/09/2007 - 12:12
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

That port current mode is 'access'. The pruning command is not doing anything at the moment.


If you were to change the command


switchport mode access

to

switchport mode trunk


All Vlans will be allowed on this trunk except vlan 100.


You can verify more information on the switchport by typing


show int fa0/0 switchport


replace fa0/0 with the interface and port number.


rwamstutz Wed, 05/09/2007 - 12:19
User Badges:

but, I dont want the port to be a trunk port, if its an end user port, correct? Based on the config, how does the port know to be in trunking mode or access? Should a end user port ever be in trunking mode?

Correct Answer
jahilnt10 Wed, 05/09/2007 - 12:25
User Badges:

no never for access port...


You can remove all settings belongs to trunk port and add


switchport mode access

span..tree portfast


mohammedmahmoud Wed, 05/09/2007 - 12:26
User Badges:
  • Green, 3000 points or more

Hi,


You are right, a user port should always be an access port, the "switchport trunk pruning vlan 100" command has no meaning here, and thus it has no effect here.


You only need:


switchport mode access

switchport access vlan 100

spanning-tree portfast


P.S Please see my reply on your other post "Another Question regarding Switchport trunk, mode, and Trunk"


HTH, please do rate all helpful replies,

Mohammed Mahmoud.

Edison Ortiz Wed, 05/09/2007 - 12:31
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

The config you posted clearly says to place the port in 'access' mode with the command


switchport mode access


by default, a layer 2 switchport is set to dynamic desirable (3550 use dynamic auto).


Dynamic desirable will trunk automatically if the other devices replies to DTP packets, if it doesn't the port will be set to access mode.


For user connection, you don't need trunking. Access mode is the recommended setting.


Actions

This Discussion