2800 series with pots lines, can't call in/out via voip

Unanswered Question
May 9th, 2007
User Badges:

I have a cisco 2800 series router at a remote site with 4 pots lines in an FXO card, one main number (config below). After a power surge users at that site can no longer dial out from their phones both internally and externally and people cannot call into the main number, users at other sites can complete a call to the affected users. When calling the main number configured on the router it rings with no answer.


trunk group analog

hunt-scheme longest-idle

!

voice-card 0

no dspfarm

!

voice call send-alert

voice call carrier capacity active

voice rtp send-recv

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

codec preference 3 g729br8

!

voice class h323 1

h225 timeout tcp establish 3


class-map match-any Video

match access-group 152

class-map match-any Voice

match ip rtp 16383 16383

match access-group 151

!

policy-map voice_video_qos

class Video

priority 384

class Voice

priority 768

class class-default

fair-queue

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$

ip address 192.168.XX.XX 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.XX.XX

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

!

control-plane

!

voice-port 0/1/0

trunk-group analog

no comfort-noise

connection plar XXXXXXX

description XXXXXXXXXX

caller-id enable

!

voice-port 0/1/1

trunk-group analog

no comfort-noise

connection plar XXXXXXX

description XXXXXXXXXX

caller-id enable

!

voice-port 0/1/2

trunk-group analog

no comfort-noise

connection plar XXXXXXXXXX

description XXXXXXXXXX

caller-id enable

!

voice-port 0/1/3

trunk-group analog

no comfort-noise

connection plar XXXXXXX

description XXXXXXXXXX

caller-id enable

!

dial-peer voice 1 pots

trunkgroup analog

incoming called-number .

direct-inward-dial

!

dial-peer voice 911 pots

trunkgroup analog

destination-pattern 911

progress_ind setup enable 3

progress_ind alert enable 8

direct-inward-dial

forward-digits all

!

dial-peer voice 411 pots

trunkgroup analog

destination-pattern 411

progress_ind setup enable 3

progress_ind alert enable 8

direct-inward-dial

forward-digits all

!

dial-peer voice 8888 pots

trunkgroup analog

destination-pattern 8T

progress_ind setup enable 3

progress_ind alert enable 8

direct-inward-dial

!

dial-peer voice 810 pots

trunkgroup analog

destination-pattern 81..........

progress_ind setup enable 3

progress_ind alert enable 8

direct-inward-dial

forward-digits 11

!

dial-peer voice 807 pots

trunkgroup analog

destination-pattern 8[2-9]......

progress_ind setup enable 3

progress_ind alert enable 8

direct-inward-dial

!

dial-peer voice 8411 pots

trunkgroup analog

destination-pattern 8411

progress_ind setup enable 3

progress_ind alert enable 8

direct-inward-dial

forward-digits 3

!

dial-peer voice 8911 pots

trunkgroup analog

destination-pattern 8911

progress_ind setup enable 3

progress_ind alert enable 8

direct-inward-dial

forward-digits 3

!

dial-peer voice XXXXXXX voip

description XXXXXXXXXX Main number

destination-pattern XXXXXXX

progress_ind setup enable 3

voice-class codec 1

session target ipv4:10.30.X.XX

incoming called-number .

dtmf-relay h245-alphanumeric

ip qos dscp cs5 media

no vad

!

!

call-manager-fallback

secondary-dialtone 8

max-conferences 8 gain -6

transfer-system full-consult

limit-dn 7910 2

limit-dn 7935 1

limit-dn 7940 2

limit-dn 7960 4

timeouts interdigit 5

timeouts busy 5

timeouts ringing 20

ip source-address 192.168.XX.XX port 2000

max-ephones 30

max-dn 60

access-code pri 8T direct-inward-dial

!

What may be wrong with this config that would cause these issue(s)?


Is there a way I can find out if it is the FXO card?


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Wed, 05/09/2007 - 13:58
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


can you have some plug a regular phone in place of router and see if it rings ?


I haven't really looked at your config but if it was working before there is no reason it should not work now.


Hope this helps, please rate post if it does!

kelvin.blair Wed, 05/09/2007 - 19:06
User Badges:
  • Silver, 250 points or more

Do a show log and verify that you do not have any DSP errors. I have seen DSP's go bad after a power surge. Although it?s not a common occurrence, it has happened twice in my case.



jmrosenfeld Thu, 05/10/2007 - 04:17
User Badges:

Thanks, the log shows there are some dsp errors on the lines though I'm not sure exactly what the error means - is it a hardware problem on the router or an issue with the pots lines?


*May 9 19:51:28.247: %C5510-1-C5510_CHPI_ERROR: cHPI error for pa_bay 0 pump 0 dsp 1.

*May 9 19:51:28.571: %FLEX_DNLD-3-ERROR_FIRMWARE_DNLD: DSP firmware download fails for slot 0 dsp_id 0

*May 9 19:51:39.435: %C5510-1-C5510_CHPI_ERROR: cHPI error for pa_bay 0 pump 0 dsp 1.

*May 9 19:51:39.763: %FLEX_DNLD-3-ERROR_FIRMWARE_DNLD: DSP firmware download fails for slot 0 dsp_id 0

*May 9 19:51:50.639: %C5510-1-C5510_CHPI_ERROR: cHPI error for pa_bay 0 pump 0 dsp 1.

*May 9 19:51:50.963: %FLEX_DNLD-3-ERROR_FIRMWARE_DNLD: DSP firmware download fails for slot 0 dsp_id 0

*May 9 19:52:01.831: %C5510-1-C5510_CHPI_ERROR: cHPI error for pa_bay 0 pump 0 dsp 1.

*May 9 19:52:02.155: %FLEX_DNLD-3-ERROR_FIRMWARE_DNLD: DSP firmware download fails for slot 0 dsp_id 0


I found the following info on the errors:


Explanation An error has occurred during initialization of the DSP in the specified slot with the application firmware.


Recommended Action Power down, reinsert the port module, and reboot. If this message recurs, copy the error message exactly as it appears on the console or in the system log, contact your Cisco technical support representative, and provide the representative with the gathered information.


kelvin.blair Thu, 05/10/2007 - 05:11
User Badges:
  • Silver, 250 points or more

The errors look the same as what I was getting. Two things you can do.


The first is to do what the Explanation above stated.


The second is to get anther DSP Firmware and apply to the flash in the router. Reboot the router and let the new firmware download to the DSP.


If both these options do not work, you need to get a RMA on the dsp's they are bad.

jmrosenfeld Thu, 05/10/2007 - 07:25
User Badges:

Go it.


Where can I get the DSP firmware and how is it applied to router? Is this just a normal firmware update?

kelvin.blair Thu, 05/10/2007 - 07:59
User Badges:
  • Silver, 250 points or more

You can get dsp firmware from TAC or upgrade the IOS. Generally newer IOS has new dsp firmware builtin

Actions

This Discussion