How to configure a new interface on a router

Unanswered Question
May 10th, 2007


I hope someone can help me. I've got a 3640 router that has the following config

interface FastEthernet0/0

ip address

no ip redirects

ip route-cache same-interface

ip route-cache flow

no ip mroute-cache

speed 100


standby 1 timers 5 15

standby 1 preempt

standby 1 authentication xxxxx

standby 1 ip


interface FastEthernet0/1

ip address

no ip redirects

ip route-cache flow

speed 100



router ospf 1



redistribute connected subnets route-map PRIVONLY

redistribute static subnets

redistribute rip metric 120

network area 0

network area 0

network area 0

default-information originate


router rip

version 2

redistribute ospf 1


default-metric 30


What I'd like to do is create a new VLAN on the same connection that is coming off of fa 0/0 so instead of just I want to have a

My question is how can I change the above config to accomodate a new vlan? I think I need to create subinterfaces, but I was worried about what it might affect given the above config. Also on the switch port do I need to convert the port to a trunk link?

Thanks in advance


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Jon Marshall Thu, 05/10/2007 - 04:06

Hi Dan

Yes you will need to use subinterfaces and the switchport will need to be a trunk port.

For arguments sake let say is vlan 10 is vlan 20

int fa0/0.10

encapsulation dot1q 10

ip address

+ other config you have

int fa0/0.20

encapsulation dot1q 20

ip address 10.32.x.x

+ additonal config you need

As alreay said you need to convert your switchport to a trunk port.




This Discussion