STUMMPED W/ A SUP32 <------ help!

Unanswered Question
May 10th, 2007

I recently tried to upgrade a Sup32 (6500 chassis) from CatOS to IOS. I'm a Cisco rookie (still green, fresh out of college), and I ran into some issues. The IOS image that I copied to the bootdisk is 50MEGS. The image also ended up being corrupt (I'm not in front of it right now, but i know I got several error when I punched in "BOOT bootdisk: s3223-advipservicesk9_wan-mz.122-18.sxf8.bin". I get a 0x0 error with a "bad magic number" (im not in front of the sup and i dont quite remember the exact error). So here's the story, I believe the image is corrupt and I want to recopy it. Sounds easy enough right? Wrong. I am stick in rommon mode where i have full XMODEM transfer capability, but NO WAY (that i know of) to squeeze the bootdisk (flash), to make room for the new massive image. The Sup32 only has 64MB (?) onboard flash. I tried to use disk0 (flash card) but i am getting errors that the device in unknown (when punching in a dir disk0:). If anyone can help me it would be GREATLY appreciated. Now in rommon, i also hit the confreg command and played with all the settings. Now my SET values are all outta wack. Is there anyway to restore to factory settings or can someone tell me the default SET (rommon command) setting so I can just paste them in and call it a day? I may be doing something wrong, so ANY help would be appreciated. Thank you very much.

-Hungry Mind

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
djrickybeatz Thu, 05/10/2007 - 09:07

I came across this document while I was working on the SUP. While it is very helpful, It does not discuss the process of erasing flash (bootdisk) from ROMMON. Thank you anyway for your input.

e-dennington Thu, 05/10/2007 - 10:17

Sup32's have 256MB of bootflash not 64. I would suggest copying over a different version of IOS to the switch and in rommon mode boot to sup-bootflash:. Then you can delete the corrupt version, recopy it and change the boot variable back to the IOS you copied over (or just delete the temp IOS you loaded to get the switch booted).

Another way is to copy the IOS from a currently running sup32 (if you have one) to a flash card and boot off of disk0.

Actions

This Discussion