×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Question on VLAN for Voice and Data for the same port.

Unanswered Question
May 10th, 2007
User Badges:

All: this port config below, is an end user port 201 is for data, 246 is for voice. What is the command:

"switchport trunk native vlan 205" doing?


interface FastEthernet1/0/18

switchport access vlan 201

switchport trunk encapsulation dot1q

switchport trunk native vlan 205

switchport mode dynamic desirable

switchport voice vlan 246

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast


Also, if a port had a config like below:

interface FastEthernet1/0/18

switchport access vlan 200

switchport voice vlan 245


should there be a switchport mode access command?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ankbhasi Thu, 05/10/2007 - 09:06
User Badges:
  • Cisco Employee,

Hi Friend,


Your second config looks better


interface FastEthernet1/0/18

switchport mode access

switchport access vlan x <----Data Vlan

switchport voice vlan x <---- Voice Vlan


Once you configure voice vlan command on an interface you need not configure the switch interface as trunk port as voice vlan internall forms a trunk.


HTH


Ankur



rwamstutz Thu, 05/10/2007 - 09:11
User Badges:

ankur:

what does these commands do, if switchport voice and switchport access are also configured?


switchport trunk encapsulation dot1q

switchport trunk native vlan 205

switchport mode dynamic desirable

hoogen_82 Thu, 05/10/2007 - 09:28
User Badges:
  • Silver, 250 points or more

Well the switchport trunk exncapsulation dot1q can be removed of the phone is a Cisco phone, you would require it if there is a Avaya or any other phone.


Switchport mode dynamic desirable should actually go away when you configure switch mode access, since you have access vlan configured.


Ideally speaking this command is also not required:"switchport trunk native vlan 205": In 802.1Q trunking, all VLAN packets are tagged on the trunk link, except the native VLAN. The native VLAN packets are sent untagged on the trunk link. Therefore, the native VLAN should be the same on both switches configured for trunking. This way, you can deduce to which VLAN a frame belongs when you receive a frame with no tag. By default, VLAN 1 is the native VLAN on all switches.


HTH

Hoogen

ankbhasi Thu, 05/10/2007 - 09:28
User Badges:
  • Cisco Employee,

Hi Friend,


This command will form a trunk and will allow all vlan traffic where vlan 205 vlan traffic will pass the trunk untagged.


Ideally when you connect an ip phone and a computer to an ip phone the recommended configuration is


switchport access vlan

switchport voice vlan

switchport mode access


HTH


Ankur

Actions

This Discussion