Possible error in BAT 5.3(2) with CCM 4.2.3 sr1

Unanswered Question
May 10th, 2007
User Badges:

Hi!

I think, there is a bug in BAT. I tried to create a phone template for a 7971 phone. I have filled all required fields, but after pressing the "Insert" button I received "Error No." message.


After quick investigatement I have found, that the problem is in the file called UserPhoneConfig.asp. The problematic function is updateDevice. There is an external function call:

rsInsertFromFile.phoneTemplate(strOldFileName, strFileName, strData, 2, strTempPath,"copy")

When the length of strData is more then 1326 symbols, this call does not work. Has anybody fixed this alredy?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dfokin Fri, 05/11/2007 - 01:08
User Badges:

Yep, this is exactly this bug. The stated workaround works for 7941G-GE phone, but does not work for 7941, because strData, created for it with all settings set to default values is large enough, to create problems with the external function call.

Moreover, when I add 7971 phone in ordinary way and then try to edit its settings, I receive another error. I think, this problem is caused by the same thing.

uldericonucci Mon, 10/01/2007 - 01:40
User Badges:

I'm getting the same problem with 7941 templates and BAT 5.3(0.1) (Callmanager 4.3(1)SR1A). When I try to insert the new template i get the error No. message window.

Someone found a workaround?




dfokin Mon, 10/01/2007 - 02:22
User Badges:

Have you tried to install latest update to your CCM version?

uldericonucci Tue, 10/02/2007 - 00:49
User Badges:

Sure. CCM 4.3(1) SR1A (29-AUG-2007) using OS 2003.1.2aSR3 (18-SEP-2007). Stil the problem exists.


pklos Tue, 10/02/2007 - 04:32
User Badges:
  • Silver, 250 points or more

Did you install new BAT version after paching CCM?


--

regards,

pk

Actions

This Discussion