isdn not hanging up issue

Unanswered Question
May 10th, 2007
User Badges:

I have the following:

1 x MPLS (Provider) router

1 x Layer 3 3750 stack

1 x ISDN router


Both routers are connected to the stack and are in the same vlan. they are all running EIGRP 100.


The MPLS router injects a gateway of last resort

Gateway of last resort is 10.45.x.x to network 0.0.0.0

If the MPLS router stops advertising the ISDN router is setup to dial.

ISDN setup as follows:

access-list 101 deny eigrp any any

access-list 101 deny ip any host 255.255.255.255

access-list 101 permit ip any any

access-list 10 permit 0.0.0.0

dialer-list 1 protocol ip list 101

route-map weighted_default_only permit 10

match ip address list 10

router eigrp 100

redistribute connected

redistribute static metric 64 1000 255 1 1500 route-map weighted_default_only

no passive-interface FastEthernet0/0

passive-interface Dialer1

network 10.0.0.0

no auto-summary

!

interface BRI1/0

description Local Service Number 0x-xxxxxxx

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink

!

interface BRI1/1

description Local Service Number 0x-xxxxxxx

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink


!

interface Dialer1

description Backup Link to hostname (Dialer 2)

ip address 10.45.x.x 255.255.255.252

encapsulation ppp

dialer pool 1

dialer remote-name hostname

dialer idle-timeout 300

dialer string 095801293

dialer load-threshold 1 either

dialer-group 1

ppp authentication chap callin

ppp chap hostname hostname

ppp chap password 7 XXXXX!!!!!!

ppp multilink

!

Gateway of last resort is 10.45.x.x to network 0.0.0.0


172.19.0.0/32 is subnetted, 1 subnets

D EX 172.19.4.123 [170/2502656] via 10.45.x.x, 2d16h, Vlan5

10.0.0.0/8 is variably subnetted, 35 subnets, 8 masks

D EX 10.0.0.0/8 [170/2502656] via 10.45.x.x, 2d16h, Vlan5

D EX 10.45.y.y/29 [170/2502656] via 10.45.x.x, 08:01:10, Vlan5

D EX 10.9.y.y/24 [170/2502656] via 10.45.x.x, 2d16h, Vlan5

D EX 10.45.y.y/26 [170/2502656] via 10.45.x.x, 2d16h, Vlan5

D EX 10.45.y.y6/30 [170/2502656] via 10.45.x.x, 08:01:10, Vlan5

D EX 10.45.y.y/26 [170/2502656] via 10.45.x.x, 2d16h, Vlan5

D EX 10.45.y.y/26 [170/2502656] via 10.45.x.x, 2d16h, Vlan5

D EX 10.45.y.y/26 [170/2502656] via 10.45.x.x, 2d16h, Vlan5

C 10.45.y.y/25 is directly connected, Vlan20

D EX 10.45.y.y/26 [170/2502656] via 10.45.x.x, 2d04h, Vlan5

D EX 10.45.y.y/26 [170/2502656] via 10.45.x.x, 2d16h, Vlan5

D EX 10.45.y.y/26 [170/2502656] via 10.45.x.x, 2d16h, Vlan5

D*EX 0.0.0.0/0 [170/2502656] via 10.45.x.x, 2d14h, Vlan5


Issue:

When the MPLS router drops, ISDN dials. when the MPLS router comes back up everything routes through it due to its better metric but the ISDN doesn't hangup--annoying. When ISDN dials a static route becomes present in the routing table with an AD of 240---much higher than the D*EX 0.0.0.0/0 [170/2502656] via 10.45.x.x, 2d14h, Vlan5

How can I get ISDN to hangup, once the MPLS router comes backup? Any ideas?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Thu, 05/10/2007 - 15:32
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


the ISDN doesn't disconnect because the dialer sees interesting traffic, please see the following document how access-list so that routing hello, etc, do not reset the idle timer.

http://cisco.com/en/US/tech/tk801/tk133/technologies_configuration_example09186a00800943ad.shtml


Hope this helps, please rate post if it does!

sundar.palaniappan Thu, 05/10/2007 - 18:39
User Badges:
  • Green, 3000 points or more

When ISDN doesn't hang up execute the command 'show dialer' and that would show the source and destination IP that kept the link up. Based on that you should be able to fix the issue.


HTH


Sundar

Richard Burts Thu, 05/10/2007 - 18:51
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Sidney


I believe that Sundar is on the right track in identifying what is keeping the ISDN up is that there is "interesting" traffic. The configuration posted includes the definition of "interesting" traffic:

dialer-list 1 protocol ip list 101

access-list 101 deny eigrp any any

access-list 101 deny ip any host 255.255.255.255

access-list 101 permit ip any any

So "interesting" traffic excludes eigrp and broadcast traffic and includes everything else. You need to identify what that other traffic is and to address that in access list 101.


HTH


Rick

andersonsidney Tue, 07/10/2007 - 18:11
User Badges:

shall do, but a quick question. If EIGRP is routing everything through the other router and the static that get stuck has an admin of 240, what would be routed across the link and why?

Richard Burts Thu, 07/12/2007 - 10:14
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Sidney


Knowing some details about the static route would make it easier to answer your question. I can not tell from your description whether the static route with admin distance of 240 is a default route or is something different. The behavior you describe almost makes me think it might be something different.


In general static routes with high admin distance like this are floating static routes. The idea of the floating static route is that it is a static route configured with a higher then default admin distance. The default admin distance for static routes is 1 which makes them very believable. If you have a static route with default admin distance of 1 then it is better than any dynamic route for the same prefix. When you configure the static with a higher admin distance that allows the dynamic route to be used when it is available and allows the static route to be used when the dynamic route is not available. And when the dynamic route is available again it should go into the routing table and the static should float away.


Your description sounds like the floating static route is not getting out of the way when the EIGRP route comes back. If you can provide some details about the static route (and maybe a config of the router) it might help us to figure out what is happening.


HTH


Rick

andersonsidney Mon, 07/23/2007 - 14:33
User Badges:

Here is the amended router config. I hope this is enough info.


When EIGRP adverts stop from the telco router my ISDN dials, and I get the following. which shows the ISDN route in the routing table, but notice that when I do a traceroute everything is routing through the better metric on the MPLS router(as it should, but the static route doesn't drop and the ISDN stays connected until I clear the ip route 0.0.0.0. then EIGRP advertises the default route and ISDN hangs up.




Attachment: 
smothuku Fri, 07/13/2007 - 02:03
User Badges:
  • Silver, 250 points or more

Hi Sydney ,


You need to add floating static for destination with di1 as next hop.


I mean ip route destination subnet next-hop 240.


and below access-list


access-list 100 deny eigrp any any

access-list 100 permit ip any any

dialer-list 1 protocol ip list 100


It should work ...isdn must disconnect as soon as mpls router comes up.


Note : Floating static comes into picture once the static route goes off....means we cann't see floating static route in routing table until unless staticd route for that particular destination goes off.....


Pl check the below link where isdn is backup for eigrp...


http://www.cisco.com/en/US/tech/tk713/tk237/technologies_configuration_example09186a00800a3b77.shtml


Cheers :

satish

vinay_verma80 Sun, 07/15/2007 - 14:59
User Badges:

hi


plz check ur redistrubute command


anyhow if u r not using isdn for any this but for backup



us the "backup " command , so their will no need for static routes

:-)


plz rate if u like


regards




paolo bevilacqua Sun, 07/15/2007 - 17:10
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

[as already mentioned in another thread]


The problem with 'backup' command is thats it doesn't make the line go active when for example there is a 'black hole' in the network, or the FR PVC status is not reliable, or many other situations that dictates the use of floating static routes for a professional design.


Richard Burts Sun, 07/15/2007 - 17:30
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Paolo


I am not sure what other thread you are referencing, but I agree that in recent practice the use of floating static routes for redundancy is more preferred than the backup command. I am also not sure of the logic when Vinay says that backup command removes the need for static routes. The backup command only controls the conditions in which the backup interface will become active and as far as I know has no change in the routing logic.


HTH


Rick

paolo bevilacqua Mon, 07/16/2007 - 00:04
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Well, in fact once "backup interface" successfully triggers up an interface that is configured for dynamic routing, here we have the situation Vinay was referring. No need for floating static routes.


Anyway as we were saying the "backup interface" is very limited. Here is another reason: you cannot dial into an interface configured as "backup". Thing that you want to do for testing or other purposes. With floating static, it is perfectly possible.



Actions

This Discussion