problems with Dial-up on 1721 AUX port to MS-RAS

Unanswered Question
May 11th, 2007
User Badges:

I'm trying to configure a 1721 using the AUX port with external USR modem to dial up to a MS-RAS server as a backup. Everything dials fine and it goes through the necessary modm handshake etc.. but my async interface just disconnects/resets for somereason. Not sure if I'm missing something in my config or I have something misconfigured. Any assistance would be appreciated. I have pasted the config below with some debug outputs.


memory-size iomem 20

ip subnet-zero

!

chat-script DIALOUT ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 120 CONNECT \c

modemcap entry MY_USR_MODEM:MSC=&F1S0=1

!

!

!

interface FastEthernet0

ip address 10.100.33.1 255.255.255.0

no keepalive

speed auto

!

interface Serial0

ip address 192.168.200.1 255.255.255.0

!

interface Serial1

no ip address

shutdown

!

interface Async5

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 1

async default routing

async mode interactive

ppp authentication ms-chap chap pap callout

!

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

dialer remote-name unified

dialer idle-timeout 300

dialer wait-for-carrier-time 60

dialer string xxxxxx

dialer hold-queue 10

dialer-group 1

ppp authentication ms-chap chap pap callout

ppp chap hostname xxxx

ppp chap password 0 xxxx

ppp pap sent-username xxxxx password 0 xxxx

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 Dialer1 200

no ip http server

!

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

!

line con 0

password cisco

line aux 0

exec-timeout 0 0

script dialer DIALOUT

modem InOut

modem autoconfigure type MY_USR_MODEM

transport input all

autoselect ppp

stopbits 1

speed 115200

flowcontrol hardware

line vty 0 4

login





  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
hks10 Fri, 05/11/2007 - 09:45
User Badges:

Here are some debut outputs


00:16:39: As5 DDR: rotor dialout [best] least recent failure is also most recent failure

00:16:39: As5 DDR: rotor dialout [best] also has most recent failure

00:16:39: As5 DDR: rotor dialout [best]

00:16:39: As5 DDR: Dialing cause ip (s=10.100.33.2, d=199.0.8.1)

00:16:39: As5 DDR: Attempting to dial xxxxxxxxxx

00:16:39: CHAT5: Attempting async line dialer script

00:16:39: CHAT5: Dialing using Modem script: DIALOUT & System script: none

00:16:39: CHAT5: process started

00:16:39: CHAT5: Asserting DTR

00:16:39: TTY5: Set DTR to 1

00:16:39: CHAT5: Chat script DIALOUT started

00:17:16: CHAT5: Chat script DIALOUT finished, status = Success

00:17:16: TTY5: no timer type 1 to destroy

00:17:16: TTY5: no timer type 0 to destroy

00:17:16: TTY5: no timer type 2 to destroy

00:17:16: As5 PPP: Async Protocol Mode started for 0.0.0.0

00:17:16: As5 AAA/ACCT: Using PPP accounting list ""

00:17:18: %LINK-3-UPDOWN: Interface Async5, changed state to up

00:17:18: As5 DDR: Dialer statechange to up

00:17:18: %DIALER-6-BIND: Interface As5 bound to profile Di1

00:17:18: As5 DDR: Dialer call has been placed

00:17:18: As5 PPP: Using dialer call direction

00:17:18: As5 PPP: Treating connection as a callout

00:17:38: TTY5: Async Int reset: Dropping DTR

00:17:38: TTY5: Set DTR to 0

00:17:40: %LINK-5-CHANGED: Interface Async5, changed state to reset

00:17:40: DDR: Call disconnected, 10 packets unqueued and discarded

00:17:40: As5 DDR: has total 0 call(s), dial_out 0, dial_in 0

00:17:40: %DIALER-6-UNBIND: Interface As5 unbound from profile Di1

00:17:41: TTY5: DSR was dropped

00:17:41: tty5: Modem: READY->(unknown)

00:17:42: TTY5: dropping DTR, hanging up

00:17:42: TTY5: Set DTR to 0

00:17:42: tty5: Modem: HANGUP->(unknown)

00:17:43: TTY5: cleanup pending. Delaying DTR

00:17:43: Async5: Async protocol mode stopped for 0.0.0.0

00:17:43: TTY5: no timer type 0 to destroy

00:17:43: TTY5: no timer type 1 to destroy

00:17:43: TTY5: no timer type 3 to destroy

00:17:43: TTY5: no timer type 4 to destroy

00:17:43: TTY5: no timer type 10 to destroy

00:17:43: TTY5: no timer type 2 to destroy

00:17:43: Async5: allowing modem_process to continue hangup

00:17:44: Di1: No free dialer - starting fast idle timer

00:17:45: TTY5: restoring DTR

00:17:45: TTY5: Set DTR to 1

00:17:45: %LINK-3-UPDOWN: Interface Async5, changed state to down

00:17:46: TTY5: autoconfigure probe started

00:17:46: TTY5: Modem command: --AT&F1S0=1--

00:17:47: TTY5: Modem configuration succeeded

00:17:47: TTY5: Detected modem speed 115200

00:17:47: TTY5: Done with modem configuration

00:17:50: Di1: No free dialer - starting fast idle timer

00:17:55: As5 DDR: re-enable timeout

00:17:55: As5 DDR: rotor dialout [best] least recent failure is also most recent failure

00:17:55: As5 DDR: rotor dialout [best] also has most recent failure

00:17:55: As5 DDR: rotor dialout [best]

00:17:55: As5 DDR: Dialing cause ip (s=10.100.33.2, d=199.0.8.1)

00:17:55: As5 DDR: Attempting to dial xxxxxxxxx

00:17:55: CHAT5: Attempting async line dialer script

00:17:55: CHAT5: Dialing using Modem script: DIALOUT & System script: none

00:17:55: CHAT5: process started

00:17:55: CHAT5: Asserting DTR

00:17:55: TTY5: Set DTR to 1


Wilson Samuel Fri, 05/11/2007 - 11:34
User Badges:
  • Gold, 750 points or more
  • Community Spotlight Award,

    Mobile User, July 2015

Hi,


It looks like the modem is dropping the connection, see the DSR


00:17:40: %DIALER-6-UNBIND: Interface As5 unbound from profile Di1

00:17:41: TTY5: DSR was dropped

00:17:41: tty5: Modem: READY->(unknown)

00:17:42: TTY5: dropping DTR, hanging up

00:17:42: TTY5: Set DTR to 0



Moreover I shall request you to paste output from following debugs:


1. debug modem

2. debug ppp authe


Kind Regards,

Wilson Samuel


hks10 Fri, 05/11/2007 - 11:46
User Badges:

Hi Wilson Samuel.Thanks for your reply. Below is the debug outputs for the mod/ppp auth only. I can't seem to make it out.


Router#debug modem

Modem control/process activation debugging is on

Router#de

Router#debu

Router#debug ppp au

Router#debug ppp authentication

PPP authentication debugging is on

Router#ping 199.0.8.1


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 199.0.8.1, timeout is 2 seconds:


02:44:10: CHAT5: Attempting async line dialer script

02:44:10: CHAT5: process started

02:44:10: CHAT5: Asserting DTR

02:44:10: TTY5: Set DTR to 1.....

Success rate is 0 percent (0/5)

Router#

02:44:46: TTY5: no timer type 1 to destroy

02:44:46: TTY5: no timer type 0 to destroy

02:44:46: TTY5: no timer type 2 to destroy

02:44:48: %LINK-3-UPDOWN: Interface Async5, changed state to up

02:44:48: %DIALER-6-BIND: Interface As5 bound to profile Di1

02:44:48: As5 PPP: Using dialer call direction

02:44:48: As5 PPP: Treating connection as a callout

02:45:08: TTY5: Async Int reset: Dropping DTR

02:45:08: TTY5: Set DTR to 0

02:45:10: %LINK-5-CHANGED: Interface Async5, changed state to reset

02:45:10: %DIALER-6-UNBIND: Interface As5 unbound from profile Di1

02:45:10: TTY5: DSR was dropped

02:45:10: tty5: Modem: READY->(unknown)

02:45:11: TTY5: dropping DTR, hanging up

02:45:11: TTY5: Set DTR to 0

02:45:11: tty5: Modem: HANGUP->(unknown)

02:45:12: TTY5: cleanup pending. Delaying DTR

02:45:13: TTY5: no timer type 0 to destroy

02:45:13: TTY5: no timer type 1 to destroy

02:45:13: TTY5: no timer type 3 to destroy

02:45:13: TTY5: no timer type 4 to destroy

02:45:13: TTY5: no timer type 10 to destroy

02:45:13: TTY5: no timer type 2 to destroy

02:45:13: Async5: allowing modem_process to continue hangup

02:45:14: TTY5: restoring DTR

02:45:14: TTY5: Set DTR to 1

02:45:15: %LINK-3-UPDOWN: Interface Async5, changed state to down

02:45:15: TTY5: autoconfigure probe started

Router#

hks10 Fri, 05/11/2007 - 12:52
User Badges:

Hello I just tested changing the async int to autodetect encap ppp and it looks like it's holding up a little bit longer but it then goes back down. I ran the same debugs and the output it a little different. Still cant' figure it out. Do you think my modem might be bad? It's a new modem fresh out of the box.


interface Async5

no ip address

encapsulation slip

dialer in-band

dialer pool-member 1

autodetect encapsulation ppp

async default routing

async mode interactive



03:46:16: CHAT5: Attempting async line dialer script

03:46:16: CHAT5: process started

03:46:16: CHAT5: Asserting DTR

03:46:16: TTY5: Set DTR to 1.....

Success rate is 0 percent (0/5)

Router#

03:46:52: TTY5: no timer type 1 to destroy

03:46:52: TTY5: no timer type 0 to destroy

03:46:52: TTY5: no timer type 2 to destroy

03:46:54: %LINK-3-UPDOWN: Interface Async5, changed state to up

03:46:54: %DIALER-6-BIND: Interface As5 bound to profile Di1

03:46:55: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async5, changed state to up

Router#

03:48:55: TTY5: DSR was dropped

03:48:55: tty5: Modem: READY->(unknown)

03:48:56: TTY5: dropping DTR, hanging up

03:48:56: TTY5: Set DTR to 0

03:48:56: TTY5: Async Int reset: Dropping DTR

03:48:56: TTY5: Set DTR to 0

03:48:56: tty5: Modem: HANGUP->(unknown)

03:48:57: TTY5: cleanup pending. Delaying DTR

03:48:58: %LINK-5-CHANGED: Interface Async5, changed state to reset

03:48:58: %DIALER-6-UNBIND: Interface As5 unbound from profile Di1

03:48:58: TTY5: cleanup pending. Delaying DTR

03:48:59: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async5, changed state to down

03:48:59: TTY5: cleanup pending. Delaying DTR

03:49:00: TTY5: cleanup pending. Delaying DTR

03:49:01: TTY5: no timer type 0 to destroy

03:49:01: TTY5: no timer type 1 to destroy

03:49:01: TTY5: no timer type 3 to destroy

03:49:01: TTY5: no timer type 4 to destroy

03:49:01: TTY5: no timer type 10 to destroy

03:49:01: TTY5: no timer type 2 to destroy

03:49:01: Async5: allowing modem_process to continue hangup

03:49:01: TTY5: restoring DTR

03:49:01: TTY5: Set DTR to 1

03:49:01: TTY5: autoconfigure probe started

03:49:03: %LINK-3-UPDOWN: Interface Async5, changed state to down


Actions

This Discussion