EIGRP not establishes the neighbor from one side

Unanswered Question
May 11th, 2007

Hi guys,

Please Advise on this issue ASAP.

I have a DSL link through ISP between two routers.

1st router with sub serial interface.

2nd router with Fastethernet interface.

i have configured EIGRP between them, i tried to see the EGIR neighbor on the first one and i can see the it but for some reasons on the second one i cannot see any neighbors established !!!!

i tried to put the neighbor command manually on both sides and i can see the neighbor on both side, but something happened with the whole WAN network and every thing stopped working !!!

thanks in advance...

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
hassan_oudeh Fri, 05/11/2007 - 23:21

this is the config:

--------------First Router---------------

router eigrp 301

passive-interface default

no passive-interface Serial0/0.1

no passive-interface Serial0/0.2

network 10.200.4.0 0.0.0.255

network 172.19.5.0 0.0.0.3

network 172.19.5.4 0.0.0.3

network 172.19.254.0 0.0.0.255

no auto-summary

interface Serial0/0

description QNET DSL Frame-Relay Link for Partners

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type q933a

!

interface Serial0/0.1 point-to-point

description KFIC - 1

bandwidth 1024

ip address 172.19.5.1 255.255.255.252

ip accounting output-packets

ip nat outside

frame-relay interface-dlci 101

--------------Second Router---------------

interface ATM0

bandwidth 640

ip address 172.19.5.2 255.255.255.252

no atm ilmi-keepalive

pvc 8/80

ubr 128

encapsulation aal5snap

!

dsl operating-mode auto

!

router eigrp 301

redistribute static metric 128 1000 255 1 1500

network 172.19.5.0 0.0.0.3

network 192.168.6.0

distribute-list 10 out ATM0

no auto-summary

!

bjornarsb Sat, 05/12/2007 - 06:40

Hi,

First I think the problem is a multicast issue. i.e some DSLAMs does not support multicast. And you have to manually configure neibours.

The neighbor command is used in EIGRP in order to define a neighboring router with which to exchange routing information. Due to the current behavior of this command, EIGRP exchanges routing information with the neighbors in the form of unicast packets whenever the neighbor command is configured for an interface. EIGRP stops processing all multicast packets that come inbound on that interface. Also, EIGRP stops sending multicast packets on that interface.

The ideal behavior of this command is for EIGRP to start sending EIGRP packets as unicast packets to the specified neighbor, but not stop sending and receiving multicast packets on that interface. Since the command does not behave as intended, the neighbor command should be used carefully, understanding the impact of the command on the network.

To define a neighboring router with which to exchange routing information on a router that is running Enhanced Interior Gateway Routing Protocol (EIGRP), use the neighbor command in router configuration mode. To remove an entry, use the no form of this command.

neighbor ip-address interface-type interface-number

no neighbor ip-address interface-type interface-number

Syntax Description

ip-address

IP address of a peer router with which routing information will be exchanged.

interface-type

Interface through which peering is established.

interface-number

Number of the interface or subinterface.

So of this is done correct it should work.

Check your routing table and the the distrbute-list 10 out !

HTH

Regards,

Bjornarsb

Actions

This Discussion