CCME and Telular Phonecell SX4e

Unanswered Question
May 12th, 2007

All -

I am looking for someone who has successfully utilized a Telular SX4e with an FXO port on a CCME gateway.

In doing debugs of voip ccapi inout and voice vpm signal I can see the inbound or outbound calls hit the port, but the gateway is failing the calls for no circuit.

If I connect a telephone to the SX4e I can successfully make and receive calls. I've connected a regular phone line to the port - and have successfully made calls.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Paolo Bevilacqua Sat, 05/12/2007 - 06:27


phonecells with FXS/FXO can be a problem to make work satisfactorily, an ISDN one would have no issue.

Now for the problem. Where do you see that gateway has no circuit ? That should not apply to outgoing.

For incoming, you almost certainly will need "connection plar opx", have you set that already ?

If you connect a phone to the adapter, does it work well?

If configure a dial-peer for outbound that just connects you to port and give dialtone from the adapter, can you dial?

kbrown Sat, 05/12/2007 - 16:02

The reason for the 'no circuit' is that the debug vpm signal is generating the following:

012230: May 11 22:22:04.133: //1139/DCF9BA3082D2/CCAPI/cc_api_call_proceeding:

Interface=0x48BE9B04, Progress Indication=NULL(0)

012231: May 11 22:22:04.285: htsp_process_event: [1/0/4, FXOLS_WAIT_DIAL_TONE,


and immediately following the ccapi is sending a disconnect with cause code 34.

Yes if I connect a phone to the SX4e it works fine.

The inbound dial peer is setup to connection plar 88 (The extension of the AA script).

We get the fxols_power_denial_proc on both inbound and outbound calls using this particular FXO port attached to the SX4e.

Paolo Bevilacqua Sat, 05/12/2007 - 17:03


for some reason the phonecell is executing power denial. The router seeing the port disconnected abnormally, reports no circuit. Please configure under voice-port

no supervisory disconnect signal

This will make the router ignore that condition.

I would have liked to see how long goes between router going off-hook and power denial, anyway doesn't matter. Basically, now you have to figure out tones for disconnect supervision (important as you are using AA), you can look at that later after making basic calls work.

Note, to connect to scripts via connection plar you will need a "loopback voip DP", or an incoming pots DP that matches the specific port via "answer-address" and has application configured.


This Discussion