CiscoWorks SNMS

Unanswered Question
May 13th, 2007

Hi,

I was trying to install the CiscoWorks SNMS software. Instalation went good, but when I try to access the Cisco works web interface and enter the userid and password, then web page error as web page not found.

When I check the error.og, I saw the details in attached file. What can be the problem?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.9 (10 ratings)
Loading.
Joe Clarke Sun, 05/13/2007 - 22:42

At this point (i.e. today), there are no errors in the file. Check to make sure the SNMS services are running (i.e. what does pdshow report?), and check to make sure you're accessing SNMS on the correct port (default is 1741).

examples20001 Tue, 05/15/2007 - 03:01

Hi,

SNMS is running in 1741 port and I can enter the userid and password too.

But after entering the id and password, it says page cannot find.

I have attached the pdshow result.

In the event viewer I see the below log:

The Apache service named Apache.exe reported the following error:

>>> Syntax error on line 61 of d:/program files/cscopx/mdc/apache/conf/httpd.conf: <<<

before the error.log file could be opened.

More information may be available in the error.log file. .

What can be the problem?

Pervious mail I have send the error log file.

Joe Clarke Tue, 05/15/2007 - 08:00

Please include your d:/program files/cscopx/mdc/apache/conf/httpd.conf file. It is obviously corrupt, and this is why Apache is not starting.

examples20001 Wed, 05/16/2007 - 04:54

I tryed to attach the httpd.conf file, but cisco server is giving error. will try later.

i just installed the software from the CD. So how can the file get corrupt?

Is it possible to get the http.conf file?

Joe Clarke Wed, 05/16/2007 - 07:22

Without seeing the file, I cannot say how or why it could be corrupt. It is best to fix your local httpd.conf.

examples20001 Thu, 05/17/2007 - 05:15

Hi,

when ever i try to upload the file, i get the below error message from cisco server for past 2 days:

"Server Error

This server has encountered an internal error which prevents it from fulfilling your request. The most likely cause is that the web site might be experiencing technical difficulties, or you may need to adjust your browser settings.

"

What is the problem, will it be possible to upload the file?

Joe Clarke Thu, 05/17/2007 - 07:23

No idea. You should use the NetPro Feedback link to report this problem. In the meantime, try zipping the file, then see if you can attach it. If that doesn't work, see if you can paste the portion of the file around the offending line.

examples20001 Thu, 05/17/2007 - 16:24

Hi,

I have attached the file httpd.conf file.

Can you please tell where the problem is?

Joe Clarke Thu, 05/17/2007 - 16:40

Your installation is bad. At this point, your only choice is to completely uninstall SNMS, then reinstall it. On what version of Windows did you install this? Please post your original installation log.

examples20001 Thu, 05/17/2007 - 17:23

I installed it in Microsoft Windows 2000 Server 5.0.2195 Service Pack 4.

Which is the file name to check the original installation log?

Joe Clarke Thu, 05/17/2007 - 19:16

There should be Ciscoworks_setup*.log files in C:\. One of them will correspond with the installation of SNMS.

Joe Clarke Thu, 05/17/2007 - 20:43

It looks like SNMS was properly installed on January 6, 2005, but must have been corrupted later. The two failed reinstallations since then did not help matters.

At this point, you should uninstall, then manually delete the D:\progra~1\CSCOpx directory. From there, you should be able to do a clean installation (as a local Administrator) and have success.

examples20001 Thu, 05/17/2007 - 22:54

Now I have got the new upgrade installation cd.

If I uninstall and reinstall the the SNMS with upgrade cd will it work?

As my old cd is misplaced and it is not their.

Joe Clarke Fri, 05/18/2007 - 07:37

If the upgrade CD is a complete version of SNMS, then it should work. What is its part number?

examples20001 Sun, 05/20/2007 - 16:05

My product number is: CWSNM-1.5-WINUP-K9

Desc: CiscoWorks Small NMS upgrade for cwn 5.x and 6.x customers.

will this product work if I un-install the current CWSNMS from my server and install the new CWSNM-1.5-WINUP-K9 product?

In my previous attached Ciscoworks_setupxxx.log, can you please tell at which part their is error?

Joe Clarke Sun, 05/20/2007 - 16:25

Yes, you can install this once you uinstall the current SNMS.

The first install log indicated no problems, and the other two appeared to be aborted installations. I do not know when the corruption occurred, or why, but clearly the httpd.conf is bad.

examples20001 Sun, 05/20/2007 - 22:51

Hi,

I un-installed and re-installed the CWSNMS software.

I am able to enter the userid and password.

But after that I get below messages:

I have attached my instalation log file.

What can be the problem?

"Not able to connect WhatsUp Gold on the server, hpsfjmgmt.

You may have changed the WhatsUp Gold admin or guest passwords using the Change Password option from the Admin > WhatsUp Gold navigation path. To make the password change effective, you must restart WhatsUp Gold.

Do you want to restart the WhatsUp Gold server now? Yes

Unable to start or restart WhatsUp Gold on the server, hpsfjmgmt for one of these reasons:

? There may be another window or file opened on the CiscoWorks SNMS server that has WhatsUp Gold as the title.

? The WhatsUp Gold console is waiting for your confirmation to save an unsaved map, on the CiscoWorks SNMS server.

? CWSNMSTaskbar.exe is not running on the CiscoWorks SNMS server.

? No user has logged on to the Windows workstation on which the CiscoWorks SNMS server is installed.

Please contact your administrator for further action.

"

examples20001 Mon, 05/21/2007 - 00:31

After re-installation and when I login to CWSNMS website, I get below error message:

"Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

--------------------------------------------------------------------------------

Apache/1.3.27 Server at xxxx Port 443"

In the error.log below is the messages:

[Mon May 21 17:12:04 2007] [notice] jrApache[2189] cannot connect to inetProxy(127.0.0.1:42343): Connection refused

[Mon May 21 17:12:08 2007] [notice] jrApache[2193] cannot connect to inetProxy(127.0.0.1:42343): Connection refused

[Mon May 21 17:12:11 2007] [notice] jrApache[2195] cannot connect to inetProxy(127.0.0.1:42343): Connection refused

[Mon May 21 17:12:16 2007] [notice] jrApache[2197] cannot connect to inetProxy(127.0.0.1:42343): Connection refused

[Mon May 21 17:12:20 2007] [notice] jrApache[2199] cannot connect to inetProxy(127.0.0.1:42343): Connection refused

examples20001 Mon, 05/21/2007 - 02:49

Always I am getting the below error:

What can be the problem?

"Not able to connect WhatsUp Gold on the server, hpsfjmgmt.

You may have changed the WhatsUp Gold admin or guest passwords using the Change Password option from the Admin > WhatsUp Gold navigation path. To make the password change effective, you must restart WhatsUp Gold.

Do you want to restart the WhatsUp Gold server now? Yes

Unable to start or restart WhatsUp Gold on the server, hpsfjmgmt for one of these reasons:

? There may be another window or file opened on the CiscoWorks SNMS server that has WhatsUp Gold as the title.

? The WhatsUp Gold console is waiting for your confirmation to save an unsaved map, on the CiscoWorks SNMS server.

? CWSNMSTaskbar.exe is not running on the CiscoWorks SNMS server.

? No user has logged on to the Windows workstation on which the CiscoWorks SNMS server is installed.

Please contact your administrator for further action.

"

Joe Clarke Mon, 05/21/2007 - 08:44

Is this currently the only problem you're facing, or is the previous connection refused error still being seen?

Are you trying to connect to WUG from the server itself, or from a remote client? What URL are you using to connect to WUG?

This problem could be indicative of an incomplete uninstallation. There may have been files and Registry entries left on the server.

Joe Clarke Mon, 05/21/2007 - 15:41

A complete uninstallation requires you to uninstall the software as you normally would, then delete the leftover NMSROOT directory (e.g. C:\progra~1\CSCOpx). Then, launch regedit, and remove HKLM\SOFTWARE\Cisco and HKLM\SOFTWARE\IpSwitch. Then reboot the machine.

Note, there is also a bug that has been release noted that if the admin and guest users have been removed from WUG, then you can get this error. Make sure you don't touch any of the user info in WUG when you reinstall, and you should no longer see the error you are seeing.

examples20001 Mon, 05/21/2007 - 16:43

Just now I uninstalled the CWSNMS and deleted the NMSROOT directory (e.g. C:\progra~1\CSCOpx).

check the regedit, for HKLM\SOFTWARE\Cisco and HKLM\SOFTWARE\IpSwitch.

But IpSwitch folder was not their and under Cisco their is no folder for CWSNMS.

As my same server is used for ACS (AAA), the cisco folder has got this info only.

Joe Clarke Mon, 05/21/2007 - 16:49

Okay, under the Cisco directory key there should be MDC and Resource Manager directories. You should remove them if they exist. If the IpSwitch branch is gone, that is a good sign. Do not forget to reboot before doing the reinstallation.

examples20001 Mon, 05/21/2007 - 17:20

There is no MDC directories, but Resource Manager directories was their and I have deleted and rebooted the server.

examples20001 Wed, 05/23/2007 - 06:07

Hi,

After re-installation, every thing is working fine and WhatsUp showed the devices after the scan.

But when I try to export to essential, nothing is displayed.

How to export the devices to essential and control the devices from Cisco device manager?

Joe Clarke Wed, 05/23/2007 - 08:13

Exactly what are you doing to export the devices to RME, and what do you mean, nothing is displayed? Please provide a screenshot.

Actions

This Discussion