CDP Warning when making phone updates after upgrading to CCM 4.1(3)sr4d

Unanswered Question
May 14th, 2007

After upgrading from 4.1(3)sr4b to 4.1(3)sr4d, I get the following warning messages when hitting "update" on any phone:

'Cisco Discovery Protocol (CDP): Switch Port: Warning! CDP should only be disabled on the Network port if this phone is connected to a non-Cisco switch. For further details, consult the Cisco Callmanager Administration Guide.'

'Cisco Discovery Protocol (CDP): PC Port: Warning! Disabling CDP on the PC port will prevent Cisco VT Advantage/Unified Video Advantage from working properly on this phone. For further details, consult the Cisco Callmanager Administration Guide.'

CDP is enabled on all phones, and working fine.

Anybody else encounter this?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (1 ratings)
Loading.
gogasca Mon, 05/14/2007 - 10:26

Hi Johny,

Last week I recieved a case experiencing the same problem in 7970s. In fact CDP was not working fine.

Customer was not able to continue troubleshooting and we just upgrade to latest phone load...

Are you using Cisco switches?

Which phone model?

VVLAN is aquired correctly via CDP?

Thanks

johnnylingo Mon, 05/14/2007 - 10:34

This looks like a problem with CallManager's backend scripting, not the phones. It started after doing the upgrade and I see there was a change to xmlrulevalid.js, but unfortunately I don't have the previous version handy for comparison.

We're using 7906, 7940, 7941, 7920, 7921, and 7961 phones. Switches are mostly 3550, 3560, or 3570 and there's a few 3500XLs too.

CDP works fine. If I do "show cdp neighbors" on any switch, all the phones show up. Also we're using CER, and all the tests done have completed successfully.

agster Fri, 05/25/2007 - 06:14

Yes I have a customer with EXACTLY the same symptoms, did you find any resolution?

Their's occurred after Dev pack 43 was applied and they are still running 4.1(3)sr3b so it can't be solely attributed to sr4d

Anyone help?

johnnylingo Fri, 05/25/2007 - 09:20

I had also applied Dev Pack 43 right after the upgrade from b to d, so sounds like that was what did it.

I've been meaning to open a TAC case, but we're in the middle of an upgrade and since there have been no ill effects noticed, it's low priority. I'll keep you posted.

rob.huffman Fri, 05/25/2007 - 10:19

Hi Guys,

There are two Bugs associated to this problem. Have a look;

CSCsi52910

All IP Phones are connected to Cisco Switches and have CDP enabled .

It does not matter If the third generation IP Phone is registered or not registered with call Manager.Message pops up on both the cases for all third generation IP Phones.

7940,7960 Phones does not have this problem.

Status

Fixed

Severity

5

Last Modified

In Last 3 Days

Product

Cisco Unified Communications Manager (CallManager)

Technology

1st Found-In

4.2(3)

Fixed-In

4.3(1.62)

4.3(1)SR1

4.2(3)SR2a

4.2(3)ES32

4.1(3)SR5

4.1(3)ES112

3.3(5)ES62

Related Bugs

CCMAdmin - CDP pop-up warning whenever phone updated

Symptom: CCMAdmin pops up CDP warning messsages whenever phone (7941, 7970 etc) is updated. Conditions: When phone is updated, with or without changes to the CDP flags. Workaround: Click ok on each warning message Further Problem Description:

CSCsi88338 Bug Details

Headline CCMAdmin - CDP pop-up warning whenever phone updated

Symptom: CCMAdmin pops up CDP warning messsages whenever phone (7941, 7970 etc) is updated.

Conditions: When phone is updated, with or without changes to the CDP flags.

Workaround: Click ok on each warning message

Hope this helps!

Rob

s.schiassi Sat, 05/26/2007 - 00:26

Hi,

we have the same issue after installing device pack 43. We are not able anymore to insert and modify 7970s phones properties like Video Capabilities. It's a bug that should be resolved by the latest 4.1(3) ES.

Do not install Dev-pack 43!!!

HTH,

Simone

philippgrafl Wed, 06/20/2007 - 01:09

I have the same issue. After installing dev pack 43 i cannot make any change to my 7970 phones. And i cannot uninstall the dev-pack. Has anyone a Cisco Bug ID for this issue?

spartain Wed, 08/22/2007 - 05:03

We just applied a patch for 3.3 and we are getting this issue now. What was the fix action for this error. We need the ability to update the phones and currently cannot.

Thanks,

Mike

agster Wed, 08/22/2007 - 05:48

We were hitting bug CSCsi52910 which affects 3rd Generation phones, this is fixed in 4.1(3)SR5 (now SR5b is the latest without checking).... however as your running 3.3 not sure what you'll need to go to! :-)

rob.huffman Wed, 08/22/2007 - 08:09

Hi Mike,

What version of CCM 3.3? Did you change the Device Pack or Phone Loads? Have you tried the Workaround until you can try the ES?

CM 4.2.3

After applying ES26

update , modification on any Third generation IP Phones , 7941/7961/7970 , From CCM Administration page after updating 4.2.3 ES26 pops up Error message

"Cisco Discovery protocol CDP : switch Port: Warning! CDP should only be disabled on the Network Port if the phone is connected to non-switch.

For further details , consult the call Manager Administration guide.

Note If you clicked update just prior to receiving this message, the update operation did not occur.PLease click ok and then click update again to save your changes."

Click OK

Second time message comes again with same description including VT Advantage .

click OK

The update does take effect though.

Conditions:

Applied ES26 on Call Manager 4.2.3 . Issue started after applying ES26

Workaround:

None

Further Problem Description:

All IP Phones are connected to Cisco Switches and have CDP enabled .

It does not matter If the third generation IP Phone is registered or not registered with call Manager.Message pops up on both the cases for all third generation IP Phones.

7940,7960 Phones does not have this problem.

Let us know,

Rob

spartain Wed, 08/22/2007 - 09:04

We are actually using Call Manager 3.3(5)sr2c

Cisco had suggested applying the device package 78 but it gave us the message that it was older than what we had applied so that is where we are at now.

thanks for the response.

muhammadt Wed, 10/31/2007 - 14:06

I'm running 4.2.3sr1, it started after DEV pack 36 for 4.2.3 was added. I get the popup and the changes Won't TAKE!!! Sucks. TAC told me to upgrade to sr2b. Hopefully this repairs the problem.

Here's the bug ID CSCsi52910 but this doesnt' match perfectly

Actions

This Discussion