AUDIO FROM IP 7970GE

Unanswered Question

I am having a heck of a time with the audio stream RTPRx.


I have a phone which is using the Call Manager Simulator (no real CM).


This phone is getting a push command to recieve stream...once I execute command, the lights on phone go...


Then I am executing the AVTransmit2 and I hear nothing...


Now, when I try to increase volume or do anything, it says key not active...


Does this need to be hooked to a call manager to work?


Can anyone post a .wav file that they have absolutely verified that works?


It is frustrating that nothing like this is included in the SDK to test...developers are pretty much on their own here...


thanks....

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
stephan.steiner Tue, 05/15/2007 - 00:19

avtransmit isn't very flexible I'm afraid.. the only thing I've tried that worked was a regular CD quality audio file. Basically I took my MP3 file that I wanted to stream, loaded it in winamp and configured winamp to use the diskwriter plugin with 44.1 khz 16bit stereo rather than the default directsound output plugin, then pressed play.. that wrote me a wav file that I could then stream.

What definitely doesn't work is G.711 quality audio... if I created a G.711u audio file via Windows, I could stream it, but the phones wouldn't get anything (I didn't bother to record with wireshark and try to play it from there to verify that really nothing is being streamed). The wireshark thing is a good way to verify that you're really sending audio out.. have it run on the machine you're streaming from, capture udp, then right click on a udp packet and tell wireshark to decode it as rtp.. then you can save the stream as audio file and play it in windows media player.

I am beginning to believe that the RTP stuff is the "crazy aunt" that the family doesn't want to talk about...


Meaning - it seems like if the moon is full, sun is in the right position, and the phone is facing north - it will work...


Is there a bona fide .wav or any audio file that exists that someone knows for sure runs unaltered through the AVTransmit2 and works?

msabir Tue, 05/15/2007 - 11:18

I am attaching a file that I works well on these phones: 7905/12/40/41/60/61/70/71 with CCM 3.3.x and above. I have also tested it with CallManager simulator and it worked like a charm. This is actually a live recording from an Emergency Alert System (EAS) where PhoneTop Alerts pushes out live audio to Cisco IP Phones.



I appreciate this, did you use this with the AVTransmit2 java program....this is what I get

...but I don't hear anything from the phone...



C:\hold\rtp>java AVTransmit2 file:/C:/hold/rtp/AnneArundelHUW.wav 192.168.7.120

30000

Track 0 is set to transmit as:

dvi/rtp, 22050.0 Hz, 4-bit, Mono

Created RTP session: 192.168.7.120 30000

Start transmission for 60 seconds...

...transmission ended.

msabir Tue, 05/15/2007 - 12:46

Is multicast enabled on your router (if you are using one)? All switches forward IP multicast traffic by default.

Actions

This Discussion