CiscoWorks LMS 2.6 Device Discovery questions

Answered Question
May 14th, 2007

I have configured the campus manager settings for device discovery as per the user guide and I can only see roughly half of my network devices discovered.

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 9 years 6 months ago

Correct, location in the file does not matter.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Mon, 05/14/2007 - 11:37

Things to check in this case are discovery filters under Campus Manager > Admin > Device Discovery > Discovery Settings and make sure you are not filtering out the missing devices.

Next, make sure that the SNMP settings are correct for all devices in your network under Campus Manager > Admin > Device Discovery > SNMP Settings.

Then, make sure CDP is enabled down to all of the devices in your network. If you have gaps in CDP, you will need to add multiple seed devices in each CDP region.

Finally, check the Discovery report by clicking on the number of devices discovered under Campus Manager > Home. Make sure all of the devices that were discovered were reachable. If not, you will need to figure out why those devices are not SNMP-reachable from the LMS server.

If you still can't figure out why Discovery is not finding all of your devices, enable devdiscovery debugging under Campus Manager > Admin > Device Discovery > Debugging Options, run a new Discovery, and look at the discovery.log for any errors.

paul.coley Tue, 05/22/2007 - 11:45

* I have listed 9 upto major core seed devices (routers&switches) from our Toronto, Montreal and Calgary core infrastructure.

* I have specified our three major IP summarized IP ranges with asterisks for wildcards as follows

-> 162.53.*.*

-> 172.20.*.*

-> 10.*.*.*

* CDP is enabled on at least 90% of our network gear. We estimate that our total netwok devices of routers/switches should be in the range of 1000 to 4000, and I am only seeing 571.

* I am using the same SNMP string that our other monitoring application is using. which is IND and that application see's the whole topology.

I will try the debugging and find out why some devices are unreachable.

Joe Clarke Tue, 05/22/2007 - 11:50

Also, check to make sure you have enabled "Jump Router Boundaries" in your discovery settings. If you still can't figure it out, post the log and the NMSROOT/campus/etc/cwsi/DeviceDiscovery.properties file.

paul.coley Thu, 05/24/2007 - 08:09

I have enabled all the device discovery settings including "Jump Router Boundaries"

I am going to post the DeviceDiscovery.properties file. I want to attatch the discovery.log file but it's 10mb. Is there another option?

Joe Clarke Thu, 05/24/2007 - 08:21

You can compress it down. Note, you will also need to provide one missing device, and how that device is connected into the discovered topology.

paul.coley Thu, 05/24/2007 - 08:38

an example of one missing device would be

Hostname: LCLKEN12

Loopback: 172.29.96.5

Fa0/0: 162.53.5.233

It is a router(3640) that is connected to the same vlan on our core switch.

Device 162.53.5.243 was discovered and it is on the same vlan as 162.53.5.233

I hope i provided the info you needed.

Attachment: 
Joe Clarke Thu, 05/24/2007 - 08:52

This device did get discovered as 172.29.96.5, then it was rejected since that was not in the valid range. You might want to try adding the following to DeviceDiscovery.properties, and see if that helps:

Discovery.SkipExcludedLoopback=true

paul.coley Thu, 05/24/2007 - 10:50

- I will change the seed ip range from 172.20.x.x & 172.21.x.x to 172.*.*.*

- I will go back and see what the loopback scheme is that is being used.

- if I wanted to ensure I grab every single device regardless of scheme..would you recommend *.*.*.* in device discovery?

what exactly does "Discovery.SkipExcludedLoopback=true" do?

Joe Clarke Thu, 05/24/2007 - 10:55

If you want to grab every device, don't specify a discovery range.

SkipExcludedLoopback tells Discovery not to set a device's management IP to an address that is not in the allowed discovery range.

paul.coley Thu, 05/24/2007 - 11:35

I assume it doesn't matter where "SkipExcludedLoopback" is located within that file, as long as there is no "#" in front.

I have now gone from 570+ discovered devices to 1600+. I will have to investigate the network discovery further to find out why every single device is still not there. But you have helped me get alot farther than before. thanks j

Actions

This Discussion