Virtual routers and ip redundant vip

Unanswered Question
May 14th, 2007

I have for example the following config:

CIRCUIT VLAN40:

ip add 10.2.5.247 255.255.255.0

ip virtual-router 4 priority 210

ip virtual-router 5 priority 210

ip virtual-router 6 priority 210

ip redundant-vip 4 10.2.5.73

ip redundant-vip 5 10.2.5.74

ip redundant-vip 6 10.2.5.75

I have changed the config to have only one virtual router and multiple redundant vips.

CIRCUIT VLAN40:

ip add 10.2.5.247 255.255.255.0

ip virtual-router 4 priority 210

ip redundant-vip 4 10.2.5.73

ip redundant-vip 4 10.2.5.74

ip redundant-vip 4 10.2.5.75

After doing this the content rules for .74 and .75 stopt working. I see them as Master status and all services on the content rules are alive. But users are unable to access this vip. I can ping the vip from outside.

Kind regards,

Frederik De Muyter.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
joquesada Mon, 05/14/2007 - 17:35

Hi Frederik,

Would you mind to add the following outputs from both CSS':

- sh run

- sh virtual-routers

- sh reduntant-vips

- sh redundant-interfaces

Thanks!

Jose Quesada.

Frederik1980 Tue, 05/15/2007 - 00:07

Hi Jose,

I have added in attachement the commands you asked off both CSS machines. I now have a working config with different virtual routers. I would like to move to one virtual router that uses multiple redundant-vips. (the output i'm giving you is the working version. i had to move back to it). The show run doesn't include access lists, and settings like snmp, aaa authentication,... and a default route.

I would like to move to one virtual router. Because i would like to setup vrid peering, and i have other content switches with more then 12 virtual routers running, and i can only add 8 off them to a critical-reporter.

Kind regards,

Frederik De Muyter.

Attachment: 
joquesada Wed, 05/16/2007 - 20:19

Hi Frederik,

Where are the content rules 10.2.5.73, 74 & 75? I also noticed that the subnet used in VLAN 40 is different than the one you used on the example of your initial question.

When you tried adding all the VIPs under the virtual router 4, did you do it only on one CSS, or in both CSS? Your configuration seems to be ok and should work properly, but it very difficult to determine what might be the problem if the outputs I've requested aren't taken when the problem occurs. I understand it might be difficult to do that if this is a production environment. Thanks!

Regards,

Jose Quesada.

Frederik1980 Sun, 05/20/2007 - 23:37

Hi Jose,

The config i have added is the right one.

The following content rules 10.2.12.173 stop

working.

ip redundant-vip 7 10.2.12.173

ip redundant-vip 8 10.2.12.174

I have configured the ip redundant-vip 4 on both content switches. An when i do show summary i get Master --> backup. Could it bet that the vips are used as default gateway for upstream or downstream devices? Can this be a problem? I could also ping the VIP after changing the config. So layer 3 connectivity to the VIP was no problem.

I will see if i can reproduce the problem.

Kind regards,

Frederik De Muyter.

joquesada Mon, 05/21/2007 - 08:22

Dear Frederik,

The VIPs shouldn't be used as DG for any device on your network. If you need to use the CSS as DG, please have your devices pointing to the circuit's IP address. Try to replicate this matter, to see if are able to get an idea about what might be the issue. Thanks!

Regards,

Jose.

Actions

This Discussion