Martin Parry Tue, 05/15/2007 - 00:25
User Badges:
  • Silver, 250 points or more

Hi


Can you take a look in the logging buffer? You should get an indication as to why the ports have been placed in err-disabled state.



avicapri Tue, 05/15/2007 - 01:33
User Badges:

Hi ,

Below is the message i get :

PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/3 in err-disable state

%PM-4-ERR_DISABLE: channel-misconfig error detected on Po20, putting Gi0/1 in err-disable state


Martin Parry Tue, 05/15/2007 - 01:44
User Badges:
  • Silver, 250 points or more

Hi


Please can you try the following steps. Connect the first port from po10.


Then connect the first port from po20.


Make sure that all is as it should be and that you have connectivity. Then connect the next port from po10 etc.


It may be that you are connecting the two ports in the same portchannel to multiple devices.



avicapri Tue, 05/15/2007 - 01:50
User Badges:

No that is not the case.I have attached the Setup diagram & configuration for Reference

Martin Parry Tue, 05/15/2007 - 02:09
User Badges:
  • Silver, 250 points or more

I cannot see any issues with the configuration on the switches. Can you confirm at what stage the message occurs if you connect each port up one at a time?


avicapri Tue, 05/15/2007 - 02:26
User Badges:

Error occurs when one port-channel(10) is up & other port-channel(20) comes up

Martin Parry Tue, 05/15/2007 - 02:40
User Badges:
  • Silver, 250 points or more

Is that when one individual link from each port channel is enabled?


avicapri Tue, 05/15/2007 - 02:42
User Badges:

not individual link all the ports for that Port-channel.

pavansuraj Tue, 05/15/2007 - 02:22
User Badges:

Hi,


if the above error messages are from the 3560-3 switch, then ensure the interfaces G0/1 and G0/3 connectivity to other switches(corresponding port channels) and the port channels they belong to locally.


As per configuration both belong to port channel 20 but the error messages show that

G0/3 maps to port channel 10


Best regards,

Pavan


avicapri Tue, 05/15/2007 - 03:31
User Badges:

i have not used allowed vlan command .so by default all the vlans are allowed

glen.grant Tue, 05/15/2007 - 03:36
User Badges:
  • Purple, 4500 points or more

People seem to like to force the channels on, myself I let them negotiate , you could try on one of your links to channel this way," channel-group X mode desirable non-silent" , you would use this on both ends of the link . May sure all links are equal speeds , they appear to be . Native vlans are the same on each end and each end is the same , it is either a layer 2 etherchannel or a layer 3 etherchannel . Also make sure your cables are going where you think they are going , if they are crossed somehow that will take the channel down . Verify with show cdp neighbor.

A warning which may be what you are running into to.


Caution You should exercise care when setting the mode to on (manual configuration). All ports configured in the on mode are bundled in the same group and are forced to have similar characteristics. If the group is misconfigured, packet loss or spanning-tree loops might occur.

Here is a good link .


http://cisco.com/en/US/products/hw/switches/ps5528/products_configuration_guide_chapter09186a00801e85ce.html#1024682

glen.grant Tue, 05/15/2007 - 03:55
User Badges:
  • Purple, 4500 points or more

A little more info out of a cisco doc.A disadvantage of trying to force etherchannels on.

Err-Disable State


A common issue during EtherChannel configuration is that the interfaces go into err-disable mode. This can be seen when Etherchannel is switched to the ON mode in one switch, and the other switch is not configured immediately. If left in this state for a minute or so, STP on the switch where EtherChannel is enabled thinks there is a loop. This causes the channeling ports to be put in err-disable state. See this example for more information on how to determine if your EtherChannel interfaces are in the err-disable state:


%SPANTREE-2-CHNL_MISCFG: Detected loop due to etherchannel misconfiguration of Gi0/9

%PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/9 in err-disable state

%PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/10 in err-disable state


Switch1#show etherchannel summary

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

u - unsuitable for bundling

U - in use f - failed to allocate aggregator

d - default port


Number of channel-groups in use: 1

Number of aggregators: 1


Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

10 Po10(SD) - Gi0/9(D) Gi0/10(D)


Switch1#show interfaces GigabitEthernet 0/9 status


Port Name Status Vlan Duplex Speed Type

Gi0/9 err-disabled 1 auto auto 10/100/1000BaseTX


Switch1#show interfaces GigabitEthernet 0/10 status


Port Name Status Vlan Duplex Speed Type

Gi0/10 err-disabled 1 auto auto 10/100/1000BaseTX


The error message states that the EtherChannel encountered a spanning tree loop. To resolve the issue, set the channel mode to desirable on both sides of the connection, and then re-enable the interfaces:


Switch1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch1(config)#interface gi0/9

Switch1(config-if)#channel-group 10 mode desirable


This causes each side to form a channel only if they both agree to channel. If they do not agree to channel, they continue to function as normal ports.


After the channel mode is set to desirable on both the sides of the connection, issue the shutdown and no shutdown commands on the associated interface to re-enable the ports by manually:


Switch1(config-if)#shutdown

Switch1(config-if)#no shutdown



avicapri Tue, 05/15/2007 - 21:42
User Badges:

Hi ,


U have given me a good info

Let me try it out & let u know soon


thanks

Actions

This Discussion