Problem configuring CCME features

Unanswered Question
May 15th, 2007
User Badges:

I have just installed CCME4.0, and i have installed 7961 ip phones. I am trying to configure directory services, MOH for internal calls, and custom ringtones. But it doesnt reflect on the phones. I have enabled all the required files in TFTP and followed all config steps but no go. Can someone please help?



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
rseiler Tue, 05/15/2007 - 12:07
User Badges:
  • Silver, 250 points or more

Directory services are configured by default (you don't need to do anything other than global speeddial.xml file if necessary).


MOH for internal calls requires multicast MOH which has specific router and switch requirements in addition to the CME config. This is clearly documented in the CME 4.0 configuration guide.


Custom ringtones requires you to create a Ringlist.xml file in the routers flash and copy the relevant ringtone (.raw) files into flash as well.


Let me know if you have any additional questions.

moblix123 Wed, 05/16/2007 - 03:11
User Badges:

Thanks a million for your response. i have followed all the config steps but no luck, pls find below my running config and tell me what i'm doing wrong.


Building configuration...


Current configuration : 4648 bytes

!

! Last configuration change at 10:59:45 UTC Wed May 16 2007

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname yourname

!

boot-start-marker

boot-end-marker

!

! card type command needed for slot/vwic-slot 0/0

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 149.17.18.2

!

ip dhcp pool cme-pool

network 149.17.18.0 255.255.255.0

default-router 149.17.18.1

option 150 ip 149.17.18.1

!

!

no ip domain lookup

ip domain name yourdomain.com

ip multicast-routing

!

!

voice-card 0

no dspfarm

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 149.17.18.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip classless

!

!

ip http server

no ip http secure-server

ip http path flash:

!

access-list 23 permit 10.10.10.0 0.0.0.7

access-list 23 permit 149.17.0.0 0.0.255.255

access-list 23 permit 149.17.18.0 0.0.0.255

!

!

!

tftp-server flash:cnu41.2-7-6-26.sbn

tftp-server flash:CVM41.2-0-2-26.sbn

tftp-server flash:Jar41.2-9-2-26.sbn

tftp-server flash:TERM41.7-0-3-0S.loads

tftp-server flash:term41.default.loads

tftp-server flash:term61.default.loads

tftp-server flash:RingList.xml

tftp-server flash:Analog1.raw

tftp-server flash:Bass.raw

tftp-server flash:Chime.raw

tftp-server flash:Jamaica.raw

tftp-server flash:Pop.raw

!

control-plane

!

!

!

!

!

!

!

!

!

!

telephony-service

load 7961 term61.default.loads

max-ephones 24

max-dn 48

ip source-address 149.17.18.1 port 2000

system message Pinky Inc

create cnf-files version-stamp 7960 May 16 2007 10:49:28

max-conferences 8 gain -6

moh music-on-hold.au

multicast moh 239.0.0.19 port 2000

web admin system name cisco password cisco

dn-webedit

time-webedit

directory entry 1 1001 name test 1

directory entry 2 1003 name test 2

directory entry 3 1002 name test 3

xmltest

!

!

ephone-dn 1 dual-line

number 1001

description Test 1

name Test 1

!

!

ephone-dn 2

number 1003

description Test 2

name Test 2

!

!

ephone-dn 3 dual-line

number 1002

description Test 3

name Test 3

hold-alert 30 originator

!

!

ephone-dn 4 dual-line

number 1004

description fdfss

name fsff

hold-alert 30 originator

!

!

ephone-dn 5 dual-line

number 1006

description test 6

no huntstop

hold-alert 30 originator

!

!

ephone-dn 20

number 1000

name paging

paging ip 239.0.0.18 port 2000

!

!

ephone 1

mac-address 001B.535C.6E51

button 1:1

!

!

!

ephone 2

mac-address 001B.5413.FC6A

paging-dn 20

button 1:2

!

!

!

ephone 3

mac-address 001B.5413.CBF0

button 1:3

!

!

!

line con 0

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

no login

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

login local

end

rseiler Wed, 05/16/2007 - 09:32
User Badges:
  • Silver, 250 points or more

This is a typical problem that people do all the time. I guess you configured the phones manually, rather than via the GUI?


You left an important *REQUIRED* config item off each of your ephone entries, the phone 'type'. If you don't define a phone type, the phone never gets the default xml file which defines a *BUNCH* of settings for the phone including locale, timezone (on the odd numbered phones), URLs, presence, etc.


Your phones are basically not getting any config from the router. You can 'no create cnf-files' and 'create cnf-files' all you want which will create the default xml files on the router, they are just never getting to the phone because you haven't told the router what phone type they are.


You also would notice that time is wrong, right? In addition, settings/status/status messages on the phone would show that it can't find the SEP.cnf.xml file.


Another troubleshooting trick for this is if you enter the exec command 'show telephony-service tftp-bindings' you will see that all the router is doing is creating the SEP.cnf.xml files as aliases to the XMLDefault.cnf.xml and you don't have those entries yet because you haven't defined the phone type.


To fix this, just do the following, for example:


conf t

ephone 1

type 7961

reset

end


Let me know if this does the trick...

moblix123 Thu, 05/17/2007 - 07:17
User Badges:

Thanks alot, you been the best help. It worked but quite partially. The directory service is working now but the custom ring tones and internal MOH are still not working.

I cant help but notice that each time i creat cnf-files, the file created is version-stamp 7960. Instead of 7961.

I really dont know if that is an issue.



Any other suggestions please?

paolo bevilacqua Thu, 05/17/2007 - 07:32
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


You can ignore the version-stamp file it only applies to older phone types.

For ring files you need to configure correctly "tftp-server" with all the files in list, plust the list itself. Please do "debug tftp events" to see what the phones are requesting".

The MOH, keep in mind for internal calls usually MOH is not used, calling from outside you should be able to hear it.


Hope this helps, please rate post if it does!

rseiler Thu, 05/17/2007 - 07:35
User Badges:
  • Silver, 250 points or more

Again, the internal MOH requires a specific minimum version of CME and *MUST* use IP multicast. This may require more configuration on the CME router and whatever switch you are using. Do not use a multicast IP that starts with 239.0 (per the documentation).


The ringtones requires a Ringlist.xml file in the routers flash (and permitted by a tftp-server global command) as well as the same for each .raw file you copy to flash as well. I usually copy the .raw files I want from a CallManager server and modify the Ringlist.xml file as necessary.


There are a few good documents on the Cisco site that detail the xml files. It is listed under custom xml applications, I believe. These forums have a bunch of posts reqarding the Ringlist.xml, speeddial.xml, and the newer phone background images...

moblix123 Thu, 05/17/2007 - 23:37
User Badges:

I have followed all the steps for configuring custom ringtones from the manuals but still nothing.


I really appreciate the assistance i have recieved at this forum.


Here is the result for the debug tftp-events


May 18 07:12:30.011: TFTP: Looking for CTLSEP001B5413FC6A.tlv

May 18 07:12:30.187: TFTP: Looking for SEP001B5413FC6A.cnf.xml

May 18 07:12:30.187: TFTP: Opened system:/its/XMLDefault7961.cnf.xml, fd 0, size 917 for process 163

May 18 07:12:30.191: TFTP: Finished system:/its/XMLDefault7961.cnf.xml, time 00:00:00 for process 163

May 18 07:12:30.331: TFTP: Looking for term61.default.loads.loads

May 18 07:12:31.335: TFTP: Looking for English_United_States/mk-sccp.jar

May 18 07:12:31.591: TFTP: Looking for /g3-tones.xml

May 18 07:12:31.991: %IPPHONE-6-REG_ALARM: 25: Name=SEP001B5413FC6A Load= TERM61.DEFAULT Last=Initialized

May 18 07:12:32.243: %IPPHONE-6-UNREGISTER_ABNORMAL: ephone-2:SEP001B5413FC6A IP:149.17.18.5 Socket:2 DeviceType:Phone has unregistered abnormally.

May 18 07:12:32.243: %IPPHONE-6-REGISTER: ephone-2:SEP001B5413FC6A IP:149.17.18.5 Socket:4 DeviceType:Phone has registered.

rseiler Thu, 05/17/2007 - 23:56
User Badges:
  • Silver, 250 points or more

This is really very easy so you must be missing something simple.


One thing to look out for is the formatting of the Ringlist.xml file. Be sure there are no extra characters and that the xml syntax is correct.


Note that the file that needs to be in the root of your flash system is 'Ringlist.xml' (note the capital R). Obviously, this would need to be in a tftp-server global statement in the router as well.


Depending on the router platform, be careful with specifying the directory when copying the file: '/Ringlist.xml' may not be the same as 'Ringlist.xml'.


Finally, what is the phone displaying when you try to change the ringer for one of the lines? Is there an error message? File not found?


I'm not sure why your tftp server debug above is looking for /g3-tones.xml. Did you specify that anywhere?


Are you using a locale other than US?


What phoneload are you running on the 7961 phone(s)?

moblix123 Fri, 05/18/2007 - 00:49
User Badges:

Yes i agree, its supposed to be easy but its turned out to be hard nut for me.


i didnt specify for it to look for /g3-tones.xml


The router is a 2811 runing 12.4(3g).


I did copy the file properly into flash and enabled it with tftp command.I took note of the case.


When i go to settings/user pref/rings/... i only see chirp1. i dont get the option to even change to another ringtone.


The phone load i am currently using is TERM41.7-0-3-0S.loads.


I am not using any locale other than US.


Find attached a copy of the Ringlist.xml, you can reconcile it with the running config.



Attachment: 
rseiler Fri, 05/18/2007 - 01:07
User Badges:
  • Silver, 250 points or more

If you are not seeing the request for the RingList.xml file under the tftp server debug (when you try to change the ringtone for a line), then you have a problem with the CME config or the phone.


Be sure each ephone has a type defined and try the following commands:


conf t

telephony-service

no create cnf-files

create cnf-files

reset all

end


If that doesn't work, I would try the 8.2.2SR1 DST phone load, the 7.0(3) phoneload is quite old.


Are you sure the phone is running the phoneload that you have defined in the router? Try settings/status/firmware on the phone to confirm.

paolo bevilacqua Fri, 05/18/2007 - 01:37
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


keep in mind the newer java-based phones request ringlist.xml only at boot time, and not when changing settings!

moblix123 Mon, 05/21/2007 - 01:35
User Badges:

Eureka! Its working now. i had to replace all the phone files in flash with another one that I got from the Cisco site. And now i have my custom ringtones working.

Thanks all so much for the assistance. you guys are the best.

adandrade Fri, 08/10/2007 - 12:31
User Badges:

Could you explain what you did ? I am having the same issue . thanks

Actions

This Discussion