HSRP Failover question

Unanswered Question
May 15th, 2007

This may be difficult question to ask as I can not draw it out, however I have no doubt that the expertise in this fourm will persevere and figure this out anyway:

- two seperate networks A -> B and C -> D

- A and C are in site 1

- B and D are in site 2

- two seperate data pipes DS3 and MPLS network

- 4 routers (inside and outside interface is configured on both)

- A -> B network (DS3) = 172.16.1.x (outside interface)

- C -> D network (MPLS) = 172.16.2.x (outside interface)

- inside interfaces for all routers is operating in HSRP mode

- dont ask why...just the way an existing network admin set this up

- if the primary link DS3 goes down, then it goes over the MPLS network however it is not seamless

- this process (HSRP) requires manual intervention at both sites because if a process at site 1 on some server etc is running, it stops because site 2 does not know how to route back to through the MPLS network to allow the process to continue seamlessly

- so ulitmately the process has to be stopped, then HSRP can be manually triggered, then the process cab begin again

- this is not a true HSRP environment I know, but I am on the tailend of trying to fix this

OK Gentleman and ladies.....any clue as to what is going here?

Thank you very much

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
hoogen_82 Tue, 05/15/2007 - 08:22

If you could draw a simple diagram and show us i guess it might help us visualize your network better.

-Hoogen

hoogen_82 Tue, 05/15/2007 - 08:28

If you could draw a simple diagram and show us i guess it might help us visualize your network better. If possible post the configuration of all the four routers.

-Hoogen

stonnet72 Tue, 05/15/2007 - 09:01

i will provide all with a diagram of the setup, however it is not possible for me to provide configuration. I hope that by me providing the diagram will be helpful enough.

Craig Norborg Tue, 05/15/2007 - 09:57

I'm guessing the problem is not in your HSRP configuration although you probably want to configure it on each router to "track" the WAN interface so if it goes down it will reduce the priority of the HSRP to switch it over to the other router.

Your problem however is probably in the routing protocol your using. MPLS networks usually want to use BGP for dynamic routing, but its not an easy routing protocol to deal with. So many providers say just put in a static route and it will handle routing the traffic. However, if the other router has a higher priority route for the network, the traffic will still try and go that way regardless of the static route on the MPLS network.

If you want to not run BGP throughout your network there can be an easier way to run an "easier to configure" protocol such as EIGRP. Set up a GRE tunnel across the MPLS network which will allow your routing protocol to go through the tunnel even though it can't traverse the MPLS network by itself...

ie:

router 1 config

interface serial1/0.1

description To MPLS tunnel

ip address 57.1.1.1 255.255.255.252

!

ip route 57.1.0.0 255.255.0.0 57.1.1.1

! static route to MPLS network

!

interface tunnel 0

desc tunnel to other router

ip address 192.168.254.1 252.255.255.252

tunnel source serial1/0.1

tunnel destination 57.1.10.1

!

router 2 config

router 1 config

interface serial2/0.1

description To MPLS tunnel

ip address 57.1.10.1 255.255.255.252

!

ip route 57.1.0.0 255.255.0.0 57.1.10.1

! static route to MPLS network

!

interface tunnel 0

desc tunnel to other router

ip address 192.168.254.2 252.255.255.252

tunnel source serial2/0.1

tunnel destination 57.1.1.1

!

Then configure up your routing protocol and remove your static routes for everything but the routes to the MPLS network and you're all set... The GRE tunnel will permit whatever routing protocol your using to sync up across the tunnel and the traffic will flow across it.

Actions

This Discussion