hsrp both routers in active

Unanswered Question
May 15th, 2007

Can someone explain what the impact is when both routers of one hsrp group are in mode active, in example when you have 2 catalysts with the same interface vlan in mode active, both catalysts are connected with a L2 port-channel. Is it possible that you don't have any problem ?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Richard Burts Tue, 05/15/2007 - 14:26


It would help us give you a better answer if we knew more about your situation. Perhaps you could explain a bit more about the topology of the network.

I have seen this symptom when there was a configuration error. Perhaps you can post the configuration of both router interfaces.

I have seen this symptom when there was some connectivity issue and the two routers were not successfully communicating over the LAN. If you traceroute from one router to the interface address of the other router (not the HSRP address) do you get a response and is it one hop to the destination? Also if traceroute works, if you do show arp, do you see the MAC address of the interface on the other router in the ARP table?

I am not yet sure what the problem is. But I would be very surprised if there was no problem.



glen.grant Tue, 05/15/2007 - 16:05

If they are both active then each side is not able to communicate with the other side thus thinks it is the active side . there is a problem somewhere and redundancy will not will correctly if it is not fixed . If there are authentication strings on each side make sure they match "exactly" and that one sides priority is higher (the active side) than the other . Is it a strict l2 port channel or is it trunking also ? If a trunk then make sure the vlan for the problem hsrp subnet is allowed across the trunk on both sides .

pbogaerts Mon, 05/21/2007 - 11:03

Sorry for my late respons, but i know what the problem is, in the paste someone configured a vlan interface with hsrp and also an acl but he did forget to put the multicast address in the acl,i would like to understand why we didn't have any problems over the time when the 2 default-gateways were active


This Discussion