RDP fails

Answered Question
May 16th, 2007

I have a 501 with a VPN set up. Once the VPN is established, I rdp to an internal server. Usually, I have no problem; I can connect repeatedly from either my desktop or laptop computers.

The problem is that after another user connects RDP and disconnects, RDP is no longer available for any users. What I usually do is go in and reload the configuration. The vpn still works but RDP cannot go across it. My config is as follows:

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

clock timezone EST -5

clock summer-time EDT recurring

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol pptp 1723

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list 101 permit ip 10.1.1.0 255.255.255.0 192.168.2.0 255.255.255.0

pager lines 24

logging on

mtu outside 1500

mtu inside 1500

ip address outside X.X.X.X 255.255.255.0

ip address inside 10.1.1.1 255.255.255.0

ip verify reverse-path interface outside

ip verify reverse-path interface inside

ip audit info action alarm

ip audit attack action alarm drop

ip local pool 10.1.2.32-10.1.2.62 255.255.255.0

ip local pool ip 10.1.2.32-10.1.2.60 mask 255.255.255.0

pdm location 10.1.1.32 255.255.255.255 inside

pdm location 10.1.1.2 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list 101

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

route outside 0.0.0.0 0.0.0.0 X.X.X.1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

http 192.168.2.0 255.255.255.0 inside

http 10.1.1.32 255.255.255.255 inside

http 10.1.1.2 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

tftp-server inside 10.1.1.32 c:\cisco

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set myset

crypto map mymap 10 ipsec-isakmp dynamic dynmap

crypto map mymap interface outside

isakmp enable outside

isakmp identity address

isakmp nat-traversal 20

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup vpn address-pool ip

vpngroup vpn dns-server 10.1.1.2

vpngroup vpn wins-server 10.1.1.2

vpngroup vpn split-tunnel 101

vpngroup vpn idle-time 1800

vpngroup vpn password XXXXXXXX

telnet 10.1.1.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

management-access inside

console timeout 0

dhcpd auto_config outside

terminal width 80

I have this problem too.
0 votes
Correct Answer by acomiskey about 9 years 6 months ago

I don't see how the vpn works at all. Your acl 101 for nat exemption and split tunnel is not correct. It should be...

access-list 101 permit ip 10.1.1.0 255.255.255.0 10.1.2.0 255.255.255.0

add additional inside networks as required...

access-list 101 permit ip 10.1.2.0 255.255.255.0

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
acomiskey Wed, 05/16/2007 - 07:40

I don't see how the vpn works at all. Your acl 101 for nat exemption and split tunnel is not correct. It should be...

access-list 101 permit ip 10.1.1.0 255.255.255.0 10.1.2.0 255.255.255.0

add additional inside networks as required...

access-list 101 permit ip 10.1.2.0 255.255.255.0

peteb41976 Wed, 05/16/2007 - 09:03

This seems to be working - Let's hope it stays that way...

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password XXXX

clock timezone EST -5

clock summer-time EDT recurring

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol pptp 1723

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list 101 permit ip 10.1.1.0 255.255.255.0 10.1.2.0 255.255.255.0

pager lines 24

logging on

mtu outside 1500

mtu inside 1500

ip address outside XXXX 255.255.255.0

ip address inside 10.1.1.1 255.255.255.0

ip verify reverse-path interface outside

ip verify reverse-path interface inside

ip audit info action alarm

ip audit attack action alarm drop

ip local pool 10.1.2.32-10.1.2.62 255.255.255.0

ip local pool ippool 10.1.2.32-10.1.2.60 mask 255.255.255.0

pdm location 1.2.3.5 255.255.255.255 inside

pdm location 10.1.1.32 255.255.255.255 inside

pdm location 10.1.1.2 255.255.255.255 inside

pdm location 192.168.1.95 255.255.255.255 inside

pdm location 192.168.1.0 255.255.255.0 inside

pdm location 10.1.1.0 255.255.255.0 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list 101

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

route outside 0.0.0.0 0.0.0.0 X.X.X.X.

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

http 192.168.2.0 255.255.255.0 inside

http 10.1.1.32 255.255.255.255 inside

http 10.1.1.2 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

tftp-server inside 10.1.1.32 c:\cisco

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set myset

crypto map mymap 10 ipsec-isakmp dynamic dynmap

crypto map mymap interface outside

isakmp enable outside

isakmp identity address

isakmp nat-traversal 20

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup vpn address-pool ip

vpngroup vpn dns-server 10.1.1.2

vpngroup vpn wins-server 10.1.1.2

vpngroup vpn split-tunnel 101

vpngroup vpn idle-time 1800

vpngroup vpn password XXXX

telnet 10.1.1.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

management-access inside

console timeout 0

dhcpd auto_config outside

terminal width 80

acomiskey Wed, 05/16/2007 - 09:13

So you aren't experiencing the weird rdp issue now?

please rate if it helped.

Actions

This Discussion