Configuring Priority Queueing on Multilink PPP interface

Answered Question
May 16th, 2007
User Badges:

I have one Cisco 7206VXR (NPE-G1) with IOS version 12.3(17b) and using QoS Priority Queueing on Multilink PPP interface.

The ACL number 100 doesn?t have match, then, the QoS isn?t operating.

Do you have idea the issue? Will be IOS bug or configuration?


OBS: It follows attached configuration.









Correct Answer by bjornarsb about 9 years 10 months ago

Like this:

!

class-map match-all yellow

match qos-group 3

class-map match-all blue

match qos-group 2

!

!

policy-map clients

class blue

priority XX

class yellow

priority XX

!

!

!

crypto isakmp profile blue

match identity group cisco

client authentication list autho

isakmp authorization list autho

client configuration address respond

qos-group 2

crypto isakmp profile yellow

match identity group yellow

match identity address 10.0.0.11 255.255.255.255

client authentication list autho

isakmp authorization list autho

client configuration address respond

qos-group 3

!

!

crypto dynamic-map mode 1

set security-association lifetime seconds 180

set transform-set client

set isakmp-profile blue

reverse-route

crypto dynamic-map mode 2

set transform-set combo

set isakmp-profile yellow

reverse-route

!

!

interface FastEthernet0/0

ip address 10.0.0.110 255.255.255.0

no ip redirects

no ip proxy-arp

no ip mroute-cache

duplex half

no cdp enable

crypto map mode

service-policy out clients

!


BR,

Bjornarsb



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
bjornarsb Wed, 05/16/2007 - 10:00
User Badges:
  • Bronze, 100 points or more

Hi,


Keep in mind that using esp encrypts your IP.

You must do QOS like this:


crypto isakmp profile blue

match identity group cisco

client authentication list autho

isakmp authorization list autho

client configuration address respond

qos-group 2



Regards,

Bjornarsb

fjmendonca Wed, 05/16/2007 - 10:30
User Badges:

Hi,


But if I to configure in this way I obtain to use PQ (Priority Queueing)?


Thank you,


Fabiano

royalblues Wed, 05/16/2007 - 11:10
User Badges:
  • Green, 3000 points or more

Generally when you have encryption, QoS pre classification is used.

under the crypto map configurtion add

QoS pre-classify.


I do not know whether this will work with priority list but it works fine when you use class based QoS and running encryption


HTH, rate if it does

Narayan


Correct Answer
bjornarsb Wed, 05/16/2007 - 12:41
User Badges:
  • Bronze, 100 points or more

Like this:

!

class-map match-all yellow

match qos-group 3

class-map match-all blue

match qos-group 2

!

!

policy-map clients

class blue

priority XX

class yellow

priority XX

!

!

!

crypto isakmp profile blue

match identity group cisco

client authentication list autho

isakmp authorization list autho

client configuration address respond

qos-group 2

crypto isakmp profile yellow

match identity group yellow

match identity address 10.0.0.11 255.255.255.255

client authentication list autho

isakmp authorization list autho

client configuration address respond

qos-group 3

!

!

crypto dynamic-map mode 1

set security-association lifetime seconds 180

set transform-set client

set isakmp-profile blue

reverse-route

crypto dynamic-map mode 2

set transform-set combo

set isakmp-profile yellow

reverse-route

!

!

interface FastEthernet0/0

ip address 10.0.0.110 255.255.255.0

no ip redirects

no ip proxy-arp

no ip mroute-cache

duplex half

no cdp enable

crypto map mode

service-policy out clients

!


BR,

Bjornarsb



Actions

This Discussion