Notification when Uplinks go down

Answered Question
May 16th, 2007
User Badges:

Whats the easiest way for me to get notifications when the uplinks on my 3560-24T's shutdown/disconnect from each other? Also can the same idea/steps be applied to 3550-12Gs?


I tried turning on logging in the Cisco Network Assistant but I ended up getting notified on every single port status change like when a computer gets rebooted.

Correct Answer by sundar.palaniappan about 9 years 10 months ago

You should be able to disable link status traps on access ports with the interface command 'no logging event link-status. This should filter all the unwanted traps.


SW1-3550(config)#logging trap 5

SW1-3550(config)#int range f0/1 - 23

SW1-3550(config-if-range)#no logging event ?

bundle-status BUNDLE/UNBUNDLE messages

link-status UPDOWN and CHANGE messages

spanning-tree Spanning-tree Interface events

trunk-status TRUNK status messages

SW1-3550(config-if-range)#no logging event link-status

SW1-3550(config-if-range)#int f0/24

SW1-3550(config-if)#logging event link-status

SW1-3550(config-if)#do show run int f0/24

Building configuration...


Current configuration : 119 bytes

!

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

SW1-3550(config-if)#do show run int f0/23

Building configuration...


Current configuration : 99 bytes

!

interface FastEthernet0/23

switchport mode dynamic desirable

no logging event link-status


HTH


Sundar

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.8 (5 ratings)
Loading.
royalblues Wed, 05/16/2007 - 13:50
User Badges:
  • Green, 3000 points or more

Unfortunately all the link up/down status are sent as level 3 syslog messages or errors. This will include both the access as well as your trunk ports between the switches


I dont think there is any specific MIB either for you to get this information to a network management station.


Narayan

Correct Answer
sundar.palaniappan Wed, 05/16/2007 - 14:08
User Badges:
  • Green, 3000 points or more

You should be able to disable link status traps on access ports with the interface command 'no logging event link-status. This should filter all the unwanted traps.


SW1-3550(config)#logging trap 5

SW1-3550(config)#int range f0/1 - 23

SW1-3550(config-if-range)#no logging event ?

bundle-status BUNDLE/UNBUNDLE messages

link-status UPDOWN and CHANGE messages

spanning-tree Spanning-tree Interface events

trunk-status TRUNK status messages

SW1-3550(config-if-range)#no logging event link-status

SW1-3550(config-if-range)#int f0/24

SW1-3550(config-if)#logging event link-status

SW1-3550(config-if)#do show run int f0/24

Building configuration...


Current configuration : 119 bytes

!

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

SW1-3550(config-if)#do show run int f0/23

Building configuration...


Current configuration : 99 bytes

!

interface FastEthernet0/23

switchport mode dynamic desirable

no logging event link-status


HTH


Sundar

Joe Clarke Sat, 05/19/2007 - 15:13
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

no logging event link-status will filter out syslog messages, but not SNMP traps. To disable SNMP link traps for certain interfaces, you also need the following under each interface:


no snmp trap link-status

ricky-li Fri, 05/25/2007 - 11:11
User Badges:

Thanks everyone, the SNMP traps actually worked easier than the syslogs because I'm using intermapper the traps got sent out automatically once they were received.

ricky-li Fri, 05/25/2007 - 13:23
User Badges:

its' working too great, does anyone know what this means all the switches are generating these messages at some random interval:



05/25 11:12:45: Message from InterMapper 4.5.5


Event: TRAP

Name: 9f-out-3524xl

Document: 1164-C1-switches

Address: 10.10.21.13

Probe Type: SNMP MIB-II (port 161 SNMPv1)

Condition: SNMPv2-SMI::enterprises.9.0.1 (v2c) {

SNMPv2-SMI::enterprises.9.2.9.3.1.1.1.1 : "5",

TCP-MIB::tcpConnState.10.181.69.64.23.10.8.29.128.55297 : "5",

SNMPv2-SMI::enterprises.9.2.6.1.1.5.10.181.69.64.23.10.8.29.128.55297 :

"78624", SNMPv2-SMI::enterprises.9.2.6.1.1.1.10.181.69.64.23.10.8.29.128.55297

: "729", SNMPv2-SMI::enterprises.9.2.6.1.1.2.10.181.69.64.23.10.8.29.128.55297

: "17219", SNMPv2-SMI::enterprises.9.2.9.2.1.18.1 : "" }


Time since last reported down: N/A

Device's up time: 27 days, 21 hours, 4 minutes, 4 seconds


Joe Clarke Fri, 05/25/2007 - 13:36
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This is a tcpConnectionClose trap. It indicates a TCP (most likely a telnet) session has closed. You can disable these traps by removing the "tty" keyword from your trap config.

Actions

This Discussion