SIP 400 Bad Request

Unanswered Question

I'm getting a bad request error when attempting to an outbound SIP call on a IP2IP gateway (H323 -> SIP).


It's a slightly odd configuration as we will only be using this route for outgoing calls only. The only error message I get is:

//-1/xxxxxxxxxxxx/SIP/Error/sipsdp_add_standard_lines: media_src_address is NULL; c-line is not added



SIP Invite message:


Sent:

INVITE sip:[email protected]:5060 SIP/2.0

Via: SIP/2.0/UDP 192.168.1.1:5060;branch=z9hG4bK11222C

From: "anonymous" <sip:[email protected]>;tag=404CF30-282

To: <sip:[email protected]>

Date: Wed, 16 May 2007 13:09:44 GMT

Call-ID: [email protected]

Supported: 100rel,timer

Min-SE: 1800

Cisco-Guid: 15103203-2971783453-520093696-2887190163

User-Agent: Cisco-SIPGateway/IOS-12.x

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE, NOTIFY, INFO, UPDATE, REGISTER

CSeq: 101 INVITE

Max-Forwards: 70

Remote-Party-ID: <sip:[email protected]>;party=calling;screen=yes;privacy=full

Timestamp: 1179320984

Contact: <sip:[email protected]:5060>

Call-Info: <sip:192.168.1.1:5060>;method="NOTIFY;Event=telephone-event;Duration=2000"

Expires: 180

Allow-Events: telephone-event


May 16 13:09:44.608 UTC: //-1/xxxxxxxxxxxx/SIP/Info/HandleUdpSocketReads: Msg enqueued for SPI with IP addr: 192.168.1.2:5060

May 16 13:09:44.608 UTC: //-1/xxxxxxxxxxxx/SIP/Transport/sipTransportProcessNWNewConnMsg: context=0x00000000

May 16 13:09:44.608 UTC: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:SIP/2.0 400 Bad Request

Via: SIP/2.0/UDP 192.168.1.1:5060;branch=z9hG4bK11222C

From: "anonymous" <sip:[email protected]>;tag=404CF30-282

To: <sip:[email protected]>

Call-ID: [email protected]

CSeq: 101 INVITE

User-Agent: 2N StarGate V-02.20.47

Allow: INVITE, BYE, ACK, CANCEL, OPTIONS

Content-Length: 0



Any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
joncbanks Tue, 05/22/2007 - 02:35
User Badges:

Hi


Have you found a solution to this? I'm getting the exact same SIP error message and we are also using a H323-to-SIP gateway.

However rather than getting a 400 error I am recieving a 480 error - Temporarily Unavailable.


I'm connecting to a Mitel PBX via a SIP trunk.

joncbanks Tue, 05/22/2007 - 02:51
User Badges:

Hi


Have you found a solution to this? I'm getting the exact same SIP error message and we are also using a H323-to-SIP gateway.

However rather than getting a 400 error I am recieving a 480 error - Temporarily Unavailable.


I'm connecting to a Mitel PBX via a SIP trunk.

tboynton Wed, 05/23/2007 - 05:49
User Badges:

For what its worth, I had the same problem from Callmanager to an IOS IPIPGW. I was getting the SIP/2.0 400 Bad Request - 'Malformed/Missing Contact field' error message. Turns out I had mistyped my caller id mask and was sending characters in place of numbers. By correcting it, my problem went away.


Todd

Actions

This Discussion