Ping works while telnet fails

Unanswered Question
May 17th, 2007

Hi all,

Here is an approach to the network diagram:

CE - Satellite - MetroEthernet - PE - NOC

The thing is that we can ping any CE from the NOC but suddenly telnet doesn't work. Here is a debug ip packet in the CE when I try to telnet from a compuner of the NOC:

CE01#deb ip pack det 101

IP packet debugging is on (detailed) for acCE01ss list 101

CE01#term mon

CE01#

.May 17 10:01:27.590: IP: tableid=0, s=172.26.26.99 (FastEthernet0), d=10.9.169.179 (Loopback0), routed via RIB

.May 17 10:01:27.590: IP: s=172.26.26.99 (FastEthernet0), d=10.9.169.179, len 48, rcvd 4

.May 17 10:01:27.590: TCP src=1192, dst=23, seq=3227178390, ack=0, win=64512 SYN

.May 17 10:01:27.590: IP: tableid=0, s=10.9.169.179 (local), d=172.26.26.99 (FastEthernet0), routed via FIB

.May 17 10:01:27.594: IP: s=10.9.169.179 (local), d=172.26.26.99 (FastEthernet0), len 44, sending

.May 17 10:01:27.594: TCP src=23, dst=1192, seq=1033714810, ack=3227178391, win=4128 ACK SYN

CE01#

.May 17 10:01:29.594: IP: tableid=0, s=10.9.169.179 (local), d=172.26.26.99 (FastEthernet0), routed via FIB

.May 17 10:01:29.594: IP: s=10.9.169.179 (local), d=172.26.26.99 (FastEthernet0), len 44, sending

.May 17 10:01:29.594: TCP src=23, dst=1192, seq=1033714810, ack=3227178391, win=4128 ACK SYN

.May 17 10:01:30.550: IP: tableid=0, s=172.26.26.99 (FastEthernet0), d=10.9.169.179 (Loopback0), routed via RIB

.May 17 10:01:30.550: IP: s=172.26.26.99 (FastE

CE01#thernet0), d=10.9.169.179, len 48, rcvd 4

.May 17 10:01:30.550: TCP src=1192, dst=23, seq=3227178390, ack=0, win=64512 SYN

.May 17 10:01:30.550: IP: tableid=0, s=10.9.169.179 (local), d=172.26.26.99 (FastEthernet0), routed via FIB

.May 17 10:01:30.554: IP: s=10.9.169.179 (local), d=172.26.26.99 (FastEthernet0), len 40, sending

.May 17 10:01:30.554: TCP src=23, dst=1192, seq=1033714810, ack=3227178391, win=4128 ACK

.May 17 10:01:33.594: IP: tableid=0, s=10.9.169.179 (local), d=172.26.26.99 (FastEthernet0), routed via FIB

.May 17 10:01:33.594: IP: s=10.9.169.179 (local), d=172.26.26.99 (FastEthernet0), len 44, sending

.May 17 10:01:33.594: TCP src=23, dst=1192, seq=1033714810, ack=3227178391, win=4128 ACK SYN

CE01#

.May 17 10:01:36.678: IP: tableid=0, s=172.26.26.99 (FastEthernet0), d=10.9.169.179 (Loopback0), routed via RIB

.May 17 10:01:36.678: IP: s=172.26.26.99 (FastEthernet0), d=10.9.169.179, len 48, rcvd 4

.May 17 10:01:36.678: TCP src=1192, dst=23, seq=3227178390, ack=0, win=64512 SYN

.May 17 10:01:36.682: IP: tableid=0, s=10.9.169.179 (local), d=172.26.26.99 (FastEthernet0), routed via FIB

.May 17 10:01:36.682: IP: s=10.9.169.179 (local), d=172.26.26.99 (FastEthernet0), len 40, sending

.May 17 10:01:36.682: TCP src=23, dst=1192, seq=1033714810, ack=3227178391, win=4128 ACK

CE01#

.May 17 10:01:41.594: IP: tableid=0, s=10.9.169.179 (local), d=172.26.26.99 (FastEthernet0), routed via FIB

.May 17 10:01:41.594: IP: s=10.9.169.179 (local), d=172.26.26.99 (FastEthernet0), len 44, sending

.May 17 10:01:41.594: TCP src=23, dst=1192, seq=1033714810, ack=3227178391, win=4128 ACK SYN

CE01#

It seems good to me, but telnet don't works...

Any idea?

Thanks a lot in advance,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
desai.jaideep Thu, 05/17/2007 - 02:45

Hi

have u checked after clearing the line on CE routers?

maybe you have blocked telnet access?

Regards

JD

enriquebs Thu, 05/17/2007 - 02:49

Yes, it's checked. Line VTY is permitting telnet.

And the "debug ip packets" output shows the telnet session from my computer, but It doesn't works... there are no firewalls in this side of the network.

Thanks,

enriquebs Thu, 05/17/2007 - 03:30

I've realized that sequence number and ACK are always the same, it doesn't change, just the window size in the reply:

.May 17 10:01:27.590: TCP src=1192, dst=23, seq=3227178390, ack=0, win=64512 SYN

.May 17 10:01:27.594: TCP src=23, dst=1192, seq=1033714810, ack=3227178391, win=4128 ACK SYN

enriquebs Thu, 05/17/2007 - 05:14

access-list 101 permit ip host 172.26.26.99 host 10.9.169.179

access-list 101 permit ip host 10.9.169.179 host 172.26.26.99

Manoj Wadhwa Thu, 05/17/2007 - 08:51

Can you also please try using ssh instead and let us know if it works . Thanks!

Actions

This Discussion