Can I sub-interface this 6500 blade?

Unanswered Question
May 17th, 2007
User Badges:

I have a 6500 with a WS-X6724-SFP blade

in it and IOS 12.2(18)SXE3.


I need connect a 3750 switch to one of the SFP ports on the blade. This 3750 switch will have PC's and IP phones connected and will have a data and voice vlan.


data vlan = 6

voice vlan = 910


I want to make the ws-x6724 port a routed port with sub-interfaces for the two vlans. The commands take, but I cannot ping the switch, nor can the switch ping the router port.


I remove the sub-interfaces, re-address the primary interface and I can ping the switch.


Config with sub-interfaces that does not work:


interface GigabitEthernet3/24

no ip address

!

interface GigabitEthernet3/24.6

encapsulation dot1Q 6

ip address 161.2.6.1 255.255.255.128


Config without sub-interfaces which works:


interface GigabitEthernet3/24

ip address 161.2.6.1 255.255.255.128


3750 switch config:


All interfaces are:

switchport access vlan 6


int vlan 6

ip address 164.72.6.15 255.255.255.128


ip default-gateway 164.72.6.1


Can the ws-x6724-sfp do sub-interfaces and if so why do you think I can't ping the switch?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ankbhasi Thu, 05/17/2007 - 10:52
User Badges:
  • Cisco Employee,

Hi Friend,


I believe the reason is when you create sub interface you are specifying dot1q tag for vlan 6 but on 3750 switch the port is configured as an access port which will send the vlan 6 traffic without any tag and cat 6k subinterface will drop the traffic.


So try to configure the 3750 switchport as trunk port and allow vlan 6 only or on the subinterface dot1q command specify native keyword after vlan number something like this


encapsulation dot1Q 6 native


Try this and update if it works.


Regards,


Ankur


*Pls rate all helpfull post

glen.grant Thu, 05/17/2007 - 16:46
User Badges:
  • Purple, 4500 points or more

Thats the hard way to do it , just create your layer 2 vlans on each side then create the corresponding layer 3 SVI's . Then create your trunk link between the 2 switches. Don't really get your addressing your vlan 6 addresses on each side are in different subnets so I don't know how it could work at all . on the 6500 it is in the 161.2.6 and on the 3750 it is 164.72.6 .



jkeeffe Fri, 05/18/2007 - 06:35
User Badges:

I made a mistake on the IP address in the 3750 switch - it should be:


int vlan 6

ip address 161.2.6.15 255.255.255.128


ip default-gateway 161.2.6.1


Thanks for you ideas and I'll give it a try also.

Actions

This Discussion