Slow internet performance

Unanswered Question
May 17th, 2007
User Badges:

Dears;


Attached is a network topology and explanation that i have , i have made load balance on R2 to forward the traffic to five links , 4 of them are connected to R1 through Serial interfaces and the fifth one is connected to R1 by connecting R2 to a R-T through tunnel and then from R-T to R1 trough another tunnel,


i have bad inter net performance now, can you suggest a solution plz.


Regards



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
spremkumar Thu, 05/17/2007 - 19:21
User Badges:
  • Red, 2250 points or more

Hi Mahmoud


From your query i understand you are trying to load balance over 5 links on which 4 of them are point to point links and the 5th one being a tunnel created over internet.


I feel you are facing this problem because of difference in the latency between a point to point and the tunnel created over internet.


Though logically you are bypassing the hops comes on the internet cloud by creating a logical tunnel between your locations you don't have any control on the latency through that link..


Thats the reason i feel you are facing issues with the performance.


Better take out the tunnel from load balancing act and check out for the performance.


regds



mahmoud.abotaleb7 Thu, 05/17/2007 - 20:04
User Badges:

Hi Kumar;


i have take out it , performance was good without it , but i noticed from ping that Avg. RTD of tunnel is the same as all other links , so there is no latency problem. i do not know what is the problem that cause web pages to take so much time to be opened and also i noticed that when trying to refresh the page while its loading then it comes faster...!!!


Regards

Hi Mahmoud,


Try to configure "ip tcp adjust-mss 1400" on the LAN interface of R2. This will probably solve the tcp problem caused by the tunnel mtu. Are the 4 links bundled on layer2 (mppp, mfr) or on layer3? If you use per destination load sharing then the latency is not necessarily problem (I think) but if per packet loadsharing used will may experince some problems due to latency.


Krisztian

mahmoud.abotaleb7 Mon, 05/21/2007 - 14:18
User Badges:

Hello;


it works fine now , but i monitored the Load on Links i see that the tunnel is carrying more than the other links, is that normal ,, i do not know why ,, can anyone explain plz ..??


Regards //

Actions

This Discussion