OSPF neigboring issue

Unanswered Question
May 18th, 2007
User Badges:

Hi, I have configured my router to run OSPF and established adj with other routers (thru switch). However there are 2 routers that wont established the adj. It keep appears below log. It is in the same network/subnet. The MTU is 1500. What is other posibble things to check?


FastEthernet5/0/0 from 2WAY to DOWN, Neighbor Down: Interface down or detached

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
royalblues Fri, 05/18/2007 - 05:22
User Badges:
  • Green, 3000 points or more

Mazlan,


Check the cable connection to fastethernet 5/0/0. There may be a speed/duplex issue which is causing the interface to go down and thus breaking your adjacency


HTH, rate if it does

Narayan

mazlan.alatif Fri, 05/18/2007 - 05:29
User Badges:

Narayan,


The connection is up. This interface also established ospf neigbor with other routers except 2 router. It keep stuck in exchange state. Also have check the MTU. It is same for all routers connected.

royalblues Fri, 05/18/2007 - 05:35
User Badges:
  • Green, 3000 points or more

Mazlan,


If all the four routers are connected to a LAN segment, OSPF would choose a DR and BDR and all the routers would establish adjacencies only with these 2 routers.


But the status of the routers would not be in exchange but in a stae of 2-way..


Can you post your configurations


HTH, rate if it does

Narayan

guruprasadr Fri, 05/18/2007 - 05:32
User Badges:
  • Gold, 750 points or more

HI Mazlan, [Pls Rate if Helps]


After creating / "Changing" a OSPF router id inorder to take effect you need to reload the router / reset the ospf process. Pls try cmd below:


#clear ip ospf process

Reset All OSPF Process[n]:yes

#show ip ospf neighbor


Pls Rate if Helps ! !


Best Regards,

Guru Prasad R

mazlan.alatif Fri, 05/18/2007 - 05:37
User Badges:

Hi guruprasadr,


Why I need to change router ID. This router has established neigbor with other routers as well. However i have tried this but still same. :(


--mazlan

royalblues Fri, 05/18/2007 - 05:43
User Badges:
  • Green, 3000 points or more

Would it be possible for you to paste the sh ip ospf neighbors from all the 4 routers


Narayan

guruprasadr Fri, 05/18/2007 - 05:44
User Badges:
  • Gold, 750 points or more

HI Mazlan,


Try this command twice / thrice. Can you please check by rebooting the router.


Number of LSA's should be same on all the Routers.Check with "show ip ospf database database-summary" cmd to observe.


Check "show ip ospf database" to check the LSA's on all routers.


Pls Rate if Helps ! !


Best Regards,

Guru Prasad R

mazlan.alatif Fri, 05/18/2007 - 05:53
User Badges:

Hi Prasad,


Thank you. I have check the number of LSA and it is same througout the network.


Area 0 database summary

LSA Type Count Delete Maxage

Router 116 0 0

Network 30 0 0

Summary Net 2393 0 0

Summary ASBR 269 0 0

Type-7 Ext 0 0 0

Prefixes redistributed in Type-7 0

Opaque Link 0 0 0

Opaque Area 4 0 0

Subtotal 2812 0 0



guruprasadr Fri, 05/18/2007 - 05:58
User Badges:
  • Gold, 750 points or more

HI Mazlan,


Whether this solved your Issue. Can you pls confirm / post the configuration.


Pls Rate if Helped you to identify / solve.


Best Regards,

Guru Prasad R

mazlan.alatif Mon, 05/21/2007 - 00:52
User Badges:

I have checked seems everything is ok. excpt it still wont established neigborship.. below logs keeps appears. have run debug i osf adj, the mtu is 1500.. any ideas??


May 21 16:47:50.754: %OSPF-5-ADJCHG: Process 1, Nbr 61.6.191.77 on GigabitEthernet0/0/0 from DOWN to DOWN, Neighbor Down: Dead timer expired

61.6.163.160 for invalid RP 161.142.158.14

May 21 16:49:11.431: %OSPF-5-ADJCHG: Process 1, Nbr 61.6.191.77 on GigabitEthernet0/0/0 from EXSTART to DOWN, Neighbor Down: Too many DBD retransmitions


Debup output:


May 21 16:51:32.417: OSPF: Retransmitting DBD to 61.6.191.77 on GigabitEthernet0/0/0

May 21 16:51:32.417: OSPF: 61.6.191.77 address 161.142.173.70 on GigabitEthernet0/0/0 is dead, state DOWN

May 21 16:51:32.417: %OSPF-5-ADJCHG: Process 1, Nbr 61.6.191.77 on GigabitEthernet0/0/0 from EXSTART to DOWN, Neighbor Down: Too many DBD retransmitions

May 21 16:51:33.388: OSPF: Nbr 61.6.191.77 161.142.173.70 GigabitEthernet0/0/0 is currently ignored

May 21 16:51:35.926: OSPF: Nbr 61.6.191.77 161.142.173.70 GigabitEthernet0/0/0 is currently ignored

May 21 16:51:38.641: OSPF: Nbr 61.6.191.77 161.142.173.70 GigabitEthernet0/0/0 is currently ignored

May 21 16:51:43.096: OSPF: Nbr 61.6.191.77 161.142.173.70 GigabitEthernet0/0/0 is currently ignored



Harold Ritter Mon, 05/21/2007 - 04:41
User Badges:
  • Cisco Employee,

Mazlan,


Can you try configuring "no capability lls" to see if it makes a difference.


Hope this helps,

mazlan.alatif Mon, 05/21/2007 - 05:13
User Badges:

Harold,


I have tried but still same. This router wont established neibor with one router.


It keep stuck at exstart state.

Harold Ritter Mon, 05/21/2007 - 05:15
User Badges:
  • Cisco Employee,

Mazlan,


Can you run a "deb ip ospf adj" on the opposite router as well.


Thanks,

mazlan.alatif Mon, 05/21/2007 - 05:28
User Badges:

Harold,


Below is the output from opposite router when i run debug ospf adj.


May 21 21:27:49.603: OSPF: Up DBD Retransmit cnt to 3 for 61.6.191.77 on FastEthernet5/0/0

May 21 21:27:49.603: OSPF: Send DBD to 61.6.191.77 on FastEthernet5/0/0 seq 0xDAB opt 0x52 flag 0x7 len 32

May 21 21:27:54.603: OSPF: Retransmitting DBD to 61.6.191.77 on FastEthernet5/0/0

May 21 21:27:54.603: OSPF: Up DBD Retransmit cnt to 4 for 61.6.191.77 on FastEthernet5/0/0

May 21 21:27:54.603: OSPF: Send DBD to 61.6.191.77 on FastEthernet5/0/0 seq 0xDAB opt 0x52 flag 0x7 len 32

May 21 21:27:59.603: OSPF: Retransmitting DBD to 61.6.191.77 on FastEthernet5/0/0


044102947 Mon, 05/21/2007 - 04:46
User Badges:

Hi Mazlan,


What kind of switch u are using to connect routers, if it is manageable please check the VLAN configuration of switch, or please check the HELO and HOLD DOWN timers on routers.


Actions

This Discussion