cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
717
Views
6
Helpful
3
Replies

No QoS Stats on Cat 3750 VLAN

aoshea
Level 1
Level 1

Dear Support,

Have a small setup of 4 site, and using QoS to mark certain traffic.

However, I'm not sure if it's working or that the ASIC's on the switch don't allow for tracking the stats like a router.

I've done the marking and classification on the VLAN rather than the port, and set the routed port that connects between sites to 'trust' the markings.

Can someone point me in the right direction?

Thanks in advance.

I always rate helpful posts.

class-map match-any SAN-Replication

description Mark SAN replication traffic based on ACL Match-SAN

match access-group name Match-SAN

class-map match-any VOICE-Control

match ip dscp af31

class-map match-any VOICE

match ip dscp ef

class-map match-any Citrix-Traffic

description Match Citrix Traffic based on ACL Match-Citrix

match access-group name Match-Citrix

!

!

policy-map BRANCH-WAN-EDGE

class Citrix-Traffic

set dscp cs3

class SAN-Replication

set dscp af41

class VOICE

set dscp ef

class VOICE-Control

set dscp af31

class class-default

set dscp default

!

!

ip access-list extended Match-Citrix

permit tcp any eq 1494 any

permit tcp any any eq 1494

remark Match Citrix ICA traffic based upon TCP 1494

ip access-list extended Match-SAN

permit ip host 192.168.104.100 host 192.168.204.100

permit ip host 192.168.204.100 host 192.168.104.100

remark Match SAN replication Traffic

ip access-list extended SAN-Replication-Traffic

remark ACL to identify SAN replication traffic

permit ip host 192.168.204.100 host 192.168.104.100

!

route-map PBR-for-SAN permit 10

match ip address SAN-Replication-Traffic

set ip next-hop 192.168.254.2

!

route-map PBR-for-SAN permit 20

!

interface FastEthernet1/0/1

description LES 100 circuit to site1

no switchport

ip address 192.168.254.5 255.255.255.252

ip ospf network point-to-point

speed 100

duplex full

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust dscp

auto qos voip trust

!

!

interface FastEthernet1/0/3

description LES 100 circuit for SAN

no switchport

ip address 192.168.254.1 255.255.255.252

ip ospf network point-to-point

ip ospf cost 3

speed 100

duplex full

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust dscp

auto qos voip trust

!

!

interface FastEthernet1/0/5

description LES 100 circuit to site2

no switchport

ip address 192.168.254.9 255.255.255.252

ip ospf network point-to-point

speed 100

duplex full

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust dscp

auto qos voip trust

!

interface FastEthernet1/0/7

description server port

switchport access vlan 100

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

spanning-tree guard root

!

interface FastEthernet1/0/8

description user port

switchport access vlan 304

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

spanning-tree guard root

!

interface Vlan100

description Server VLAN DR Site

ip address 192.168.100.250 255.255.254.0

service-policy input BRANCH-WAN-EDGE

shutdown

!

interface Vlan304

description Management VLAN

ip address 192.168.204.250 255.255.255.0

service-policy input BRANCH-WAN-EDGE

ip policy route-map PBR-for-SAN

!

router ospf 100

log-adjacency-changes

network 192.168.100.0 0.0.1.255 area 0

network 192.168.204.0 0.0.0.255 area 0

network 192.168.254.0 0.0.0.3 area 0

network 192.168.254.4 0.0.0.3 area 0

network 192.168.254.8 0.0.0.3 area 0

1 Accepted Solution

Accepted Solutions

johgill
Level 1
Level 1

QoS on a switch is mostly about Tx queues and the mappings of markings. The marking and policing happens in policy-maps, but not much else usually - very different from router QoS.

Be careful on switches, "show policy-map interface" is not supported for stats on the 3750. Always be sure "mls qos" is enabled, and think of QoS as a L1 technology, to be used on physical interfaces.

You can use VLAN-based QoS, but remember that policy gets applied as a copy to the interfaces who have "mls qos vlan-based" configured, and in that VLAN.

Some good stats for the 3750/3560/2960 are:

sh mls qos int stats

sh plat port-asic stats drop

sh plat port-asic stats enq

Until QoS is enabled, the stats count on the last queue, last threshold. You cannot clear the port-asic stats, but you can clear mls qos int stats with "clear mls qos int statistics".

Also, "class default" is not supported either.

View solution in original post

3 Replies 3

bjornarsb
Level 4
Level 4

Hi,

First I would say that you should do marking and classification on input and then QOS on your output wan interface.

Second I cannot see that you are doing QOS , you have just configured marking.

Does your ISP's configuration match your marking ?

exa:

!--- Create a class map named Voice.

Router(config)#class-map Voice

!--- Specifies the packet that matches criteria that

!--- identifies voice packets that have a DSCP value of "ef".

Router(config-cmap)#match dscp ef

!--- Create a policy to be applied to a set

!--- of voice traffic.

Router(config-cmap)#policy-map Voicepolicy

!--- Specify the class name created in order to apply

!--- the action to it.

Router(config-pmap)#class Voice

!--- Strict scheduling priority for the class Voice.

Router(config-pmap-c)#priority

!--- Apply the policy defined to the outside interface.

Router(config-pmap-c)#service-policy Voicepolicy interface outside

To have full utilization of QOS you need to aggree with your ISP on both output traffic and return traffic.

HTH

Regards,

Bjornarsb

Hi Bjornarsb,

Many thanks for the reply, I believe I've worked out myself what the issue was, on catalyst switches VLAN classification the port needs to be configured;

i.e.

mls qos vlan-based.

thanks anyway.

regards, adrian.

johgill
Level 1
Level 1

QoS on a switch is mostly about Tx queues and the mappings of markings. The marking and policing happens in policy-maps, but not much else usually - very different from router QoS.

Be careful on switches, "show policy-map interface" is not supported for stats on the 3750. Always be sure "mls qos" is enabled, and think of QoS as a L1 technology, to be used on physical interfaces.

You can use VLAN-based QoS, but remember that policy gets applied as a copy to the interfaces who have "mls qos vlan-based" configured, and in that VLAN.

Some good stats for the 3750/3560/2960 are:

sh mls qos int stats

sh plat port-asic stats drop

sh plat port-asic stats enq

Until QoS is enabled, the stats count on the last queue, last threshold. You cannot clear the port-asic stats, but you can clear mls qos int stats with "clear mls qos int statistics".

Also, "class default" is not supported either.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco