BGP Peers

Unanswered Question
May 20th, 2007
User Badges:

Hi,


When i doing the BGP home lab, i came to notice that when iam establishing the BGP session between the two private AS which comes under a single public AS


It is forming the adjacency without giving the command #bgp confederation peers (Private AS number)


The one of the router is running of Version 12.2(5)and other router router is 12.2(8)


I dont know why its happening and i tried of shutdown the interface and made the interface UP, same think is happening


can u help me know abt the issue,other think when i try to establish the bgp session between the One public AS to other Privte AS (Which comes under a Public As)without giving the command # bgp conferderation identifier (Public AS)


Then it showing me the NOTIFICATION ERROR MSG


So Why not the above think is not happening


Thanks in advance

Vinoth



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bjornarsb Mon, 05/21/2007 - 00:18
User Badges:
  • Bronze, 100 points or more

Hi,


I belive that you have to specify both

confederation identifier and every peer you have in you condederation to make this work:



router bgp 2120

bgp confederation identifier 500

bgp confederation peers 6001 6003

neighbor 10.70.70.1 remote-as 6002

neighbor 172.16.232.57 remote-as 6001

neighbor 172.16.232.56 remote-as 6003

neighbor 10.99.99.2 remote-as 700



Regards,

Bjornarsb

vinoth.kumar Mon, 05/21/2007 - 01:45
User Badges:

Thanks for information,


As 65510 R1----------R2 AS 65520


---------------------------------------------Both R1 and R2 comes under Public AS of 20


What i want to know is whether the TCP connection will establish without giving the command as


R1 # BGP Conferderation peer 65520

and in

R2 # BGP Conferderation peers 65510


Regards,

vinoth




CSCO10892433 Mon, 05/21/2007 - 03:32
User Badges:
  • Silver, 250 points or more

Hi, vinoth


Without the bgp confederation peer command, both routers will see each other as a true EBGP peer. R1 will send an open message with AS=20 to R2 and expect to recevie an open message from R2 with AS=65520.

R2 do the same thing.(send an open message with AS=20 and expect to receive an open message with AS=65510). And the result is a wrong-AS issue. Theorectically, the BGP session cannot be established.


And why did your routers can establsh the session successfully? I don't know. Wait the expert to answer you.(Harold, where are you?) Before that, it's a good idea to issue the debug ip bgp command on your routers and see what messages are brought to you.


HTH

SSLIN

Harold Ritter Mon, 05/21/2007 - 05:14
User Badges:
  • Cisco Employee,

SSLIN,


You are correct the session should not come up given the above scenario.


Vinoth,


Can you provide the full configurations from both R1 and R2 that led to that mysterious behavior.


Regards,

vinoth.kumar Mon, 05/21/2007 - 21:44
User Badges:



20.0.0.1/8 .2

R2 ----------------- R3

As|65510 As 65520

-----|------------------------------

| Public As 20

|

|10.0.0.1/8

R1

Public As 10



R1#Router bgp 10

#neighbour 10.0.0.2 remote-as 65510

#network 10.0.0.0


R2#router bgp 65510

#neighbour 20.0.0.2 remote-as 65520

#neighbour 10.0.0.1 remote-as 10

#bgp conferderation identifier 10


R3#router bgp 65520

#neighbour 20.0.0.1 remote-as 65510


This what i have done in my home lab and i found that the adjacency is formed between the routers


can u suggest me were is the route cause for this issue


Note : R2 is running on version 12.2 (5)

R3 is running on version 12.2 (8)


Thanks in advance,

vinoth

CSCO10892433 Tue, 05/22/2007 - 03:27
User Badges:
  • Silver, 250 points or more

Hi, Vinoth


I try your config and the result is the same.


R2's debugging message


received from neighbor 20.0.0.2 2/2 (peer in wrong AS) 2 bytes 0014


R3's debugging message


BGP: 20.0.0.1 bad OPEN, remote AS is 20, expected 65510


show ip bgp summary on R2


Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

20.0.0.2 4 65520 8 8 0 0 0 never Active


show ip bgp summary on R3

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

20.0.0.1 4 65510 8 8 0 0 0 never Active


Would you please post your output of "debug ip bgp" and "show ip bgp summary"?


SSLIN


Harold Ritter Tue, 05/22/2007 - 04:50
User Badges:
  • Cisco Employee,

This is not normal. I tried with 12.2(10) and the session didn't come up.


You are probably running in to some older bug. I would suggest you try with more recent code, in which case you should see that the session won't form.


Hope this helps,

Actions

This Discussion