password?

Answered Question
May 21st, 2007
User Badges:

Here is question about the configuration of switch in ccna, to setup a password for a switch is like: Switch(config)#enable password XXXX,but I see another cmd in my test parebook :Switch(config)#enable password level level_# XXXX.as the privillge of admin exec the level is 15 as i know but after I typed the cmd Swith(config)#enable password level 15 XXXX and then I exit the config mode,reaccess the switch the system require the password after I enter XXXX the system does not let me in what's gonna wrong?Is the problem of lever#?how to set the # of level?

Correct Answer by mohammedmahmoud about 9 years 10 months ago

Hi,


Your main problem may be that you are using both enable password and enable secret, in such case the enable secret overrides the enable password, and thus the enable password will not let you in.


More over, if you use this command:


Router(config)#enable password level 15 cisco"


And then display the router configuration, since level 15 is the default:


Router#sh run | i enable

enable password cisco


Level --> Level for which the password applies. You can specify up to 16 privilege levels, using numbers 0 through 15. Level 1 is normal EXEC-mode user privileges. If this argument is not specified in the command or the no form of the command, the privilege level defaults to 15 (traditional enable privileges).


Please check out this link:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_command_reference_chapter09186a00800d980c.html




HTH, please do rate all helpful replies,

Mohammed Mahmoud.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.3 (3 ratings)
Loading.
CSCO10892433 Mon, 05/21/2007 - 01:21
User Badges:
  • Silver, 250 points or more

Hi, tinyue998


Is the switch prompt you to enter console password or enable password after you type in "enable" command?


More information from you and we can help.


SSLIN

tinyue998 Mon, 05/21/2007 - 17:36
User Badges:

the switch did not prompt me to enter a password of console ,only prompt me to input the switch password but the password i setup can not passed by the switch,

CSCO10892433 Mon, 05/21/2007 - 01:43
User Badges:
  • Silver, 250 points or more

Do a test on dynamips. I have no problem with this command. Please see the attachment. Maybe it can provide some helps.


BTW, if you did not save your configuration, just power off the swith and power it on again. This will bring you to the initial state and you can try it again.


HTH

SSLIN



Attachment: 
Correct Answer
mohammedmahmoud Mon, 05/21/2007 - 01:44
User Badges:
  • Green, 3000 points or more

Hi,


Your main problem may be that you are using both enable password and enable secret, in such case the enable secret overrides the enable password, and thus the enable password will not let you in.


More over, if you use this command:


Router(config)#enable password level 15 cisco"


And then display the router configuration, since level 15 is the default:


Router#sh run | i enable

enable password cisco


Level --> Level for which the password applies. You can specify up to 16 privilege levels, using numbers 0 through 15. Level 1 is normal EXEC-mode user privileges. If this argument is not specified in the command or the no form of the command, the privilege level defaults to 15 (traditional enable privileges).


Please check out this link:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_command_reference_chapter09186a00800d980c.html




HTH, please do rate all helpful replies,

Mohammed Mahmoud.


Actions

This Discussion