ASA 5510 and static route

Unanswered Question
May 21st, 2007

Hi all.

This is my first setup of a Cisco ASA box.

I'm having a lot of problems with use of static route

If I make a PING from the ASA box, I get a replay.

But if the ping comes from a computer, I keep getting: Deny inbound icmp src inside:XXX des inside:YYY (Type 8, code 0)

I have tried to make a NAT rule for this, but I cannot make a role src inside, drs inside

Can any one help me whit this?


Best regards.

Stig B.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
acomiskey Mon, 05/21/2007 - 04:44

No need for a nat rule or static route for this...just add the following

icmp permit any inside

mnetworks Mon, 05/21/2007 - 05:03


Sorry, doesn?t work.

ERROR: entry for address/mask = exists


acomiskey Mon, 05/21/2007 - 05:13

I think I misunderstood, what are you trying to ping from the inside computer? Another computer on the inside on a different network, or the ASA itself? Looks like you are trying to ping from machine on inside to another machine inside. This traffic is being routed to inside of ASA and it is denying it as by default it will not allow traffic to go in and out of same interface. You will need to add the "same-security-traffic permit intra-interface" command to allow that to happen.

mnetworks Mon, 05/21/2007 - 05:34

Thanks a lot.

Now I dont get the deny inbound error.

But I get a: Portmap translation creation failed for icmp src inside:xxx dst inside: xxx (type 8, code 0)

Do I need NAT for that?

mnetworks Mon, 05/21/2007 - 05:58

Thank you so much for your time and Knowles

But, it didn?t do the trick.

Do you have another idea?

acomiskey Mon, 05/21/2007 - 06:06

What error are you getting now? No translation group found...? Add the following...

static (inside,inside) netmask

= the computer you are trying to ping

acomiskey Mon, 05/21/2007 - 06:41

So to review you should have...

same-security-traffic permit intra-interface

global (inside) 1 interface

static (inside,inside) netmask

You could also do this for the whole network instead of just

static (inside,inside) netmask

mnetworks Mon, 05/21/2007 - 23:47


?same-security-traffic permit intra-interface? - Worked, but gave a new error.

(portmap translation creation faild for icmp src inside:XXX dst inside:YYY (type 8, code 0))

?global (inside) 1 interface? - Didn?t help on the new error

static (inside,inside) netmask - I have tried fowling:

static (inside,inside) netmask

static (inside,inside) netmask

static (inside,inside) netmask

But none of this works, and I still have the portmap problem?.

hoogen_82 Tue, 05/22/2007 - 01:03

Could you let us know about your scenario. I could possibly give you sample configuration which would work for your setup.


mnetworks Tue, 05/22/2007 - 01:26


My Cisco ASA 5510 box is going to be a new HQ firewall/VPN ? (HQN)

On the old HQ box (Cisco VPN3000), all of the VPN lines for the EU network is connected. ? (HQO)

At HQN there is a old Cisco Router whit a connection to HQO.

I?m going to move all of the VPN lines one-by-one, but keep the hole network up at the same time.

Before a start moving client computers and servers to the new HQN box (ASA), I want to be able to route traffic from ASA to the VPN3000 at HQN

A copy of my conf, see the Attachment

At The new HQ:



My problem is that fowling doesn?t work:

route LAN 1

route LAN 1

route LAN 1

route LAN 1

route LAN 1

route LAN 1

route LAN 1

I hope you understand me, because my English is not the best.


acomiskey Tue, 05/22/2007 - 04:40

Sorry, should have checked, this should do it.

no global (LAN) 1 interface

global (LAN) 200 interface

mnetworks Tue, 05/22/2007 - 05:14


The error message is gone now, but I don?t get any replay back.

I know the server I?m pinging is there, because when I?m using the as GW, there is no problem.

srue Tue, 05/22/2007 - 05:45

nat (inside) 1

global (outside) 1 interface

acomiskey Tue, 05/22/2007 - 05:53

srue, he is trying to hairpin inside, not pat to the outside.


Mind if we try something else?

no global (LAN) 200 interface

access-list LAN_nat0_outbound extended permit ip any

Then try to ping something on

mnetworks Tue, 05/22/2007 - 06:38

Sorry, no connection.

The log says:

6|May 22 2007 16:40:41|302021: Teardown ICMP connection for faddr gaddr laddr

On a computer, on the 192.168.168.x network I can ping


acomiskey Tue, 05/22/2007 - 06:45

Yes, you can ping from 192.168.168 to 192.168.163 because it is not being routed through the ASA. Maybe the problem is the return traffic from must be routed back to inside of ASA. As it stands now, the return traffic from the ping would not, it would be routed directly from to Maybe try to add a static route on 163.30 like this.

ip route

This would force the return traffic to inside of ASA.

acomiskey Tue, 05/22/2007 - 07:08

Another way to force traffic to the ASA would be to nat the traffic 192.168.163.x to 192.168.168.x like this.

access-list nat_to_168 extended permit ip

global (inside) 20 interface

nat (inside) 20 access-list nat_to_168

srue Wed, 05/23/2007 - 10:05

what kind of device is is this a router? multi layer switch?


This Discussion