CUOM 2.0 : CCM Partially Monitored state (WMI Authentication failure)

Unanswered Question
May 21st, 2007

Hi all,

I would appreciate so much your help on this matter I am facing so many troubles on.

I have an instance of CUOM 2.0 & Service Monitor installed on a WINdows 2003 SP1 Machine and trying to data collect a Cisco Call Manager (CCM, on WIN 2000 NT SP4).

I went to Devices/Device Managment and "Add Device", entering on the GUI the following credentials:

-Windows Credentials (windows administrator credentials)

- HTTP Credentials (CCM Admin credentials)

- SNMPv2c/SNMPv1 (SNMP V2 read and write credential)

But at the end of data collection, the device remains under Partially Monitored State ("WMI Authentication Failure").

This is the log I obtain

IP Address = 172.31.120.131

DNS Name = 172.31.120.131

Device Status = Partially Monitored

Device Type = Voice and Telephony

Aliases = N/A

Containments = N/A

OM Processing = Active

Ethernet Phone Port = Not Specified

Time Last Discovered = Mon 21-May-2007 19:36:35 CEST

Import Time Stamp = Tue 15-May-2007 23:23:22 CEST

*** Data Collector Status Information ***

Error Code = WMI Authentication Failure

Error Message = Success:Incorrect WMI Credential or Insufficient Priviledges

I have also tried to get inside the CCM WMI interface, and I am able to locally connect, and have also seen administrators group allowed to full read-write, remote execute and to all other tasks.

I do appreciate too much you help!

Cheers,

Leorob

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Joe Clarke Mon, 05/21/2007 - 11:18

You will first need to go to Device Management and, select "Modify/Delete Devices", choose your CCM, and click the Edit button. You need to fill in the WMI credentials under Windows Credentials fields. Pay close attention to the instructions on the page if you use a domain.

Finally, make sure TCP ports 135 and 445 are opened between CUOM and the CCM. These are needed for WMI.

Leonardo Roberto Tue, 05/22/2007 - 12:33

Dear Jclarke,

Thanks a lot for your prompt reply. I have checked both ports and they are open.

I reloaded devices as you said (CCMs aren't on a domain) but same result.

Could it be an interworking problem between Windows 2000 NT CCMs and Windows 2003 CUOM Server ?

Moreover, could it be a missing patch on CUOM 2.0 Server ?

I have installed CiscoWorks Common Services 3.0.4, Cisco Unified Operations Manager 2.0.0, Cisco Unified Service Monitor 2.0.0

Thanks a lot for your effort!

Leorob.

Joe Clarke Tue, 05/22/2007 - 12:58

I have not heard of a WMI bug that would explain this. Typically, the problem is just with missing or incorrect Windows credentials under Devices > Device Management > Modify/Delete Devices. I'd ask for an export and logs to verify, but these contain sensitive data, so it may be worth opening a TAC service request to continue this troubleshooting.

tcyee Wed, 06/06/2007 - 10:31

What information do we not get without WMI access and a server in a partially managed state?

Joe Clarke Wed, 06/06/2007 - 10:39

You will not be able to get any Perfmon counter stats from Partially Monitored devices. See the CUOM online help for more on what Perform stats are available.

sbrobak Wed, 07/11/2007 - 13:30

Have you managed to fix your issue. I have the same matter with CUOM 2.0 with Callmanager/communication manager 5.1.2

Error Code = WMI Authentication Failure

Error Message = Success:Incorrect WMI

It says that I only need to add the wmi for windows platform, but its an appliance so...

I have check all services are enabled at CCM.

Any ideas??

ruben.montes Wed, 07/18/2007 - 04:04

Hello,

I have exactly the same problem with CCM 5.1(2) and CUOM 2.0.

Can anybody that has this working please give any hint?

Thanks in advance,

Ruben

Tim Smith Thu, 01/10/2008 - 13:44

Hi...

Quick note on this one...

We had the same thing... and a restart does fix..

But also to avoid the restart you can just restart the 2 x WMI services from windows.

It did the same trick!

Cheers,

Tim.

Actions

This Discussion