Connecting 2 locations with 2 lines

Unanswered Question
May 21st, 2007
User Badges:
  • Silver, 250 points or more

Hi,

on Location A 3750 & on location B3com layer 3 switch, A & B are connected with two 2 Mbps leased line with ethernet output, now i wanted to load balance or i wanted to use a etherchannel kind of thing, so that even if 1 link goes, the other should still be up & running. how do i proceed.


3750------3com ---connected via ISP1

3750------3com ---connected via ISP2 to the same location. it is a point-to-point link.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Amit Singh Mon, 05/21/2007 - 20:49
User Badges:
  • Cisco Employee,

Anand,


I dont think so that the ISP's will aloow to do port channel the two links. My Idea for this would be to configure all the ports as L3 ports and run two static routes with the same admin distance and the Layer 3 switches will automatically load-balance across the two links.


If you want one link to be active and other to be standby, then use floating static routes and have one default route with higher admin distance added to the switches.


HTH,Please rate if it does.


-amit singh

Anand Narayana Mon, 05/21/2007 - 20:53
User Badges:
  • Silver, 250 points or more

Hi Amith,

thanks for the reply, as suggested by you i will use two static routes with the same admin distance.


ip route 192.168.1.0 255.255.255.0 gigabit 1/0/1

ip route 192.168.1.0 255.255.255.0 gigabit 1/0/2


this is the command your are referring am i right?


correct me if i am wrong


Amit Singh Mon, 05/21/2007 - 20:56
User Badges:
  • Cisco Employee,

Yes, You are correct.If you are configuring the links as L3 links, I would suggest you to set the next hop IP of each ISP in the default routes instead of gig interfaces.


HTH,

-amit singh

Anand Narayana Mon, 05/21/2007 - 20:58
User Badges:
  • Silver, 250 points or more

Thanks Amith,

certainly will do as you suggested, will let you know once i do this test by this evening(IST)

Amit Singh Mon, 05/21/2007 - 21:02
User Badges:
  • Cisco Employee,

Sure will wait for your feedback on the same :)

Anand Narayana Tue, 05/22/2007 - 23:18
User Badges:
  • Silver, 250 points or more

Hi Amith,

one of my colleague doesn't agree as what you suggested in configuring the same AD to same destination. he says that which ever command is issued last will be the primary link & only if primart goes he says the other will become active. can you suggest me in this regd.

Amit Singh Wed, 05/23/2007 - 00:23
User Badges:
  • Cisco Employee,

Hi Anand,


The switch will install both the routes in the routing table for your destination 192.168.1.0 and will show you both the interfaces under the " show ip route " command.If its has 2 paths to the same destination it will try to load-balance on it.


Do you have a spare switch to try the same. Please setup a lab and pass the traffic between the 2 switches and see the traffic on the interface.


Here is the one from my Lab :


The network is two routers connected by parallel serial links.

Cherry#sh runn

Building configuration...

Current configuration : 1557 bytes

!

hostname Cherry

!

interface Loopback44

ip address 192.168.200.1 255.255.255.0

!

interface Serial1/0

ip address 192.168.44.2 255.255.255.252

no fair-queue

!

interface Serial1/1

ip address 192.168.44.6 255.255.255.252

!

ip route 192.168.100.0 255.255.255.0 192.168.44.1

ip route 192.168.100.0 255.255.255.0 192.168.44.5

!

end

* There are two static routes to 192.168.100.0

* which is in the other router.

Cherry#sh ip ro

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

192.168.44.0/30 is subnetted, 2 subnets

C 192.168.44.4 is directly connected, Serial1/1

C 192.168.44.0 is directly connected, Serial1/0

C 192.168.200.0/24 is directly connected, Loopback44

S 192.168.100.0/24 [1/0] via 192.168.44.1

[1/0] via 192.168.44.5


* Both routes appear in the routing table because

* they have equal admin distance and metric.


Cherry#

Cherry#

Cherry#ping 192.168.100.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms

Cherry#

s=192.168.44.2 (local), d=192.168.100.1 (Serial1/0), totlen 100, fragment 0, fo 0, sending

s=192.168.100.1 (Serial1/0), d=192.168.44.2 (Serial1/0), totlen 100, fragment 0, fo 0, rcvd 3

s=192.168.44.6 (local), d=192.168.100.1 (Serial1/1), totlen 100, fragment 0, fo 0, sending

s=192.168.100.1 (Serial1/1), d=192.168.44.6 (Serial1/1), totlen 100, fragment 0, fo 0, rcvd 3

s=192.168.44.2 (local), d=192.168.100.1 (Serial1/0), totlen 100, fragment 0, fo 0, sending

s=192.168.100.1 (Serial1/0), d=192.168.44.2 (Serial1/0), totlen 100, fragment 0, fo 0, rcvd 3

s=192.168.44.6 (local), d=192.168.100.1 (Serial1/1), totlen 100, fragment 0, fo 0, sending

s=192.168.100.1 (Serial1/1), d=192.168.44.6 (Serial1/1), totlen 100, fragment 0, fo 0, rcvd 3

s=192.168.44.2 (local), d=192.168.100.1 (Serial1/0), totlen 100, fragment 0, fo 0, sending

s=192.168.100.1 (Serial1/0), d=192.168.44.2 (Serial1/0), totlen 100, fragment 0, fo 0, rcvd 3

* See how the pings are sent alternately on S1/0 and S1/1. The responses also

* come back on alternate routes because the other router has a similar config.

* This is call equal cost load sharing.


HTH,Please rate if it does.


-amit singh


Anand Narayana Thu, 05/24/2007 - 02:00
User Badges:
  • Silver, 250 points or more

Hi Amith,

i small info required again, with the same AD having to static routes to the same destinations , as u mentioned load balance will happen, but assume in a situation that i hav already connected to the remote end for a telnet or vnc session, now if one of the ISP failz, what will be the case, will the session get closed & do i need to re-open again?


Note: i was assumed that, two request will go via two links simultaneously for accessing telnet or vnc sessions.

Amit Singh Thu, 05/24/2007 - 02:07
User Badges:
  • Cisco Employee,

Hi Anand,


By default " per-destination" loadbalancing is enabled on the L3 devices. Which means that the traffic from same source to the same destination will always prefer the same link. If you have that situation in this case you will loose you connection to the server and you have re-initiate the connection to the remoe server again.


HTH,Please rate if it does.


-amit singh

Anand Narayana Thu, 05/24/2007 - 02:19
User Badges:
  • Silver, 250 points or more

Hi Amith,

i am sorry, not clear in what you say explain little bit brief?


if i am not wrong, you mean to say that by default it will rely on one link & if that link goes it will never shift automatically to the other link, am i right?

Amit Singh Thu, 05/24/2007 - 02:33
User Badges:
  • Cisco Employee,

Anand,


Let say that you are trying to reach Host A at Site A to Host B on Site B. You also have ISP1 and Isp2 links betwen the two sites. As "per destination" CEF load balancing is enabled by default, When ou initiate two sessions to the HOST B, they both will use the same ISP lets say ISP1 at the same time. As far as your destination of Host B is same, the router from Site A will always prefer the ISP1 link. and In case the ISP1 link goes down you will loose the connectivity and you have initiate the connection again to the HostB.


If you configure the CEF per-packet load-balancing, then router will try to load-balance on both the avialable links by per-packet behaviour. Incase one of the link fails, you dont have to re-initiate the connection in that case, if the application doesnot time out before the packet reaches the Host B from another link.


Hope I have made it clear enough.


HTH,Please rate if it does.


-amit singh

Anand Narayana Thu, 05/24/2007 - 02:50
User Badges:
  • Silver, 250 points or more

Hi Amith,

can you throw a configuration on this with the CEF, so that i can try & will let know?

Amit Singh Thu, 05/24/2007 - 03:02
User Badges:
  • Cisco Employee,

Hi Anand,


Unfortunately, Cat3750 does not support h/w CEF per-packet load balancing. h/w load balancing is based on hash of source/destination ip addresses. CEF per-packet load sharing is only supported for packets being switched in software. If the incoming packets have ip option then they'll be switched by 3750 in software and per-packet load balancing should work.


I woul not recommend you to disable the CEF for per-packet load-balancing and software switching might eat up a lot of CPU resources. You have to live only with per-destination load-balancing on 3750.


HTH,Please rate if it does.


-amit singh

Anand Narayana Thu, 05/24/2007 - 03:16
User Badges:
  • Silver, 250 points or more

Hi Amith,

any configuration is there related to this, so that i can go head in testing with this tonight in the network, otherwise i need to plan on some other day.

Amit Singh Thu, 05/24/2007 - 03:41
User Badges:
  • Cisco Employee,

Anand,


CEF is by default enabled on the 3750 switches.It only supports hardware per destination switching bydefault. If you want to configure it for sw per-packet load-balancing, try configuring " ip load-sharing per-packet " under the L3 interfaces.


HTH,

-amit singh

Actions

This Discussion