Historical Reporting login error

Unanswered Question
May 22nd, 2007

Hi experts,

I have a problem with IPCC 4.5(2) and Historical Reporting client. I can not login.

First step is authentication and there is no problem, but the HR client can't open database connection to db_cra.

Here is the error from log file:

1: 5/22/2007 7:40:34 PM %CHC-LOG_SUBFAC-3-UNK:Unsupported Language detected with LCID=1026

2: 5/22/2007 7:40:49 PM %CHC-LOG_SUBFAC-3-UNK:Database connection to 'CRA_DATABASE' failed due to ([Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user 'db_cra'.)

3: 5/22/2007 7:40:49 PM %CHC-LOG_SUBFAC-3-UNK:Database Connection Error | Failed to login to database. Ask your administrator to check the database user id and password that is dynamically obtained from the application server.

4: 5/22/2007 7:40:50 PM %CHC-LOG_SUBFAC-3-UNK:CRA_DATABASE Connection String: Provider=MSDASQL;APP=Cisco CRA Historical Reports3960;Persist Security Info=False;Trusted_Connection=No;DRIVER=SQL Server;UID=db_cra;PWD=*****;SERVER=\CRSSQL,4433;DATABASE=db_cra;NETWORK=dbmssocn;

5: 5/22/2007 7:40:50 PM %CHC-LOG_SUBFAC-3-UNK:Failed to login user to the apps server since we failed to initialize database connections

I think the database user have to be CiscoHistRprtUsr, but there is a negotiotion between HR client and database server and db_cra appears as DB user for DB connection.

If I change configuration in Config file at [CRA_DATABASE] section, then the HR client rewrite the config file back to original configuration:









My question is:

Can I use database user named db_cra for database connection and how to configure it at IPCC server? How to find the password for this user (log file says *****)?

I'm sorry for my english:)

Thank you

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (6 ratings)
ivillegas Mon, 05/28/2007 - 11:33

the language of your Operating System is what is preventing the HRC from running properly. The supported languages are






Simplified Chinese


Please change your OS language to one of these, and then uninstall and reinstall the Historical Reporting client.

tore.wennberg Mon, 07/09/2007 - 05:11


wwe have the same problem.

we also tried to change the language, but it did nor work.

does anybody have any clue of what the problem is ?



j-lock Tue, 07/24/2007 - 05:16


I had problem to log into Hist Report client because the proxy in IE was set (XP sp2).


villarrealed Thu, 08/30/2007 - 05:34

I ran into the same error after changing the SQL authentication method from Windows Only to Mixed Mode.

I resolved the issue by changing the Auth parameter from blank to 1 in the hrcConfig.ini file on each client.

Here is an extract from that file:

;AUTH specifies the authentication mode to use while connecting to the database.

;Use one of the following values:

;1 - Windows NT Authentication

;2 - Mixed Mode Authentication


bolz_icw_ Thu, 12/04/2008 - 02:19

You're great! You saved my life! ;-)

I run into the same problem and the configuration of the authentication mode did the trick.

Thanks a lot!



This Discussion