ACE Blade ANM 1.1 installation requirement : RHEL really needed

Unanswered Question
May 22nd, 2007


has anyone tried to install ANM 1.1 to manage the ACE Blades on anything other than red hat enterprise 4.

I tried yesterday on Centos (the free RHEL) and I got a strange error while running the installer. (something about beeing unable to read from `33'.)

Also, it was on a VMWARE image, so that might be an issue too.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
cajalat Thu, 05/24/2007 - 04:26

I have my ANM running on RHEL 4 32bit per Cisco's recommendation but inside a VMWARE instance. I ran into problems (read '33' error) installing ANM even on other flavors of Linux including RHEL 4 that were 64bit (RHEL 5, RHEL 4, Mandriva 2007). During the installation of ANM additional packages are installed and in some cases override other installed packages. Cisco seems to use 32bit version of code for their included package which is what I think causes problems.

I haven't tried the install on 32bit Linux since RHEL 4 but it might be worth a try.


cajalat Thu, 05/24/2007 - 05:45

I switched to RHEL 4, 32bit. Cisco wouldn't support me on fixing this issue unless I switched to the supported platform. I'm about to attempt this on Mandriva 2007 32 bit to see if I can get past the binary incompatibility as I prefer to use my preferred distro of Linux and not be wedded to RHEL.


dkirsch Fri, 10/12/2007 - 14:33

While not supported (by TAC / Cisco) we know of instances of users running ANM 1.1 within VMWare but it does require use of 32-bit RHEL 4.2 or 4.5. Moving it into the VMWare doesn't change the base OS requirement.


lanstreamer Tue, 03/11/2008 - 12:17

Anyone had any luck getting ANM 1.2 to run in Centos 4.5 32-bit in or out of VMWARE?

How about SLES10 32-bit?


dkirsch Tue, 03/11/2008 - 14:22

ANM 1.2 is only supported on RHEL 32-bit 4.2/4.5. It is not supported on Centos nor SLES.


David K.

lanstreamer Wed, 03/12/2008 - 03:07

Thanks - I can read that from the release notes but what I really want to know is has anyone got it to work on other platforms before I spend time giving it a go?

dkirsch Wed, 03/12/2008 - 08:52

The install scripts are going to give you hassles, as well as figuring out which RPMs to have lined up. Depending on your particular CENTOS build you might be able to figure it bit by bit, but there is no guidance written out anywhere on what is in, what is out, which to use. I suspect it would be a somewhat messy process -- If you really wanted to do it (unsupported but you wanted to anyway) then reverse engineering from a RHEL install setup is how I'd go about it. Even then, and while ANM is pretty well behaved, I don't know if there's a variation in something underlying that won't bite you down the road.

Of course if someone else did this already and is having success, that'd be good to know too.

Mind you I'm speaking as the product manager for ANM so my response is of course going to be stilted to the supported.


David K.

lionellemaire Wed, 03/12/2008 - 10:10

isn't there a free, demo version redhat that would be compatible with ANM ?

dkirsch Wed, 03/12/2008 - 10:19

Yes, anyone can get a 30-day Unsupported Evaluation Red Hat Enterprise Linux (Up to 2 Sockets) at:

The default sets you up to download RHEL 5.0, but once you have your evaluation subscription, you can just download the RHEL4 release 5.

oemabry Thu, 03/20/2008 - 15:18

I am installing ANM 1.2 on Redhat Enterprise 4 and Fedora 6 in VMware. I was wondering is there a list of rpms needed for the installation?

allan.ross Wed, 06/04/2008 - 09:25

I have it working CentOS 4.6, ANM 1.2 running on a windows hyperv vm. It has been up for 12 days now with no issues. I actually built it on my vista Virtual PC 2007 vm first and then moved it to hyperv.

allan.ross Fri, 08/21/2009 - 09:20

Just install Centos and follow the install guide from Cisco. It has been awhile since I did this, but I believe that there is a RPM that will need to be installed before the ANM install will complete with success. Just google the error you get on the first install attempt and that will tell you what RPM you need.

Remember, this is not supported by Cisco so you will be on your own to make it and keep it working.

I have not tried the lastest version. I will give it a run next week and post my results.


This Discussion