Multicasting - no RP assignment of multicast range

Unanswered Question
May 23rd, 2007

Hi,

Trying to run multicast (PIM-sparse-dense) over a LES100 connection, but though I have an IP PIM neighborship establised across it both ways, I do not see the PIM-Group to RP mappings at the far end. The same configurations have been applied to numerous LES1000 (not LES100) circuits with no issues, with the only exception of a Layer 2 only (Catalyst 2940)terminating the LES100 circuit.

I haven't exceeded my TTL boundary.

Any ideas what I should look for?

Thanks in advance

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Wed, 05/23/2007 - 06:16

You should look for RPF (Reverse Path Forwarding) failures between the mapping agent and the affected device.

'show ip mroute count' should indicate for any RPF failures.

From your diagram, I can't tell how the unicast routing looks like.

You can also enable debugging against mpacket on the 4500 and 3560.

'debug ip mpacket'

paul-giles Thu, 05/24/2007 - 06:12

Thanks for your comments.

Carrying out a debug ip mpacket on the 4500, I see it reports "not rpf interface" for the loopback of the RP, 147.184.15.244

May 24 13:45:18: IP(0): s=147.184.15.244 (Loopback0) d=224.0.1.40 id=49391, ttl=28, prot=17, len=48(48), not RPF interface

however the rpf check from the 4500 and traceroute look OK.

4500#sh ip rpf 147.184.15.244

RPF information for stvndcc02.ggr.co.uk (147.184.15.244)

RPF interface: GigabitEthernet3/1

RPF neighbor: ? (147.184.53.21)

RPF route/mask: 147.184.15.244/32

RPF type: unicast (ospf 11000)

RPF recursion count: 0

Doing distance-preferred lookups across tables

Type escape sequence to abort.

Tracing the route to stvndcc02.ggr.co.uk (147.184.15.244)

1 147.184.53.21 4 msec 0 msec 4 msec

2 147.184.53.10 0 msec 4 msec 0 msec

3 147.184.53.30 0 msec * 0 msec

What could be causing the "not rpf interface"?

Harold Ritter Thu, 05/24/2007 - 07:49

Paul,

Is PIM configured on the loopback interface? If not, this could be the issue.

Hope this helps,

paul-giles Fri, 05/25/2007 - 04:52

Hi - Here are the configurations.

3560

!

interface Loopback0

ip address 139.136.4.246 255.255.255.255

ip pim sparse-dense-mode

!

4500

!

interface Loopback0

ip address 147.184.53.250 255.255.255.255

ip pim sparse-dense-mode

!

One of the downstream RP Switches which is not shown in the diagram.

6500

!

interface Loopback0

ip address 147.184.15.246 255.255.255.255

ip pim sparse-dense-mode

ip multicast ttl-threshold 32

ip multicast boundary 20

ip ospf cost 2

logging event link-status

!

access-list 20 permit 224.0.1.39

access-list 20 permit 224.0.1.40

access-list 20 permit 239.192.0.0 0.0.255.255

!

As you can see, we set a site boundary and TTL scoping for this MAN.

Edison Ortiz Fri, 05/25/2007 - 06:42

Every device on the path has PIM enabled on their interfaces ?

I'm referring to this path:

1 147.184.53.21 4 msec 0 msec 4 msec

2 147.184.53.10 0 msec 4 msec 0 msec

3 147.184.53.30 0 msec * 0 msec

Also, ip multicast-routing in the global config ?

paul-giles Fri, 05/25/2007 - 07:14

Hi - All L3 interfaces have ip pim sparse-dense-mode configured and multicast is globally configured.

Actions

This Discussion