Unity 4.0(3) install fails with 3.0 error

Answered Question
May 23rd, 2007

I'm installing Unity 4.0(3) with an off-box Exchange server. When I try to install Unity on the Unity server, I double click the language, click Next, then I get a "Setup can not upgrade from a version older than 3.0" error. This is a lab setup, but what did I do wrong on this one? I'm using the UnityInstall account to install it. the account was not a member of the Domain Admins group, so I put it there but still the same problem. It doesn't matter what account I use, I get the same error. Thanks for any help.

I have this problem too.
0 votes
Correct Answer by neesharm about 9 years 6 months ago

looks like we did not really do a clean install(delete partition and format) but just inserted the Windows OS CD and this just re-copy the system files and which does not wipe out the registry.

This can be fixed using following options

1.Download the unity uninstall utility from www.ciscounitytools.com and clean uninstall unity and try again

2 delete following key from registry HKLM/Active voice. Also delete "commserver" folder and in AD, delete the Unity folder,reboot and try again

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
neesharm Wed, 05/23/2007 - 22:33

looks like we did not really do a clean install(delete partition and format) but just inserted the Windows OS CD and this just re-copy the system files and which does not wipe out the registry.

This can be fixed using following options

1.Download the unity uninstall utility from www.ciscounitytools.com and clean uninstall unity and try again

2 delete following key from registry HKLM/Active voice. Also delete "commserver" folder and in AD, delete the Unity folder,reboot and try again

d.anthony.hadley_2 Thu, 05/24/2007 - 08:32

Thanks. That was it. I did not do a clean install of Windows. However, the Uninstall wouldn't run, kept giving me errors about version 2.x, but I did delete the folders/reg key you suggested and was able to install Unity. All is working now. Thanks.

Actions

This Discussion