VoIP and VLANs on Cisco switches

Unanswered Question
May 23rd, 2007
User Badges:

I need assistance configuring two Cisco 2950 24-port switches for a VoIP phone system utilizing 2 VLANs.


Our current configuration is partially managed by Verizon. The two managed devices are a Cisco 2811 router and a PIX 501 firewall. For data, port 2 on the Cisco switch is connected to port 0 on the router. For voice, the PIX is connected to port 1 on the router and port 1 on the switch. Ports 3 - 23 are connected to a Polycom VoIP phone, which are then connected to a computer. Due to its length I?ll attach the running-config to this message.


While everything functions in this configuration and setup, a problem we are experiencing is with our file server that is also a DHCP server. When connecting the server to a port on the Cisco that is only using VLAN 1, all the phones are assigned an IP address by the server instead of the PIX. The remedy was to place the server on another switch connected to the VLAN 1 port 24 on the Cisco switch, then the phones obtained their IPs from the PIX. This isn?t a large problem but our office is expanding soon and we?ve purchased an identical Cisco switch that also needs to be configured to use VLANs. As such I would prefer to place the server on the Cisco switches so I can remove all unnecessary hardware and simplify the network.


In an attempt to configure the new switch to make it ready to become part of the network I connected it the old switches VLAN 1 port 24 to the new Cisco switch connected to the HP switch which is connected to the file server, and then configured the new switch with similar settings as the old Cisco switch. Soon after setting up the Voice VLAN 10 on the new switch and assigning ?switchport voice vlan 10? to the first few ports, many of the Polycom phones obtained IP addresses from the file server again.


Any assistance that could be offered to help me sort out and configure both switches so that this problem is resolved will be much appreciated.


Attached is the old Cisco switch running-config and VLAN settings.



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cozmicone Thu, 06/14/2007 - 12:00
User Badges:

Sorry about the delay in a response, I?ve had to wait until our office was empty before I made any changes that could possibly impact our phone service.


The ip helper did the trick. I am able to put the file server on the switch with the rest of the network and the phones are being assigned ip addresses by the PIX now. =^ )


Which now leads to a new issue. When I connect the switches to each other they don?t communicate as the ports don?t light up. What other change(s) do I need to make to the switches?


On a related/unrelated issue, as we?re a PIP network the PIX prevents us from having the phones obtain the current date and time because the PIX firewall prevents SNTP communication with the web. Is there a way around this?

spanlink Mon, 06/18/2007 - 13:47
User Badges:

Make sure you're using a crossover cable between the switches (both layer 2).


On the PIX issue, there are a few things you can do:

-have the phones get date/time from internal source

-open up a hole in your firewall for SNTP traffic.

cozmicone Tue, 06/26/2007 - 07:46
User Badges:

Using a crossover cable solved the problem.


The PIX is managed by Verizon, so I?ll request for them to open a port for SNTP traffic. I?ve tried to assign the phones to an internal SNTP server but the phones get assigned an external SNTP server by the PIX when they are assigned an IP address which overrides a manually assigned SNTP address.

ardenchen Thu, 05/24/2007 - 11:11
User Badges:

I guess your file server supports trunk mode and then working on it with your cisco switch by default. try put 'switchport mode access' on the interface connecting to your file server.



maskmukesh Thu, 05/24/2007 - 11:14
User Badges:

Hi,


here, can u tell me that whether IP phone and systems both are on DHCP.


If yes then on vlan interface u need to specify the helper address which will be used to check which dhcp to poll.


regards


Mukesh

cozmicone Thu, 06/14/2007 - 12:01
User Badges:

This worked. See my reply above to spanlink for the follow up reply.

Actions

This Discussion