setting up cisco AP

Unanswered Question
May 23rd, 2007

Hi all, can anyone tell me how i would set up a cisco ap so it has a managaement addresss, say in my vlan 1, but i want to have the users on another vlan via the ap and to recieve dhcp,how do i make that the management ip is in vlan 1 on the ap? and do i create a ssid to vlan mapping on it? also does the ap have a function with forwards the dhcp broadcasts, or is this done on my layer 3 switch ?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
a-vazquez Wed, 05/30/2007 - 07:04

When you configure the access point as a DHCP server, it assigns IP addresses to devices on its subnet. The devices communicate with other devices on the subnet but not beyond it. If data needs to be passed beyond the subnet, you must assign a default router. The IP address of the default router should be on the same subnet as the access point configured as the DHCP server."

You need to configure the switchport that the AP is connected to as a trunk and allow any vlans you need users to be on on that trunk. Then you can associate an SSID to a specific vlan. I currently do this and it works flawlessly. This is my config on one of my AP ports on the switch:

interface GigabitEthernet2/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 68

switchport trunk allowed vlan 64,65,68

switchport mode trunk

switchport nonegotiate

switchport voice vlan 68

service-policy output autoqos-voip-policy

qos trust cos

udld port aggressive

auto qos voip trust

tx-queue 3

priority high

shape percent 33

spanning-tree guard root

You will need to use 'ip helper-address x.x.x.x' to configure your AP to allow DHCP through it on other vlans besides the one that your DHCP server is on.

Actions

This Discussion