Redistributing EIGRP to BGP

Unanswered Question
May 24th, 2007
User Badges:

hi guys,

How can i limit my redistribution from eigrp to BGP to only /24 networks? when i redistribute eigrp routes to bgp, /32 and /30 networks are also advertise unto bgp. i don't want this to happen, just want only /24 to be advertise by bgp. Doing some lab scenario.


CRtr<->EIGRP<->GWRtr<-BGP->ISP



tnx.


jeff


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mohammedmahmoud Thu, 05/24/2007 - 00:34
User Badges:
  • Green, 3000 points or more

Hi,


Use a route-map when doing redistribution to filter unwanted routes, or just permit desired routes.



HTH, please do rate all helpful replies,

Mohammed Mahmoud.

jeffbriones Thu, 05/24/2007 - 01:08
User Badges:

Hi Mohammed,

Where will i put my filter? I tried putting it under bgp process but still advertises my /30 networks to my ebgp peer.


router bgp 100

redistribute eigrp 10 metric 0 route-map FILTER


FILTER - /24 networks


tia.

mohammedmahmoud Thu, 05/24/2007 - 01:36
User Badges:
  • Green, 3000 points or more

Hi,


Yes, you are placing it correctly, but what is the configuration under the route-map Filter ?



BR,

Mohammed Mahmoud.

jeffbriones Thu, 05/24/2007 - 02:52
User Badges:

Hi,


Here's the configuration im trying to simulate.


RouterC ---EIGRP RouterA --- BGP ISP


Router C

interface Serial0/0

ip address 10.10.10.2 255.255.255.252

clock rate 128000

no fair-queue


router eigrp 10

redistribute static

network 10.10.10.0 0.0.0.255

network 10.10.20.0 0.0.0.255

distribute-list 1 out

no auto-summary

!

ip route 10.10.30.0 255.255.255.0 Null0

ip route 10.10.40.0 255.255.255.0 Null0

ip route 10.10.50.0 255.255.255.0 Null0

!


RouterA

interface Serial2/0

ip address 100.100.100.2 255.255.255.252

!

interface Serial2/1

ip address 10.10.10.1 255.255.255.252


router bgp 100

no synchronization

bgp log-neighbor-changes

redistribute eigrp 10 metric 10 route-map OUT

neighbor 100.100.100.1 remote-as 200

neighbor 100.100.100.1 route-map OUT out

no auto-summary

!

no ip http server

ip classless

ip route 10.10.10.0 255.255.255.0 Null0

!

!

access-list 1 permit 10.10.20.0 0.0.0.255

access-list 1 permit 10.10.30.0 0.0.0.255

access-list 1 permit 10.10.40.0 0.0.0.255

access-list 1 permit 10.10.50.0 0.0.0.255

access-list 1 permit 10.10.10.0 0.0.0.255

route-map OUT permit 10

match ip address 1


I even put route-map on my bgp advertisement but still i can see /30.


Tnx.



bjornarsb Thu, 05/24/2007 - 03:08
User Badges:
  • Bronze, 100 points or more

Hi,


I would strongly recomend that when configuring BGP in this way you should use prefix lists instead :)


neighbor 20.20.20.20 prefix-list ABC out


ip prefix-list ABC seq 5 permit x.x.x.x/0




Please check the scroll-down box at the bottom rigth on every helpfull post :)


BR,

Bjornarsb



mohammedmahmoud Thu, 05/24/2007 - 03:10
User Badges:
  • Green, 3000 points or more

Hi,


Ok, here it is the problem, the standard access list looks at the network address only and can not check the length of the network mask in this scenario.


Here you are an example from one of the Cisco CCO documents:


To permit only the supernet 10.10.0.0/19, use an extended access list, such as access-list 101 permit ip 10.10.0.0 0.0.0.0 255.255.224.0 0.0.0.0.


Accordingly you'll have to use extended ACL in this manner or use prefix-lists which i would recommend.


http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00801310cb.shtml


HTH, please do rate all helpful replies using the scroll box on the right,

Mohammed Mahmoud.

bjornarsb Thu, 05/24/2007 - 03:10
User Badges:
  • Bronze, 100 points or more

So to your case, depending on how you have configured acl 1 on router C,

you will still see /30 on router A

because /30 is more spesific than /24.


BR,

Bjornarsb

guruprasadr Thu, 05/24/2007 - 03:19
User Badges:
  • Gold, 750 points or more

HI Jeff,


Use Prefix-list / Distribution-list when routing limited subnets in some protocols


distribution list:

access-list 10 permit 10.1.1.0 255.0.0.0

access-list 10 deny any

router bgp

distribution list 10 out/in


Prefix-list is also an better option for filtering.


Pls Rate if Helps ! !


Best Regards,

Guru Prasad R



John Patrick Lopez Thu, 05/24/2007 - 14:47
User Badges:

Change your ACL to prefix list.


ip prefix-list ABC seq 5 permit 10.10.10.0/24

ip prefix-list ABC seq 10 permit 10.20.10.0/24

ip prefix-list ABC seq 20 permit 10.30.10.0/24

ip prefix-list ABC seq 30 permit 10.40.10.0/24

ip prefix-list ABC seq 40 permit 10.50.10.0/24


Then change your route-map to prefix-list to.


route-map Out permit 5

match ip address prefix-list ABC


HTH,

John

autobot130 Thu, 05/24/2007 - 16:47
User Badges:

Spare yourself the time in writing a long ACL if you have SEVERAL networks by using the command below. Thats only if the prefix-list may end up to be long... this may be easier.


ip prefix-list MYLIST seq 5 permit 10.0.0.0/8 ge 24 le 24


or


ip prefix-list MYLIST seq 5 permit 192.168.0.0/16 ge 24 le 24

jeffbriones Fri, 05/25/2007 - 18:26
User Badges:

Hi guys,

Using ip prefix-list works on my advertisement. I tried redistributing my bgp routes to eigrp for my internal network to see the internet, it doesnt seem to work. How will my network on RouterC learn routes from my bgp?


tnx.





jeffbriones Fri, 05/25/2007 - 19:24
User Badges:

Hi guys,

My redistribution is working right now. When redistributing learned routes from bgp, can i see them on my routing table? I tried sh ip route on my router C and i cant see them.


tnx.



mohammedmahmoud Sat, 05/26/2007 - 00:18
User Badges:
  • Green, 3000 points or more

Hi Jeff,


I am glade that you have it working, when showing the ip route on a router doing redistribution the routes shall appear belonging to the original protocol, not the protocol that they are redistributed into.



HTH, please do rate all helpful replies using the scroll box on the right,

Mohammed Mahmoud.

Actions

This Discussion