Music On Hold problem PSTN>H323GATEWAY>IP

Unanswered Question

Hello everybody.

I have a problem in all the IP phones when I receive a call from PSTN and leave the call on hold, I hear TONE instead MOH. When I make a call from IP phones to PSTN and the call is leave on hold I hear MOH work fine.


The CallManager version is 4.2(3) and h323 gateway Cisco 2821.


I follow the instructions on this document but I continue with the problem.


Any help will be apreciated


Regards

Walter Flores



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
espereir Thu, 05/24/2007 - 10:43

Hello,


Please go to Service >> Service Parameter >> Select the server that has the MOH configured >> Select the Cisco IP voice Media Streaming App service and make sure that you have G711 and G729 selected under MoH configuration. This normally happens when the gateway codec is different so this way the CIPVMSA service will have all the codec for MoH.


By the way, you will need to restart that service in order to apply the settings.


Also, go to the Common Profile of the phone and make sure that you have the right MoH source for the User and Network MoH options.

thisisshanky Mon, 05/28/2007 - 09:55

Walter,


Are you using Multicast or Unicast. Make sure the gateway or the devicepool of the gateway has MRGL that has access to an MOH server. (MRG in the MRGL should have one MOH server for a min. listed).


If using multicast, make sure multicasting is enabled in all equipment between CM (MOH server) and the PSTN gateway. This includes enabling Multicast routing and PIM on the ethernet interface of the PSTN router. Also you should have the command ccm-manager music-on-hold.


HTH


Sankar


PS: please remember to rate posts!

I?m using unicast.

I have inside Media Resource Group MRG the MOH server 10.1.9.201 the same CallManager

and inside MRGL apply to Device Pool to all the devices.

The MOH works fine if I make the call from IP>PSTN but backwards does not work I jus hear ToH.


I applied the command

ccm-manager music-on-hold even I tried to appy bind gigaethernet 0/0 where the gateway knows the Callmanager it does not work.


Take for time

Regards

Walter Flores

espereir Mon, 05/28/2007 - 14:23

Hey Walter,


Please make sure that you have an MTP and a XCODE inside that MRG (the same MRG for the MOH server on the GW), this is because when you place someone on hold, CCM will look for a MoH source/server and an MTP in order to hold the voice leg.


Also notice that MTPs extend supplementary services, such as call hold, call transfer, call park, and conferencing, that are otherwise not available when a call is routed to an H.323 endpoint. Some H.323 gateways may require that calls use an MTP to enable supplementary call services, but normally, Cisco IOS gateways do not.


So my advise will be to add the MTP to the MRG and reset the gateway, if this does not fix the problem, please check the "Media Termination Point Required" box on the GW confiig page in CCM, update and reset the GW, please do a test during non production hours since this will impact the inbound/outbound calls, by the way, sometimes, it this parameter is enabled, it will drop any inbound/outbound calls so if you face this problem, please uncheck this parameters.


Further information about MTPs can be located at:

http://www.cisco.com/en/US/partner/products/sw/voicesw/ps556/products_administration_guide_chapter09186a00803edada.html#wp1030050


Please let us know how it goes!!!

Hi Espereir

I already have configured as you told me.

I solve the issue on service>MOH Sever I enabled with the codec g711alaw and then into h323_gateway on the dial-peer voip which sends the call to the CCM I forced the codec to g711alaw also now the MOH is working fine.


Thank very much guys for your time.


Regards

Walter Flores

simranjeet.singh Thu, 06/26/2008 - 22:54

Hi Walter


Thanks a lot for your post ..

I had the same problem and it got solved by changing the codec to g711 alaw


regards

simranjeet

Actions

This Discussion