30-40 seconds complete loss of all network activity

Unanswered Question
May 24th, 2007

sporadically and at least 5-8 times a day, using Cisco Network Assistant and bandwidth monitor/resource monitor, I see 30-40 seconds of 0 resource and 0 bandwidth across all 8 of my switches.

I have

2 Catalyst 2950G-48

1 Catalyst 3524-XL

2 Catalyst 3512-XL

1 Catalyst 3508G-XL

3 Catalyst WS-C2948

the WS-C2948 are running CatOS 4.5(3)

the rest are running Cisco IOS 12.0(5.2)XU

There are no segregations, DHCP is handled by a Windows 2000 server, only the default VLAN on all switches.

I'm looking for some direction of where to start looking for the cause of this issue.

I apologize for what I am sure is no where near the amount of information you need. Please ask me what is needed and I will provide it.

thank you.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
John Patrick Lopez Thu, 05/24/2007 - 14:54

Can you please check if there are any redundant path that causes STP loop? A loop in a layer 2 network can really cause your network to flap. Enable bpdu-guard on all access-ports except trunk.

-John

jesusdamian Thu, 05/24/2007 - 15:16

yes, I read an article on the Cisco site about STP loops.

I also read that a convergence takes an average of 30-40 seconds to complete, which is on par with what we experience.

at this point, they dont have it enabled, but I cant make any changes until the end of next week due to scheduling issues.

anything else you can suggest?

John Patrick Lopez Thu, 05/24/2007 - 15:52

Wait. Is there someone in your group who turned spanning-tree off? Spanning-tree is enabled by default. Except if you guys enabled spanning-tree portfast on all ports and created a loop. Extra care should be practiced when enabling this feature.

Also, during downtime, check your logs immediately. and see what's causing the downtime. You can also check show spanning-tree to see the state of the ports if it is in listening or learning state. Each of those timers are 15 seconds.

But you are not having problem with your routing and your routers right?

HTH,

John

jesusdamian Thu, 05/24/2007 - 16:16

Portfast is disabled on all ports, spanning tree is enabled.

and no issues at all with the routers

glen.grant Thu, 05/24/2007 - 17:31

Portfast should be turned on user ports and off for any connecting links to routers or other switches .Portfast does not turn off spanning tree it just does away with a couple of the stp states so that user ports come up faster. I would check all connecting links sounds like you may have one that is occasionally flapping which will cause spanning tree to run . check for errors across these links . This page might help http://cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a0080094797.shtml

jesusdamian Thu, 05/24/2007 - 19:09

its comforting to know I'm on the right track with this issue.

As soon as we can schedule the downtime, I'm going to enable portfast on all user ports along with a few other configuration changes.

thanks for the info, I just wanted a second opinion on this issue.

Actions

This Discussion